PDA

Afficher la version complète : [Réglé] [Réglé] Installation ut2004 version dvd



magicpixel
15/03/2005, 01h23
Bonjour

J'ai encore un probleme pour ne pas changé
J'ai la version DVD de UT2004 et j'ai voulu l'installer à partir d'un lecteur de DVD
La fenetre d'instalation s'ouvre je rentre mon numero de série et apres un chargement il me demande l'autre cd j'ai beau mettre ok il ne veut rien savoir
Curieux comme probleme et je ne sais pas comment le resoudre
J'ai la suse 9.2 pro
Merci à tous
ps: dsl de vous embeter encore

magicpixel
15/03/2005, 10h33
Meme une ptite idée je suis preneur
Merci

magicpixel
18/03/2005, 11h45
J'ai trouver un lien qui explique mon probleme mais je n'est pas su le resoudre en me servant de la console
www.slyunix.org/astuce/astuce.php?a_id=168

Merci beaucoup
a+

Diablo150
09/04/2005, 15h07
Originally posted by magicpixel@vendredi 18 mars 2005 à 10:45
J'ai trouver un lien qui explique mon probleme mais je n'est pas su le resoudre en me servant de la console
www.slyunix.org/astuce/astuce.php?a_id=168

Merci beaucoup
a+
<div align='right'><{POST_SNAPBACK}> (index.php?act=findpost&pid=26837)[/quote]


J' ai eut le meme probleme, plusieurs fois, mais un beau jour j' ai trouvé, et c' est tout une procédure a faire pour que sa se déroule nickel:
-Ouvre un terminal en root
-Lance l' installation
-Lance l' installation, si sa pose probleme lors du transfert des fichiers, (montage du dvd), edite /etc/mtab
Et dans le fichier, a la place de subfs, met auto pour le lecteur dvd.

Peut etre que tu devra demonter/remonter ton lecteur dvd.

Et apres, continu l' installation normalement, et modifi mtab pour revenir comme il etait avant :-)

magicpixel
09/04/2005, 19h13
Merci j'eassaierai demain en esperant que j'y parviennes
A+

ryo_san
18/04/2005, 02h22
salut

si ca marche pas il suffit de copier le script d install sur ton disque dur et de le lancer...
les problemes viennent souvent du fait que l'ancien repretoire de montage etait /mnt , il vaut mieux parfois monter manuellement le cdrom ou dvdrom dedans.

alexmic
21/04/2005, 12h36
Exact j'ai eu le mm pb avec les cd
umount /media/cderecorder
mount /dev/cdrom /mnt/cdrom

alexmic
27/04/2005, 16h05
dans ton cas ce serait /mnt/dvdrom

Deusexodus
27/04/2005, 17h10
Sinon peux-tu nous dire les dossier qu'il y a dans ton dossier /mnt/ parce que si on sait pas sa on pourra pas avancer !

@+

Sirius
27/04/2005, 18h43
Si le CD est piraté, ca va pas marcher... mais avec l'original, pas de problème (Sirius a testé pour vous http://www.alionet.org/style_emoticons/<#EMO_DIR#>/w00t.gif )

magicpixel
27/04/2005, 21h00
Salut

Le jeu c'est l'original achete neuf donc pas de sousis pour sa
sinon dans le dossier /mnt/ j'ai rien du tout j'ai regarder via le poste de travail j'ai cliquer sur le fichier rouge est j'ai cliquer sur mnt mais j'ai rien c normal ?
Merci de votre aide
A+

Deusexodus
27/04/2005, 22h33
C'est peut etre de la que vient le probleme !

Je crois que sous suse tes lecteurs sont dans /media mais je suis pas sur , tu veux bien verifier ?

Si c'est sa change ton /mnt/dvdrom par /media/XXX

Sa sera mieux deja !

@+

magicpixel
27/04/2005, 22h59
Salut

Deja je tiens a te remercier te te preoccuper de mon probleme je rapelle que je suis debutant sous linux
BOn pour verifier je fait comment stp ?
Et pour changer au cas ou je vais ou stp ?
Sa fait plaisir de se sentir aider comme sa je vais peut etre pouvoir y jouer a ce jeu un jou sous ma suse et virer xp d'un ou deux pc lol
Merci

A+

edit : pour changer faut renomer ?

Deusexodus
28/04/2005, 08h46
Ben avec konqueror tu fouille les dossier et tu regarde si dans /media y a des dossier ( comme tu as fait avec /mnt ) et la manip que t'as fait tu remplace toutes les occurences de /mnt/cdrecorder par le dossier contenant l'image du dvd d'installation !

Avant si tu montais ou demontais un dossier qui n'existais pas il a du te dire qu'il trouvais pas sa dans le fichier /etc/fstab , nan ?

Sinon tu fait dans la konsole :
#less /etc/fstab

Que l'on puisse voir ou sont t'es dossier sans fouiller partout !

De rien pour l'aide et on va continuer jusqu'a se que tu y arrive , nomdidiou ! http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif

@+

magicpixel
28/04/2005, 09h29
Salut

Deja merci c super sympas

Et bien lorsque je monte ou demonte je le fesait de cette facon
Dans le terminal en root :
mount /dev/cdrecorder (sur mon portable )
et le terminal me relancer la main à l'invite pas de message d'erreur

Par contre j'ai taper cela dans le terminal :

less /etc/fstab

et j'ai cela :

/dev/cdrecorder /media/cdrecorder subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=ut f8 0 0

Vola biensur j'ai pas tout reecrit mais seulemement la ligne sur le cd rom si il faut tout ecrire je le ferais

Merci

Deusexodus
28/04/2005, 09h53
Deux solutions :
Soit la methode de slunyx soit la normal je te met les deux et tu essais ! Au fait est tu sur que ton cdrecorder lis les dvd ?

tu ouvre un terminal ( konsole ) et tu tape :
#mount /media/cdrecorder ( si il te dis que c'est deja fait c'est bon sinon il valancer ton cd )

en suite met toi en root ( l'installation est obligatoirement en root ! )
#su
password :

#sh /media/cdrecorder/linux-installer.sh
Il y a une demande faut mettre accepter et on se retrouve avec sa :
http://img246.echo.cx/img246/8290/ut20046eo.th.jpg (http://img246.echo.cx/my.php?image=ut20046eo.jpg)

Si tu as sa l'installation se fera si tu as 5.5 Go de place et si tu coche SDL12 and OpenAL .... et que tu met french ( histoire de comprendre un peux se qu'il te dis ) et si tu as assez de place la ou tu veux installer in te laissera selectionner Begin Install !

Sinon on s'attaque a la maniere slunyx : je te met se que tu dois taper :

$ cp /media/cdrecorder/linux-installer.sh /home/<nom_de_ton_utilisateur>

En tant que root, arrêtez le mécanisme de supermount (Mandrake), démontez votre DVD (toutes distribs) :
$ su
password :
# supermount disable
# umount /media/cdrecorder

Nous allons créer un point de montage temporaire pour le DVD, puis nous allons faire un lien entre le répertoire CD1 du DVD et l'ancien point de montage cdrom :
# cd /media ; mkdir tmpdvd
# rm -rf cdrecorder
# mount -r /dev/cdrom /media/tmpdvd
# ln -s /media/tmpdvd/CD1/ cdrecorder

Sortez du mode root si vous souhaitez installer UT2004 pour vous, et lancez l'installation depuis le fichier recopié dans l'étape 1 et là ça va marcher !
# exit
$ sh /home/<nom_de_ton_utilisateur>/linux-installer.sh

Quand l'installation est terminée, il faut tout remettre en état.
# su
password :
# cd /media
# umount /media/tmpdvd
# rm -rf cdrecorder ; rm -rf tmpdvd
# mkdir cdrecorder ; mount /media/cdrecorder
# supermount enable

Voila : je te conseille la premiere solution la deuxieme est un peut tirer par les cheveux et tu l'essaiera si tu n'arrive pas la premiere !

Voila bonne chance et dis moi si il y a quelque chose qui marche pas !

@+

magicpixel
28/04/2005, 10h28
Merci pour tout

Je vais essayer mais je voulais dabort repondre à ta question et bien non je ne peut pas lire de dvd je suis dessus en plus depuis ce matin http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif
Je ne perd pas espoir est vais de ce pas faire ce que tu m'as dis enfin si j'a assez de temps car je dois aller au taf bientot au pire ce soir je reviens te dire si sa à marcher pour moi
Sincerment merci beaucoup sa ma beaucoup touché le temps que tu passe pour m'aider merci
A+


Edit lorsque je tape mount /media/cdrecorder j'ai un message d'erreur
Donc je l'est taper ainssi mount /media/cdrecorder et j'ai cela :

selon mtab/dev/hdc est deja monté sur mediacdrecorder
echec de mount

Sa commence bien lol
merci


re edit :
pour la deuxieme solution
des le depart lol je tape : cp /media/cdrecorder/linux-installer.sh /home/magicpixel
Et j'ai permission non accordé

Merci

Sirius
28/04/2005, 17h29
Essai de le faire en tant que "root"... peut être que ton ID user n'est pas dans le groupe Cdrom....

magicpixel
28/04/2005, 21h14
bon je refait des tests mais meme avec la deuxieme solution sa met le message de mount en gros point de depart par contre pour cette solution j'ai pas pu taper la commande supermount disable j'avais un message d'erreur
Dur dur
Merci
A+

Deusexodus
29/04/2005, 18h15
Quand tu dis que tu ne peux pas lire le dvd c'est que tu as un lecteur non dvd ou que tu n'arrive pas a le lire ?

@+

magicpixel
29/04/2005, 20h45
J'ai un lecteur de dvd mais je peut pas les lire ils faut que j'installe ce qu'il faut et comme j'ai pas encore reussis a installer apt get
Mais s'est une autre histoire enfin j'espere
Merci
A+

alexmic
29/04/2005, 22h10
Deux petites précisions:
TOn dossier /mnt/ est vide et c'est normal.
Il te faut créer un dossier cdrom et/ou dvdrom

mkdir /mnt/cdrom/
mkdir /mnt/dvdrom/
et tu pourras essayer sur le deux emplacements.
J'ai moi aussi eu des probleme lors du umount parce que j'avais des fenetres konqueror ouvertes sur le cd. IL faut tout bien ferme avant de démonter...

Pour le lecteur... Aïe aïe http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif j'espère que tu n'est pas dans un cas soit SCSI (ces lecteurs sont moins bien reconnus) ou sur une interface IDE exotique.

magicpixel
02/05/2005, 14h39
Merci mais meme en fesant cela sa ne veut pas le faire
C'est vraiment dificile je trouves d'installer ce jeu mais je n'abandonerai jamais enfin si il sorte ut 2005......
merci
A+

Poy59
13/05/2005, 12h35
y a plus simple que ça
met ton jeu ds ton lecteur
ouvre une console
su -
password

ecris ça
cd /media/ <--- utilise la touche tab et regarde ou tu vois ton jeu

moi c'est /media/UT2004_DVD/

demonte alors ton dvd jeu
umount /media/UT2004_DVD/

ensuite en faisant dans la console
cd /media/ <---- touche tab retrouve ton lecteur dvd

moi ça donne /media/dvdrecorder <== un graveur de dvd pour ma part

donc faut le monter
mount /dev/dvdrecorder /media/dvdrecorder

si t as toujours des soucis fait moi signe

magicpixel
19/05/2005, 15h16
Merci beaucoup de ta reponse je testerais cela ce week

Merci
a+

magicpixel
21/05/2005, 21h51
Un ganrd merci à tout le monde sa a marcher merci
a+