PDA

Afficher la version complète : [gcc] Compilation ou assemblage



lucienmathieu
22/09/2004, 14h54
Salut,

j'essaie de compiler gcc, mais j'ai une erreur du style as: unknow --warn-short-loop, est-ce que quelqu'un aurait une petite documentation specifique a as (c'est l'assembleur je pense)

ou meme une solution au probleme ;-P

[lm01] tag de recherche ;-P

molodoi
22/09/2004, 19h43
aucune idée http://www.alionet.org/style_emoticons/<#EMO_DIR#>/blink.gif http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

galagann
22/09/2004, 19h51
Moi aussi j'ai pas d'idée, mais tu pourrais nous dire comme cela c'est produit !

lucienmathieu
22/09/2004, 21h12
On va faire la description en image, plutot en liens... voici la methode que j'utilise, elle provient de linux from scratch.

http://www.alionet.org/style_emoticons/<#EMO_DIR#>/arrow.gif binutilsavec cette methode binutils (http://www.fr.linuxfromscratch.org/view/lfs-5.0-fr/chapter05/binutils-pass1.html) compil sans problemehttp://www.alionet.org/style_emoticons/<#EMO_DIR#>/arrow.gif gccpar contre gcc (http://www.fr.linuxfromscratch.org/view/lfs-5.0-fr/chapter05/gcc-pass1.html) a plus de mal, deja pour la configuration, je dois specifier le host pour que ca marche, evidemment je tourne en mips (ou mipsel)
../gcc-3.3.1/configure --prefix=/tools \
--with-local-prefix=/tools \
--disable-nls --enable-shared \
--enable-languages=c \
mips (aussi mipsel pour le host)mon probleme arrive au moment du make BOOT_LDFLAGS="-static" bootstrap, l'assembleur de mips ne reconnait pas l'option --warn-short-loop, je n'ai pas trouve cette options dans le man d'as. J'ai meme du mal a la trouvee sur internetJ'ai trouve d'autres informations sur un autre site que je devrais lire ce soir, apparemment, je devrais deja utiliser le nouveau binutils et les headers du nouveau kernel.

Il faudra aussi que je regarde si je ne dois pas plutot configurer le host en mipsel-unknown-linux-gnu et le target en mipsel-any-elf, enfin quelque chose comme ca, je vous tiens au courant de cette magnifique aventure. Par contre toujours pas de nouvelles de Novell.

En tout cas, si j'y arrive, je compte bien utiliser ce nouveau kernel sur PS2 pour demarrer la compil de Suse, ce sera beaucoup plus facile pour moi ;-P

atlas
24/09/2004, 19h51
beuh ...

"a as" , je suis mauvais en programmation et encore plus en assembleur .
Mais honnetement je crois pouvoir affirmer que "a as" n'est pas une instruction assembleur .

devloop
24/09/2004, 20h25
non il disait "spécifique à as" comme si il disait "spécifique à gcc" http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif

lucienmathieu
29/09/2004, 18h52
Merci devloop d'avoir specifie, en fait c'est gas le vrai nom de l'assembleur sous mips, seulement les messages restent as: <message>.

Par contre, j'ai trouve un patch pour binutils 2.4 et la playstation 2, ainsi qu'un patch pour le gcc 3.2.2, donc je vais tout recompiler avec le gcc 3.2.2.

Pour le moment, j'ai donc reussi a corriger cette erreur d'option specifique a la PS2. Mais dernierement, j'ai eu une erreur du style a: unrecognize option -m=r5900.

Je comprends l'erreur, mais pour mips, les options sont -mips1, -mips2. -mips3... et ainsi de suite, pas vraiment -m=<cpu>

Est-ce que vous connaissez assez bien binutils ou gcc pour me dire ou je pourrais modifier les options?

J'ai essaye dans ../binutils-2.4/gas/config/tc-mips.c, mais ca n'a pas marche, car maintenant a la compil, j'ai l'erreur unrecognized option -m=r5900. Et oui, le nouvel assembleur est bien utilise...

je pense effacer l'installation de binutils et recommencer la compil avec la nouvelle option, ou alors aurais-je pu changer les options de compilation directement sur la compilation de gcc... ;-P