PDA

Afficher la version complète : [Réglé] Warning: This might be caused by a malicious change in the file!



jeanlo123
26/04/2010, 14h05
Bonjour,
j'ai ce message d'erreur:
zypper ref
Repository 'home:pzn62g' is up to date.
Signature verification failed for file 'repomd.xml' from repository 'Mises à jour pour openSUSE 11.2-0'.
Warning: This might be caused by a malicious change in the file!
Continuing might be risky. Continue anyway? [yes/no] (no): y
File './repodata/a96424b2ac53d6b81ccdfd4ed38f0226e5faeaa0-updateinfo.xml.gz' not found on medium 'http://download.opensuse.org/update/11.2/'

Abort, retry, ignore? [a/r/i/?] (a): i
Retrieving repository 'Mises à jour pour openSUSE 11.2-0' metadata [error]
Repository 'Mises à jour pour openSUSE 11.2-0' is invalid.
Can't provide ./repodata/a96424b2ac53d6b81ccdfd4ed38f0226e5faeaa0-updateinfo.xml.gz : User-requested skipping of a file
Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository 'Mises à jour pour openSUSE 11.2-0' because of the above error.
Repository 'openSUSE-11.2-Non-Oss' is up to date.
Repository 'openSUSE-11.2-Oss' is up to date.
Some of the repositories have not been refreshed because of an error.

zypper up
Signature verification failed for file 'repomd.xml' from repository 'Mises à jour pour openSUSE 11.2-0'.
Warning: This might be caused by a malicious change in the file!
Continuing might be risky. Continue anyway? [yes/no] (no): y
File './repodata/a96424b2ac53d6b81ccdfd4ed38f0226e5faeaa0-updateinfo.xml.gz' not found on medium 'http://download.opensuse.org/update/11.2/'

Abort, retry, ignore? [a/r/i/?] (a): i
Retrieving repository 'Mises à jour pour openSUSE 11.2-0' metadata [error]
Repository 'Mises à jour pour openSUSE 11.2-0' is invalid.
Can't provide ./repodata/a96424b2ac53d6b81ccdfd4ed38f0226e5faeaa0-updateinfo.xml.gz : User-requested skipping of a file
Please check if the URIs defined for this repository are pointing to a valid repository.
Warning: Disabling repository 'Mises à jour pour openSUSE 11.2-0' because of the above error.
Loading repository data...
Reading installed packages...

Nothing to do.

Si, je réessaie:
zypper up
Retrieving repository 'Mises à jour pour openSUSE 11.2-0' metadata [done]
Building repository 'Mises à jour pour openSUSE 11.2-0' cache [done]
Loading repository data...
Reading installed packages...

Nothing to do.

Que faire ?

Tout à l'air de fonctionner:
zypper up
Loading repository data...
Reading installed packages...
Nothing to do.

sobkowiak
30/12/2010, 15h31
Il est possible qu'il n'y ait plus de suivi de la mise-à-jour de la 11.2 ce qui fait que l'adresse de téléchargement ne soit plus valide. Avez vous essayé de charger des paquetages pour la 11.2 depuis le site d'OpenSuse ?

jluce
30/12/2010, 15h45
slt

un petit



zypper lr -u

dans un terminale en root pour voir si les répertoires existent encore ou si y'aurais pas un autre soucis ...

a+