PDA

Afficher la version complète : Mise a jour de sécurité sur Postfix



jluce
11/05/2011, 12h57
openSUSE Security Update: postfix: Security update to fix remote code execution

__________________________________________________ ____________________________


Announcement ID: openSUSE-SU-2011:0476-1
Rating: critical
References: #689021
Cross-References: CVE-2011-1720
Affected Products:
openSUSE 11.4
openSUSE 11.3
openSUSE 11.2

__________________________________________________ ____________________________

An update that fixes one vulnerability is now available.

Description:

Remote attackers could potentially exploit a memory
corruption issue in postfix' SASL implementation to execute
arbitrary code (CVE-2011-1720).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch postfix-4524

- openSUSE 11.3:

zypper in -t patch postfix-4524

- openSUSE 11.2:

zypper in -t patch postfix-4524

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64):

postfix-2.7.2-13.16.1
postfix-devel-2.7.2-13.16.1
postfix-mysql-2.7.2-13.16.1
postfix-postgresql-2.7.2-13.16.1

- openSUSE 11.4 (noarch):

postfix-doc-2.7.2-13.16.1

- openSUSE 11.3 (i586 x86_64):

postfix-2.7.1-2.6.1
postfix-devel-2.7.1-2.6.1
postfix-mysql-2.7.1-2.6.1
postfix-postgresql-2.7.1-2.6.1

- openSUSE 11.3 (noarch):

postfix-doc-2.7.1-2.6.1

- openSUSE 11.2 (i586 x86_64):

postfix-2.6.1-2.10.1
postfix-devel-2.6.1-2.10.1
postfix-doc-2.6.1-2.10.1
postfix-mysql-2.6.1-2.10.1
postfix-postgresql-2.6.1-2.10.1


References:

http://support.novell.com/security/cve/CVE-2011-1720.html
https://bugzilla.novell.com/689021