PDA

Afficher la version complète : Mise a jour de sécurité sur libmodplug et perl-libwww-perl



jluce
30/05/2011, 17h58
libmodplug

openSUSE Security Update: libmodplug security update
__________________________________________________ ____________________________

Announcement ID: openSUSE-SU-2011:0551-1
Rating: moderate
References: #691137
Cross-References: CVE-2011-1761
Affected Products:
openSUSE 11.4
openSUSE 11.3
__________________________________________________ ____________________________

An update that fixes one vulnerability is now available. It
includes one version update.

Description:

specially crafted files could cause a stack overflow in
libmodplug (CVE-2011-1761). libmodplug version 0.8.8.3
fixes the problem.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch libmodplug-4614

- openSUSE 11.3:

zypper in -t patch libmodplug-4614

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64) [New Version: 0.8.8.3]:

libmodplug-devel-0.8.8.3-2.12.1
libmodplug0-0.8.8.3-2.12.1

- openSUSE 11.4 (x86_64) [New Version: 0.8.8.3]:

libmodplug0-32bit-0.8.8.3-2.12.1

- openSUSE 11.3 (i586 x86_64) [New Version: 0.8.8.3]:

libmodplug-devel-0.8.8.3-2.3.1
libmodplug0-0.8.8.3-2.3.1

- openSUSE 11.3 (x86_64) [New Version: 0.8.8.3]:

libmodplug0-32bit-0.8.8.3-2.3.1


References:

http://support.novell.com/security/cve/CVE-2011-1761.html
https://bugzilla.novell.com/691137

perl-libwww-perl

openSUSE Security Update: perl-libwww-perl security update
__________________________________________________ ____________________________

Announcement ID: openSUSE-SU-2011:0552-1
Rating: important
References: #693999
Cross-References: CVE-2011-0633
Affected Products:
openSUSE 11.4
__________________________________________________ ____________________________

An update that fixes one vulnerability is now available.

Description:

perl-libwww-perl did not verify enable host name checking
of SSL certificates by default (CVE-2011-0633).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch perl-libwww-perl-4589

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (noarch):

perl-libwww-perl-5.837-5.7.1


References:

http://support.novell.com/security/cve/CVE-2011-0633.html
https://bugzilla.novell.com/693999