PDA

Afficher la version complète : Occupation mémoire importante



tocri
25/04/2012, 16h42
Bonjour à tous,

Une petite question, j'ai un NAS sous OSS 11.4 en config raid6 avec agregation des cartes rx.
Il y à 3 go de RAM sur le pc. CPU cadencé à 2ghz.

Je supervise l'ensemble du SI avec Eyesofnetwork. Et le serveru NAS à une occupation ram de 98% même si personne ne l'utilise. Si je le redémarre, le taux d'occupation est de 20 % puis au fil des jours il monte à 98 %.

Je ne comprends pas trop le pb.

EON est une distribution linux également et je ne recontre pas ce pb.

Vous auriez des astuces pour régler ces problèmes ?

Cordialement

linux5623
25/04/2012, 21h05
J'ai la même chose mais avec 24gio chez moi c'est le cache disque qui prend la mémoire.
Mais en cas de besoin il se réduit.

Jamais eu d'erreur a cause de ça.

tocri
25/04/2012, 21h16
Je précise que je n'ai pas d'erreur. Tout fonctionne bien. C'est que sur ma map nagvis, j'ai mes serveurs en vert et pour le nas j'ai une belle croix rouge. Cela fait tâche :(
Ah la souci de la perfection lol.

En fait j'ai l'impression que s'est une fuite mémoire...

linux5623
25/04/2012, 23h00
Si c’était une fuite mémoire tu remplirais aussi le swap !

Je pense plutôt que c'est un problème de gestion du cache disque qui prends tout la place disponible.

Après environ 3 heures d'utilisation la cache disque prend 33% de 24Gio. Les applications seulement 10%.

Burn2
28/04/2012, 13h01
Bonjour, c'est simple, pour savoir l'utilisation de la ram, le plus important c'est :


free -m
total used free shared buffers cached
Mem: 3943 2824 1119 0 133 1423
-/+ buffers/cache: 1266 2676
Swap: 4196 33 4163


La deuxième ligne donne vraiment ce qui est utilisé.
Ici j'ai donc 2824mo de ram utilisé, donc 1266 réellement et 2676 réellement libre, et 1119 par le cache, le cache étant une portion de ram libre, ou l'os laisse les choses préchargé afin de ne pas perdre de temps à les recharger, c'est donc parfaitement normal.

J'ai 33mo de swap utilisé, à cause de l'utilisation de vm juste avant. ;) Ici si tu vois toi beaucoup de swap utilisé alors il y a réellement un soucis

Je pense que c'est plus votre commande pour récupérer l'utilisation de la mémoire qui est fausse, et que ça inclu l'utilisation de la ram par le cache. Vous n'avez pas moyen de modifier la commande de récupération de l'utilisation de la ram?