PDA

Afficher la version complète : [Réglé] Le pare-feu ne s'active ou ne se déasactive pas (sauf démarrage)



Denebe
02/10/2012, 19h00
Bonjour,

en cherchant une solution pour un sombre problème d'heure, je me suis rendu compte que l'activation et la désactivation du pare-feu via Yast ne fonctionne pas chez moi. Tout du moins c'est ce qui est affiché... Pour arrêter le pare-feu j'ai dû décocher démarrer le pare-feu au démarrage, et pour l'activer le contraire.

Denebe.

jluce
03/10/2012, 11h41
slt Denebe

en cliqant sur start firewall il démarre pas ???

t'as verifier en faisant un iptables -L -n dans un terminale poiur voir si quelquechose change ??

bizarre ca le fait pas chez moi

a+

Denebe
03/10/2012, 14h22
Slt Jluce,

oui ça m'a étonné, mais c'est bien le cas. Je passe dans l'après-midi dans une bibliothèque où j'ai accès à internet correctement (avec linux), je testerai 'iptables -L -n' voir ce que ça donne, et par la même occasion j'étudierai le sens caché de cette commande ;) Je n'y connais rien avec iptables.

Merci de ton retour.

jluce
03/10/2012, 15h20
re

iptables -L -n te liste les regles de ton firewall

ca te permet de voir si il est lancé ou non et plus si affinités avec iptables ;)

a+

Denebe
03/10/2012, 17h29
Voilà le résultat du test:

1) mon ordi est allumé normalement, je veux dire avec le pare-feu qui se lance après le boot, la commande "iptables -L -n" me donne tout un tas d'informations.

2) je vais dans la gestion du pare-feu (Yast), je clique sur "arrêter le pare-feu maintenant", la case "arrêter le pare-feu maintenant" se met au vert, puis je clique sur terminer...
Quand je lance la commande 'iptables -L -n' , je constate que mon pare-feu est éteint . Voici une capture (le dessus c'est avant la désactivation du pare-feu, la fin c'est après => pare feu désactivé)
http://www.zimagez.com/miniature/parefeu4.png (http://www.zimagez.com/zimage/parefeu4.php)

Par contre, quand je vais dans Yast, c'est indiqué que mon pare-feu fonctionne !! D'ailleurs la case "démarrer le pare-feu maintenant" est grisé et inutilisable. La case "arrêter le pare-feu maintenant" est utilisable, mais à quoi bon [...].

Pour redémarrer le pare-feu, je suis obligé de cliquer sur la troisième option " Enregistrer les paramètres et redémarrer le pare-feu maintenant" (avec le bouton terminer pour valider). Ca fonctionne, j'ai vérifier avec 'iptables -L -n'

Heureusement c'est juste un soucis d'affichage.

jluce
08/10/2012, 12h38
slt

a voir si ca se corrige avec une mise a jour futur....

a+

Denebe
08/10/2012, 18h52
Slt,

j'ai cherché deux secondes, je pense c'est un bug https://bugzilla.novell.com/show_bug.cgi?id=779455 .
Apparemment les symptömes sont identiques. Je dis apparemment car je n'ai pas lu toute la page, et d'après ce que j'ai lu ils n'ont pas testé en ligne de commande voir ce qui se passait. Bref, bref bref...

D'après Lukas Ocilka, en patchant un fichier, selon les personnes qui ont essayé, ça marche.
Je viens de tester, ça fonctionne comme il faut après le patch.
Voilà comment procéder:


éditer ce fichier avec les droits root:

/usr/share/YaST2/modules/SuSEFirewall.ycp

A la ligne 116-117, vous devez avoir quelque chose comme ça
list <string> firewall_services_reverse = [ "SuSEfirewall2_setup", "SuSEfirewall2_init" ];

/* script for starting and checking firewall status */

Ensuite, voilà lce qu'il faut modifier:
string firewall_script = "/sbin/SuSEfirewall2";

Après la correction, ça donne:
string firewall_script = "/sbin/service SuSEfirewall2_setup";

Ce qui suit (juste bien se repérer car ce n'est pas utile):
list <string> SuSEFirewall_variables = [
// zones and interfaces


Maintenant enregistrer les modifications
En console en root


cd /usr/share/YaST2/modules/puis valider par le retour chariot (on dit encore ça aujourd'hui ?)

ycpc -c SuSEFirewall.ycp

Ca marche. :)

argon
09/10/2012, 08h41
Merkiiii !!

C'est vrai que c'était un peu dérangeant de douter de la présence ou non du pare feu.