PDA

Afficher la version complète : [réglé] Kylix 3



youngpenguin
28/04/2005, 19h27
bonsoir à tous !!!
Ayant commencé à programmer en c++ avec c++builder6 sous windows j'ai voulu trouver l'équivalent linux, et il semblerait que ce soit kylix3.
Je l'ai donc téléchargé puis installé et après avoir relancé le serveur X je n'arrive toujours pas à ouvrir kylix3 avec la commande startdelphi ou en cliquant sur kylix3... http://www.alionet.org/style_emoticons/<#EMO_DIR#>/bang.gif
quelqu'un pourrait il m'aider ????
merci d'avance http://www.alionet.org/style_emoticons/<#EMO_DIR#>/cool.gif

youngpenguin
29/04/2005, 08h28
bonjour à tous !!!
si par hasard quelqu'un connaissait autre chose que kylix 3, utilisant le même principe de programmation événementielle que c++builder6, je suis preneur... http://www.alionet.org/style_emoticons/<#EMO_DIR#>/cool.gif

abgech
29/04/2005, 08h41
Tu peux utiliser Qt, logiciel utilisé pour implémenter KDE, pas vraiment libre au sens Stalmann, mais bon ... C'est du C++.

Mais tu peux aussi choisir GTK+, logiciel utilisé pour implémenter Gnome, libre. C'est du C, mais avec des "raccord" pour l'utiliser à partir de C++.

youngpenguin
29/04/2005, 08h48
merci du conseil abprfr...
par contre est ce que tu saurais me dire pourquoi je n'arrive pas à lancer kylix3 ???? http://www.alionet.org/style_emoticons/<#EMO_DIR#>/blink.gif

Ssnake
29/04/2005, 09h23
kylix n'est pas fait pour programmer du C/C++, c'est plutot du pascal/delphi.
Sinon le probleme avec kylix vient surement du fait que tu n'as pas le le fichier reg92.txt dans ton home (question de licence, kylix n'est pas libre). C'est un fichier que tu peux avoir en t'enregistrant sur le site de Borland.

youngpenguin
29/04/2005, 09h30
merci du renseignement !!!!!!
je croyais que kylix était l'équivelent de c++builder mais sur linux. Me suis trompé http://www.alionet.org/style_emoticons/<#EMO_DIR#>/unsure.gif
En ce qui concerne la programation événementielle en c++ que puis je utiliser (en libre si possible) ??? http://www.alionet.org/style_emoticons/<#EMO_DIR#>/cool.gif

yoplait
29/04/2005, 10h39
kdevelop, c'est pas bien ?

youngpenguin
29/04/2005, 11h08
Originally posted by yoplait@vendredi 29 avril 2005 à 09:39
kdevelop, c'est pas bien ?
<div align='right'><{POST_SNAPBACK}> (index.php?act=findpost&pid=34868)[/quote]

ba j'en sais rien
c pour ça que je demande http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif
moi newbie http://www.alionet.org/style_emoticons/<#EMO_DIR#>/beby.gif

molodoi
29/04/2005, 13h16
Originally posted by yoplait@vendredi 29 avril 2005 à 09:39
kdevelop, c'est pas bien ?
<div align='right'><{POST_SNAPBACK}> (index.php?act=findpost&pid=34868)[/quote]

je l'utilise un peu...

A vrai dire, j'ai tjrs eu un peu de mal avec ce genre d'outils intégrés http://www.alionet.org/style_emoticons/<#EMO_DIR#>/unsure.gif

Mais je pense que dès qu'on sait l'utiliser, ça peut devenir un outil très puissant

youngpenguin
29/04/2005, 15h37
je vais essayer Kdevelop dès ce soir http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif
il est déjà sur la SuSE 9.2 ou il faut que je passe par yast ou apt4rpm ???

molodoi
29/04/2005, 16h28
http://www.alionet.org/style_emoticons/<#EMO_DIR#>/blink.gif m'en souviens plus

Mais je pense qd même qu'il faut l'installer (Yast devrait être OK)

youngpenguin
29/04/2005, 16h37
Originally posted by molodoi@vendredi 29 avril 2005 à 15:28
http://www.alionet.org/style_emoticons/<#EMO_DIR#>/blink.gif m'en souviens plus

Mais je pense qd même qu'il faut l'installer (Yast devrait être OK)
<div align='right'><{POST_SNAPBACK}> (index.php?act=findpost&pid=34926)[/quote]

merci à toi
je vais essayer ça ce soir http://www.alionet.org/style_emoticons/<#EMO_DIR#>/cool.gif

youngpenguin
29/04/2005, 20h21
Reading Package Lists... Done
Building Dependency Tree... Done
Selecting kdevelop3 for 'kdevelop'
The following extra packages will be installed:
alsa-devel arts arts-devel autoconf automake docbook-dsssl-stylesheets
docbook-toys docbook-xsl-stylesheets docbook_3 doxygen fam-devel flex
fontconfig-devel freeglut-devel freetype2-devel gettext glib2-devel graphviz
gtkdoc html-dtd jack-devel jadetex kdebase3 kdebase3-devel kdelibs3
kdelibs3-devel kdelibs3-devel-doc kdesdk3 kdevelop3 latex-ucs libapr0
libart_lgpl libart_lgpl-devel libidn-devel liblcms liblcms-devel
libmng-devel libogg libogg-devel libpng-devel libvorbis libvorbis-devel
libxml2 libxml2-devel libxslt libxslt-devel m4 neon openjade opensp
pcre-devel pkgconfig qt3 qt3-devel qt3-devel-doc qt3-devel-tools subversion
swig te_etex te_latex te_pdf tetex xorg-x11-Mesa-devel xorg-x11-devel
zlib-devel
The following packages will be upgraded
arts kdebase3 kdelibs3 libart_lgpl liblcms libogg libvorbis libxml2 libxslt
qt3
The following NEW packages will be installed:
alsa-devel arts-devel autoconf automake docbook-dsssl-stylesheets
docbook-toys docbook-xsl-stylesheets docbook_3 doxygen fam-devel flex
fontconfig-devel freeglut-devel freetype2-devel gettext glib2-devel graphviz
gtkdoc html-dtd jack-devel jadetex kdebase3-devel kdelibs3-devel
kdelibs3-devel-doc kdesdk3 kdevelop3 latex-ucs libapr0 libart_lgpl-devel
libidn-devel liblcms-devel libmng-devel libogg-devel libpng-devel
libvorbis-devel libxml2-devel libxslt-devel m4 neon openjade opensp
pcre-devel pkgconfig qt3-devel qt3-devel-doc qt3-devel-tools subversion swig
te_etex te_latex te_pdf tetex xorg-x11-Mesa-devel xorg-x11-devel zlib-devel
10 upgraded, 55 newly installed, 0 removed and 187 not upgraded.
Need to get 135MB/140MB of archives.
After unpacking 462MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 ftp://ftp.gwdg.de SuSE/9.2-i386/base m4 1.4.2-3 [84,8kB]
Get:2 ftp://ftp.gwdg.de SuSE/9.2-i386/kde autoconf 2.59-79 [528kB]
Get:3 ftp://ftp.gwdg.de SuSE/9.2-i386/kde automake 1.9.5-5 [476kB]
Get:4 ftp://ftp.gwdg.de SuSE/9.2-i386/base docbook_3 3.1-597.1 [669kB]
Get:5 ftp://ftp.gwdg.de SuSE/9.2-i386/suse-people docbook-dsssl-stylesheets 1.79-0.1 [586kB]
Get:6 ftp://ftp.gwdg.de SuSE/9.2-i386/suse-people docbook-xsl-stylesheets 1.67.2-0.1 [1168kB]
Get:7 ftp://ftp.gwdg.de SuSE/9.2-i386/base flex 2.5.4a-295 [150kB]
Get:8 ftp://ftp.gwdg.de SuSE/9.2-i386/base gettext 0.14.1-33 [1963kB]
Get:9 ftp://ftp.gwdg.de SuSE/9.2-i386/base graphviz 1.12-3.1 [2722kB]
Get:10 ftp://ftp.gwdg.de SuSE/9.2-i386/base html-dtd 2004.1.26-63.1 [738kB]
Get:11 ftp://ftp.gwdg.de SuSE/9.2-i386/update-drpm tetex 2.0.2-198.7 [1084kB]
Get:12 ftp://ftp.gwdg.de SuSE/9.2-i386/base latex-ucs 20040703-2 [1026kB]
Get:13 ftp://ftp.gwdg.de SuSE/9.2-i386/base te_latex 2.0.2-198.4 [12,1MB]
Get:14 ftp://ftp.gwdg.de SuSE/9.2-i386/base te_etex 2.0.2-198.4 [779kB]
Get:15 ftp://ftp.gwdg.de SuSE/9.2-i386/base te_pdf 2.0.2-198.4 [1089kB]
Get:16 ftp://ftp.gwdg.de SuSE/9.2-i386/base jadetex 3.13-217.1 [1562kB]
Get:17 ftp://ftp.gwdg.de SuSE/9.2-i386/kde3-stable libart_lgpl 2.3.17-3 [69,0kB]
Get:18 ftp://ftp.gwdg.de SuSE/9.2-i386/suser-guru libxml2 2.6.17-1.guru.suse92 [603kB]
Get:19 ftp://ftp.gwdg.de SuSE/9.2-i386/base opensp 1.5.1-79 [1123kB]
Get:20 ftp://ftp.gwdg.de SuSE/9.2-i386/base openjade 1.3.2-210 [1211kB]
Get:21 ftp://ftp.gwdg.de SuSE/9.2-i386/base gtkdoc 1.2-62.1 [85,3kB]
Get:22 ftp://ftp.gwdg.de SuSE/9.2-i386/suser-guru libxslt 1.1.12-1suse92 [165kB]
Get:23 ftp://ftp.gwdg.de SuSE/9.2-i386/kde kdelibs3 3.4.0-22 [17,1MB]
Get:24 ftp://ftp.gwdg.de SuSE/9.2-i386/kde kdebase3 3.4.0-30 [26,3MB]
Get:25 ftp://ftp.gwdg.de SuSE/9.2-i386/base freetype2-devel 2.1.9-3 [977kB]
Get:26 ftp://ftp.gwdg.de SuSE/9.2-i386/suser-guru liblcms 1.14-2.guru.suse92 [149kB]
Get:27 ftp://ftp.gwdg.de SuSE/9.2-i386/suser-guru liblcms-devel 1.14-2.guru.suse92 [107kB]
Get:28 ftp://ftp.gwdg.de SuSE/9.2-i386/base libmng-devel 1.0.8-3.1 [610kB]
Get:29 ftp://ftp.gwdg.de SuSE/9.2-i386/base zlib-devel 1.2.1-74 [66,1kB]
Get:30 ftp://ftp.gwdg.de SuSE/9.2-i386/base libpng-devel 1.2.6-4 [200kB]
Get:31 ftp://ftp.gwdg.de SuSE/9.2-i386/base fontconfig-devel 2.2.96.20040728-9 [235kB]
Get:32 ftp://ftp.gwdg.de SuSE/9.2-i386/xorg xorg-x11-devel 6.8.2-35.1 [2522kB]
Get:33 ftp://ftp.gwdg.de SuSE/9.2-i386/xorg xorg-x11-Mesa-devel 6.8.2-35.1 [1060kB]
Get:34 ftp://ftp.gwdg.de SuSE/9.2-i386/base freeglut-devel 2.2.0-82.1 [166kB]
Get:35 ftp://ftp.gwdg.de SuSE/9.2-i386/kde3-stable qt3-devel 3.3.4-8 [1596kB]
Get:36 ftp://ftp.gwdg.de SuSE/9.2-i386/kde3-stable qt3-devel-doc 3.3.4-8 [6026kB]
Get:37 ftp://ftp.gwdg.de SuSE/9.2-i386/kde kdelibs3-devel-doc 3.4.0-22 [12,2MB]
Get:38 ftp://ftp.gwdg.de SuSE/9.2-i386/suse-projects libapr0 2.0.53-5.1 [679kB]
Get:39 ftp://ftp.gwdg.de SuSE/9.2-i386/base neon 0.24.7-3.1 [84,1kB]
Get:40 ftp://ftp.gwdg.de SuSE/9.2-i386/base swig 1.3.21-107.1 [1381kB]
Get:41 ftp://ftp.gwdg.de SuSE/9.2-i386/suse-projects subversion 1.1.3-7.1 [922kB]
Get:42 ftp://ftp.gwdg.de SuSE/9.2-i386/kde kdesdk3 3.4.0-9 [4006kB]
Get:43 ftp://ftp.gwdg.de SuSE/9.2-i386/base pkgconfig 0.15.0-199 [69,0kB]
Get:44 ftp://ftp.gwdg.de SuSE/9.2-i386/base glib2-devel 2.4.6-5.1 [421kB]
Get:45 ftp://ftp.gwdg.de SuSE/9.2-i386/base jack-devel 0.98.1-5.1 [59,8kB]
Get:46 ftp://ftp.gwdg.de SuSE/9.2-i386/packman-i686 libogg-devel 1.1.2-0.pm.0 [70,3kB]
Get:47 ftp://ftp.gwdg.de SuSE/9.2-i386/packman-i686 libvorbis-devel 1.1.0-0.pm.0 [672kB]
Get:48 ftp://ftp.gwdg.de SuSE/9.2-i386/packman alsa-devel 1.0.8-0.pm.0 [1289kB]
Get:49 ftp://ftp.gwdg.de SuSE/9.2-i386/kde arts-devel 1.4.0-8 [198kB]
Get:50 ftp://ftp.gwdg.de SuSE/9.2-i386/suser-guru libxml2-devel 2.6.17-1.guru.suse92 [1287kB]
Get:51 ftp://ftp.gwdg.de SuSE/9.2-i386/suser-guru libxslt-devel 1.1.12-1suse92 [295kB]
Get:52 ftp://ftp.gwdg.de SuSE/9.2-i386/kde3-stable libart_lgpl-devel 2.3.17-3 [61,5kB]
Get:53 ftp://ftp.gwdg.de SuSE/9.2-i386/base fam-devel 2.6.10-122 [28,3kB]
Get:54 ftp://ftp.gwdg.de SuSE/9.2-i386/base pcre-devel 4.5-2 [96,6kB]
Get:55 ftp://ftp.gwdg.de SuSE/9.2-i386/base libidn-devel 0.5.3-2.1 [1083kB]
Get:56 ftp://ftp.gwdg.de SuSE/9.2-i386/kde kdelibs3-devel 3.4.0-22 [1537kB]
Get:57 ftp://ftp.gwdg.de SuSE/9.2-i386/kde kdebase3-devel 3.4.0-30 [106kB]
Get:58 ftp://ftp.gwdg.de SuSE/9.2-i386/kde3-stable qt3-devel-tools 3.3.4-8 [3815kB]
Get:59 ftp://ftp.gwdg.de SuSE/9.2-i386/suser-guru doxygen 1.4.2-2.guru.suse92 [2332kB]
Get:60 ftp://ftp.gwdg.de SuSE/9.2-i386/base docbook-toys 1.51.0-267.1 [38,2kB]
Get:61 ftp://ftp.gwdg.de SuSE/9.2-i386/kde kdevelop3 3.2.0-10 [15,0MB]
Fetched 135MB in 44m21s (50,7kB/s)
Committing changes...
Preparing... ########################################### [100%]
file /opt/kde3/share/services/xcf.kimgio from install of kdelibs3-3.4.0-22 conflicts with file from package gwenview-1.1.5-8.1
file /opt/kde3/lib/kde3/kstyle_plastik_config.la from install of kdelibs3-3.4.0-22 conflicts with file from package kdeartwork3-3.3.0-7.1
file /opt/kde3/lib/kde3/kstyle_plastik_config.so from install of kdelibs3-3.4.0-22 conflicts with file from package kdeartwork3-3.3.0-7.1
file /opt/kde3/lib/kde3/plugins/styles/plastik.la from install of kdelibs3-3.4.0-22 conflicts with file from package kdeartwork3-3.3.0-7.1
file /opt/kde3/lib/kde3/plugins/styles/plastik.so from install of kdelibs3-3.4.0-22 conflicts with file from package kdeartwork3-3.3.0-7.1
file /opt/kde3/share/apps/kstyle/themes/plastik.themerc from install ofkdelibs3-3.4.0-22 conflicts with file from package kdeartwork3-3.3.0-7.1
file /opt/kde3/share/mimelnk/application/x-webarchive.desktop from install of kdelibs3-3.4.0-22 conflicts with file from package kdeaddons3-konqueror-3.3.0-10.1
file /opt/kde3/lib/kde3/kwin3_plastik.la from install of kdebase3-3.4.0-30 conflicts with file from package kdeartwork3-3.3.0-7.1
file /opt/kde3/lib/kde3/kwin3_plastik.so from install of kdebase3-3.4.0-30 conflicts with file from package kdeartwork3-3.3.0-7.1
file /opt/kde3/lib/kde3/kwin_plastik_config.la from install of kdebase3-3.4.0-30 conflicts with file from package kdeartwork3-3.3.0-7.1
file /opt/kde3/lib/kde3/kwin_plastik_config.so from install of kdebase3-3.4.0-30 conflicts with file from package kdeartwork3-3.3.0-7.1
file /opt/kde3/share/apps/kwin/plastik.desktop from install of kdebase3-3.4.0-30 conflicts with file from package kdeartwork3-3.3.0-7.1
E: Error while running transaction
E: Handler silently failed


voilà ce que j'obtiens lorsque je fais apt-get install kdevelop ???
qu'est ce qui ne va pas là dedans ???? http://www.alionet.org/style_emoticons/<#EMO_DIR#>/dry.gif

youngpenguin
29/04/2005, 20h55
comment puis je régler tous ces conflits ???????????
merci d'avance http://www.alionet.org/style_emoticons/<#EMO_DIR#>/cool.gif

alexmic
29/04/2005, 22h16
Euh ca c'est du APT...
il est dispo sous Yast, passe par la et mets (enfin essaies de) le à jour par APT .

Là il ya l'air d'avoir des pb de versions entre les packages KDE et à mon avis vaut mieux éviter de n'en mettre que certains à jour.

youngpenguin
29/04/2005, 23h07
Originally posted by alexmic@vendredi 29 avril 2005 à 21:16
Euh ca c'est du APT...
il est dispo sous Yast, passe par la et mets (enfin essaies de) le à jour par APT .

Là il ya l'air d'avoir des pb de versions entre les packages KDE et à mon avis vaut mieux éviter de n'en mettre que certains à jour.
<div align='right'><{POST_SNAPBACK}> (index.php?act=findpost&pid=34991)[/quote]

quand je tape kdevelop sous yast il trouve rien ??????????
que dois je faire svp http://www.alionet.org/style_emoticons/<#EMO_DIR#>/cool.gif

atlas
05/05/2005, 11h18
J'aie commencé en c++ il ya 6 mois environ puis j'aie arrêté faute de temps et n'aie compris environ que la moitié .

Voici un retour d'expérience ; t'en fait ce que tu veux .

Comme toi je suis parti à la pêche des IDE .
Comme toi j'aie planté sur Kilyx .Résultat abandon
J'aie testé Anjuta (GTK+)(trés prometteur et bien fait) seulement des bugs mal placés m'ont fait reculé
J'aie testé kdevelop et j'aie rien compris et il est un peu buggué .Abandon
Enfin je me suis rabattu sur Qt et là ça a collé .Il te faut juste un éditeur de texte mais j'aie du renoncer à l'habitude d'avoir un débuggueur intégré .Depuis je code un peu en Qt mon niveau reste faible (pas le temps et trop lent aussi http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif )

Voilà ,voilà j'espère t'éviter de perdre du temps .

NB : kdevelop3 est bien dans Yast étonnant que tu ne le trouves pas !