PDA

Afficher la version complète : [Réglé] PC Card WIFI PCMCIA WL110 (orinoco_cs)



Slyce
12/10/2004, 11h15
J'ai une carte PCMCIA Wifi Compaq WL110.

C'est, de source sure, une carte à base de chip Intersil Orinoco Gold. Or quand je pluggue la carte, elle est reconnue en tant que PrismII et du coup ça ne marche pas.
Je voudrais savoir si quelqu'un a déja configuré ce type de carte. A priori c'est un conflit dans la config PCMCIA: il charge les drivers Prism ou orinoco de manière aléatoire et ça cause un conflit.. C'est le bazar . En fait Suse et le wifi, c'est depuis longtemp un peu n'importe quoi.

Help !

galagann
12/10/2004, 12h23
Ceci peut-aider ?
http://lists.suse.com/archive/suse-linux-e...2-Apr/2286.html (http://lists.suse.com/archive/suse-linux-e/2002-Apr/2286.html)

Je continu mes recherches http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

Slyce
12/10/2004, 15h56
Je me réponds à moi-même. Je n'ai pas encore testé, mais il est très probable que ma réponse se trouve là :

http://portal.suse.com/sdb/en/2002/11/wavelan.html

En gros c'est bien un problème de conf PCMCIA. Je vais voir ça ce soir.

J'ai modifié la config et la carte est reconnue ! Chouette ! Bah non. J'ai une autre erreur. La carte et mon point d'acces n'arrivent pas à communiquer. Erreur de type f202. En gros la carte voit mon point d'acces tous les 5 secondes (iwconfig me retourne l'adresse MAC du point d'acces) puis la perd.

Il semble qu'il s'agit d'un bug du firmware de la carte qui tente de récupérer une clé partagée même sans WEP ! Et du coup ils ne se mettent pas d'accord. A priori les pilotes orinoco 0.15rc corrigent, mais je n'arrive pas à les compiler...

Je vous tiens au courant.

Slyce
14/10/2004, 11h28
Bon, j'ai réglé tous mes problèmes.

En fait, la carte était configurée en OpenSystem par défaut, et mon routeur en Shared key, bien que le WEP soit désactivé.

Notez que la SUSE 9.1 ne permet pas via Yast de choisir directement Open, Shared ou WPA. Pour tout ça, il faut obtenir la SuSE 9.2 ! (que j'installe ce soir ou demain !)

Donc je résume pour les posesseurs de cartes Orinoco_cs : n'installez pas le rpm km_wlan (ou un truc du genre). Dans la conf pcmcia, les cartes Orinoco et certaines à base de prism2_xxx ont le même id, à cause du firmware identique à l'origine. Il faut éditer les fichier /etc/pcmcia/config et/ou /etc/pcmcia/wlan-ng.conf pour virer (dans ce dernier) l'entrée...

Maintenant, tout marche chez moi !

boliv@r
14/10/2004, 13h17
<div class='quotetop'>Citation </div>
la SuSE 9.2 ! (que j'installe ce soir ou demain !)[/b]



http://www.alionet.org/style_emoticons/<#EMO_DIR#>/blink.gif

Slyce
14/10/2004, 15h49
Bah oui, je bosse pour Planete Linux !