PDA

Afficher la version complète : [Info] Installation drivers ATI ...



Copernicus_ThebigNewbie
13/10/2004, 23h07
INSTALLATION DRIVERS ATI

Récupération des fichiers
- Commencez par allez chercher les drivers sur le site de SuSE :

NEW URL :

ftp://ftp.suse.com/pub/suse/i386/suppleme...1/fglrx/3.14.6/ (ftp://ftp.suse.com/pub/suse/i386/supplementary/X/ATI/suse91/fglrx/3.14.6/)

/ftp.suse.com/pub/suse/i386/supplementary/X/ATI/suse91/fglrx/3.14.6/

Il s'agit des drivers 3.14.6
- Lisez la doc "Readme" sur le site, même si je vais la redétailler ci-dessous.

Installation des packages
- Installez le package fglrx*.rpm en tant que root :
# rpm -Uhv fglrx*.rpm

Vérifiez que vous avez tous les autres éléments nécessaires pour réaliser une compilation du noyau (même si on en fait pas une réellement )

ATTENTION : IL VOUS FAUT...

les sources du noyau (KERNEL SOURCES),
make (MAKE)
et gcc (GCC).

VERIFIEZ BIEN avec Yast que tout est installé.
Mettez les à jours si vous le désirez (avec YOU ou Apt4Rpm)


- Allez dans les sources du noyau et faites un cloneconfig :

# cd /usr/src/linux
# rm .config
# make cloneconfig
# make prepare-all (pour les noyaux >= 2.6.5-7.75)

- Installez ensuite le km_fglrx*.rpm :

# rpm -Uhv km_fglrx*.rpm

- Puis compilez les modules pour le noyau :

# cd /usr/src/kernel-modules/fglrx

****
Ceci est hors documentation :
Pour les noyaux 2.6.X, allez dans le répertoire /usr/src/kernel-modules/fglrx/2.6.x/
# cd /usr/src/kernel-modules/fglrx/2.6.x/
et faites un make :
# make
puis revenez en arrière :
# cd ..

****

# KERNEL_SOURCE=/usr/src/linux make modules
# KERNEL_SOURCE=/usr/src/linux make install
# depmod -a


Réglages des drivers

- Lancez ensuite SaX2 :
# sax2 -r -m 0=fglrx -b /usr/X11R6/lib/sax/profile/firegl
Mise à part pour l'écran et la résolution graphique, ne touchez pas au pilote vidéo, et n'allez surtout pas enclencher l'accélération 3D. (Sinon, il remplace le driver "fglrx" par "radeon")
N'oubliez pas de bien régler la souris et le clavier (en général, un clavier avec 105 touches Intel)

Faites un test pour voir si tout va bien. Sinon, recommencez.

- Pour avoir l'accélération 3D, éditer le fichier /etc/X11/XF86Config et ajoutez le module DRI :
# vi /etc/X11/XF86Config

Dans la section "module", ajoutez :
Load "dri"
Il suffit de l'écrire de la même façon que pour les autres lignes déjà présentes dans la section "module"

Sauvegardez :
"echap"+":wq"

- Il ne reste plus qu'à rebooter la machine pour que les changements opérés par SaX2 soit appliqués, et surtout pour que le module "fglrx" soit chargés.

- En vous connectant en root, vous pourrez ouvrir le panneau de contrôle d'ATI : "ATI Control"
Il se trouve dans "démarrer" -> Système -> Configuration -> ATI Control
PS : Cela marche aussi sur une session utilisateur. Il demandera juste le mot de passe "root".

- Sinon, sur une session utilisateur, ouvrez une console, et tappez :
> xhost +
Ainsi "root" pourra lancer des applis "graphiques".
Mettez-vous en root :
> su
et lancez l'"ATI Control" :
# fireglcontrol

- Voilà, c'est fini pour les drivers ATI.
C'est peut-être long, mais dans la pratique, cela prend entre 5 et 10 minutes avec le redémarrage. ^^.

Message original de X-Gardian : http://www.pcinpact.com/forum/index.php?showtopic=25247

galagann
14/10/2004, 10h00
Copernicus_ThebigNewbie, merci beaucoup mais X-Guardian est Super-Modérateur ICI => http://www.alionet.org/index.php?act=Stats&CODE=leaders

Copernicus_ThebigNewbie
14/10/2004, 11h32
Oups ... http://www.alionet.org/style_emoticons/<#EMO_DIR#>/ohmy.gif

Tu lui diras qu'il est trés bien fait comme tutorial .. et que cela serait cool de centralisé un max d'info pour les nuls de la Suse comme moi qui a besoin de toutes les lignes de commandes pour pigés un peu ...

Merci X-gardian .... http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif





Enfin j'avais quand même laissé la référence ...

http://www.alionet.org/style_emoticons/<#EMO_DIR#>/rolleyes.gif http://www.alionet.org/style_emoticons/<#EMO_DIR#>/rolleyes.gif

Auze
18/10/2004, 07h12
Bonjour

Voila je viens de suivre le tuto mais j'ai un soucis dés le début !!!

<div class='quotetop'>Citation </div>
# Cd /usr/src/linux
bash: cd: /usr/src/linux: Aucun fichier ou répertoire de ce type[/b]

Pourtant le package est bien installé....

Merci de votre aide http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

++

galagann
18/10/2004, 09h10
Moi aussi, je ne l'ai pas mais je sais pourquoi. C'est parce que j'ai pas télécharger les sources du mon kernel :
nicolas@Alionet:~> su
Password:
Alionet:/home/nicolas # cd ..
Alionet:/home # cd ..
Alionet:/ # cd usr/
Alionet:/usr # cd src/
Alionet:/usr/src # cd linux
bash: cd: linux: Aucun fichier ou répertoire de ce type
Alionet:/usr/src #
Arriver à la ligne "cd linux", entre la commande "ls" qui va te lister les fichiers et répertoires :
Alionet:/usr/src # ls
. .. linux-2.6.8-20041014011424-obj packages
Alionet:/usr/src #

Auze
18/10/2004, 17h59
Bonjour http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

Merci, mais la ya un autre probleme :


Absylone:/user/src # ls
. .. ATI packages

Auze
18/10/2004, 19h21
Ayé !!

J'ai trouvé !!!

Le packages : Kernel-sources n'était pas install !!

Donc maintenant j'ai le repi linux http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif

Mais voia comme c'était trop beau j'ai un nouveau soucis !!! http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif


Absylone:/usr/src/linux # rm .config
Absylone:/usr/src/linux # make cloneconfig
bash: make: command not found

Voila http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

//edit// Non C bon j'ai trouvé.

Je cherche la suite car moi j'ai 20 00 Actions à faire avant de pouvoir passé une étape de ce tuto. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif

Mais sa avance ^^

Thordius
19/10/2004, 23h35
Bonjour a tous http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif
Voila en bon debutant qui se respect j'ai un souci http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif
je vien d'installer mes drivers pour ma radeon 9600 mais en bon newbie que je suis je n'arrive pas a editer mon fichier XF86Config http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif
Pourriez vous m'indiquer la commande a taper pour pouvoir l'editer en mode root?
Merci d'avance http://www.alionet.org/style_emoticons/<#EMO_DIR#>/rolleyes.gif

yankee
11/11/2004, 00h48
le plus simple, mais pas le moins risquer (y'en as qui vont hurler)http://www.alionet.org/style_emoticons/<#EMO_DIR#>/rolleyes.gif ,
tu te logge en session root, et tu ouvre ton fichier a editer, clik droit, ouvrir avec, tu choisi l'editeur de ton choix, tu modifie comme ds un fichier texte, tu sauve, tu quitte root, et voila.
La sagesse voudrais que je te dise de d'abord prevoir une copie au cas, ou, mais suse y avais deja penser et sauver ton fichier avant modif en ~x86....

jrev
02/12/2004, 10h10
Originally posted by Copernicus_ThebigNewbie@mercredi 13 octobre 2004 à 22:07
J'ai trouver cela sur un forum ... peut aider certaines personnes

Bravo tu pourrais pas venir faire ça chez moi ?
merci d'avance

INSTALLATION DES DRIVERS ATI

llanis
31/03/2005, 17h02
J'essaie de paramétrer mais rien ne marche, vous pourriez me dire comment on annule les insall des deux fichiers de config ATI ??
Merci à vous... http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

llanis
04/04/2005, 15h06
http://www.alionet.org/style_emoticons/<#EMO_DIR#>/mad.gif Un petit UP, donc en fait j'ai réinstaller la suse 9.2 et j'ai suivi le readme donné dans le répertoire ftp des drivers de ma version de suse puis j'ai édité le fichier X86Config et ajouté Load "dri" mais sax2 ne me dit pas que j'ai l'accélération 3D et le test de performances 3D de Point2Play me signifie que je n'ai pas non plus l'accélération 3D...

Pouvez-vous m'aider ??

PS : # modprobe fglrx -> ne me dit rien, il m'affiche juste le répertoire dans lequel je suis avant de taper modprobe.

Sinon j'ai un portable avec une radéon 9600....... http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

siko
05/04/2005, 06h45
Que Sax2 ne voie pas la 3D c'est normal avec le drive Ati.

Tu n'as pas un fichier /etc/X11/xorg.conf qui traine et qui n'est pas corrigé car le serveur X cherche en premier le fichier xorg.conf et ensuite X86Config.

La commande modprobe ne retourne rien si elle s'exécute correctement.

Neolinux
05/04/2005, 09h11
Salux !

Es-tu allé voir ici (http://www.alionet.org/index.php?showtopic=571&view=findpost&p=29605) ?

Si à la fin, la commande :
# glxinfo | grep direct
retourne une réponse positive, ce sera bon.

Perso, c'est seulement la commande :
# glxinfo | grep ender
qui retourne un résultat positif avec les conséquences que je décris dans le post suivant.

llanis
05/04/2005, 16h24
En fait j'ai aussi éditer le fichier xorg.conf et le "dri" y est inscrit...
Donc je vais tester ce que tu me propose et voir ce que ça donne.
Mais ce que je ne comprend pas c'est que Point2play ne me signifie pas l'accélération 3D !!