PDA

Afficher la version complète : package org.kde.qt



JuTs
02/10/2005, 23h44
Salut

Je tente de m'initier à l'utilisation de KDevelop. J'ai créé une projet Java/KDE (Menu Projet -> Nouveau projet -> java -> KDE)

A la compilation j'obtiens testjava.java:6: package org.kde.qt does not exist

ok le package n'est pas trouvé, là c'est clair. Ma question : où se trouve-t-il ?

galagann
03/10/2005, 14h41
Vérifie que tu as bien les librairies de Qt

JuTs
03/10/2005, 15h24
Apparement j'ai tout ce qu'il faut.

Il me semble que le package se trouve dans

kdebindings3-java, la description indique : Needed libraries to write applications in Java for Qt and KDE
Je l'ai installé mais cela ne fonctionne pas.

galagann
03/10/2005, 15h44
Bon, je supose que tu as c'est 2 packetages d'installer : kdebindings3 et kdebindings3-java mais est-ce que celui là est bien présent : "kdelibs3" ?

JuTs
03/10/2005, 16h06
Oui, il est là

galagann
03/10/2005, 16h22
As-tu la possibilité d'ignoré ce message d'erreur ?
Ou de faire une compilation à la main.

Spyhawk
03/10/2005, 18h38
Galagann > Qt et KDElibs sont avec kdebase3 les paquets de base d'une install KDE.

Donc si KDevelopp est installé, Qt et KDElibs le sont de toute facon aussi http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif

JuTs
03/10/2005, 19h43
Je ne pense pas.

Toutes les erreurs que j'ai sont certainement là parce que ces deux imports ne se font pas

import org.kde.qt.*;
import org.kde.koala.*;

Spyhawk
03/10/2005, 21h42
Ca semble etre un bug de kde 3.4.
http://bugs.kde.org/show_bug.cgi?id=112409

JuTs
03/10/2005, 21h49
Je ne peux donc rien faire pour le moment .

Spyhawk
03/10/2005, 21h54
Tu peux peut etre utiliser Eclipse pour tes dev Java ?

JuTs
03/10/2005, 23h21
Il y a possibilité d'utilier Qt ? Si oui, ça m'arrangerait, je connais KDevelop depuis 2 jours seulement. Eclipse je l'utilise depuis ~10 mois.

galagann
04/10/2005, 15h48
Spyhawk, même s'il passe dans la dernière version de KDE, la 3.4.2 ?

Spyhawk
04/10/2005, 16h13
Le bug est repertorié pour KDE 3.4.0. Je ne sais pas s'il a été corrigé dans les versions suivantes...

JuTs
04/10/2005, 16h23
Ok,
Je vais attendre SuSE 10 et je verrai à ce moment là si c'est bon