PDA

Afficher la version complète : [Réglé] suse 10.0 : modem usb b-focus



flatt*
23/10/2005, 19h35
bonsoir tout le monde, voila étant un nouveau utilisateur de linux je ne connais pas grand chose.
Quelqu' un pour m' indiquer la démarche à suivre pour installer un modem USB B-focus ( wanadoo ) sous suse 10.0 .
Il semblerai que le gestionnaire de périphériques usb ne soit pas activé mais je ne sais pas où l'activer.
J'aimerais de l'aide merci beaucoup. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/rolleyes.gif

ps : je suis vraiment un débutant http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

galagann
23/10/2005, 19h56
Salux jeune Linuxien,

Déjà, on va vérifié que ton modem est reconnu, pour cela ta va aller dans une console en mode root (commande "su") puis entre la commande suivante : lsusb
Vérifie que ton modem est dedans, si tu n'es pas sur donne nous le résultat.

Ensuite en ce qui concerne le driver c'est celui ci : http://eciadsl.flashtux.org

flatt*
23/10/2005, 20h21
merci pour ta réponse rapide voici le résultat :
Bus 002 device 001 : ID: 0000:0000
Bus 001 device 003 : ID: 1532:0002
Bus 001 device 002 : ID: 0547:2131 Anchor chips, Inc , AN2131 EZUSB MicroController
Bus 001 device 001 : ID: 0000:0000

Ca donne à peu près ca :s
Voila le verdict donc ?

galagann
23/10/2005, 20h41
En gros, bonne nouvelle car il est reconnu http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif
Il te suffit de suivre ce tutoriel http://eciadsl.flashtux.org/tutorial.php

james70
23/10/2005, 22h00
J'ai ce modem !
Il fonctionne parfaitement sur toutes les distribs, merci aux développeurs libres.

flatt*
24/10/2005, 09h51
d' accord merci beaucoup pour vos réponse.
juste petit probleme la je suis sur windows http://www.alionet.org/style_emoticons/<#EMO_DIR#>/unsure.gif ( oui je sais : BOUHHHH http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif) donc je télécharge les pilotes, le seul moyen que j'ai pour transférer les pilotes pour linux sous suse est ma clé usb mais comment la faire marcher sous linux ?
ps : c' est une clé usb générique qui fait lecteur mp3 (S320)

merci d'avance pour vos prochaines réponses http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif


edit : les pilotes dois-je prendre pour suse 10.0 :

ources (gzip) download eciadsl-usermode-0.11.tar.gz (315 Ko)
Sources (bzip2) download eciadsl-usermode-0.11.tar.bz2 (263 Ko)
Mandriva/Redhat 9.0 logo_mdk_small * Non disponible * (eciadsl-usermode-0.11-1.i386.rpm)
Fedora Core 4 logo_fedora_small eciadsl-usermode-0.11-1.i386.rpm (222 Ko)
Debian i386 logo_debian_small eciadsl-usermode_0.11-1_i386.deb (202 Ko)
Debian AMD64 logo_debian_small eciadsl-usermode_0.11-1_amd64.deb (215 Ko)
Debian ppc logo_debian_small * Non disponible * (eciadsl-usermode_0.11-1_powerpc.deb)
Slackware logo_slackware_small * Non disponible * (eciadsl-usermode-0.11-i386-1.tgz)
Gentoo logo_gentoo_small eciadsl-usermode-0.11.ebuild (1 Ko)
Crux Linux logo_crux_small * Non disponible * (eciadsl-0.11.tar.bz2)
Patch kernel 2.4.28 > .30 download 2.4.28-usb-devio.patch (4 Ko)
Patch kernel 2.6.x download 2.6.x-usb.patch (1 Ko)
Patch packet size download packet_size.patch (1 Ko)

Est ce que je dois prendre le patch aussi. merci http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

james70
24/10/2005, 11h27
Il n'y a pas de driver au format rpm pour Suse donc il faut utiliser soit le tar.gz, soit le tar.bz2.
Donc par exemple le fichier : eciadsl-usermode-0.11.tar.gz.
N'oublie pas de télécharger également le fichier : http://eciadsl.flashtux.org/download/eciad...nch_bin.tar.bz2 (http://eciadsl.flashtux.org/download/eciadsl-synch_bin.tar.bz2).
Pour ta clé usb, dès insertion normalement si tout se passe bien tu verras un icône apparaître sur le bureau de KDE, Gnome je sais pas.

flatt*
24/10/2005, 13h18
Bon ma clé est détecter de ce coté pas de probleme. apres avoir extrait les pilotes je tape dans le terminal :
modprobe -r dabusb && rm -f $(modprobe -l | grep dabusb) && depmod -a

Qui a pour résultat d' effacer mon fichier blacklist est ce normal ? et du coup suse de démarre plus elle reste bloquée sur l' écran de démarrage http://www.alionet.org/style_emoticons/<#EMO_DIR#>/huh.gif
Quelqu ' un peut m'aider ?
http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

james70
24/10/2005, 13h35
<div class='quotetop'>Citation </div>
modprobe -r dabusb && rm -f $(modprobe -l | grep dabusb) && depmod -a[/b]
dabusb ?
Je regarde sur ma Mandriva ...
#modprobe -l | grep dabusb
#/lib/modules/2.6.12-12mdk/kernel/drivers/usb/media/dabusb.ko.gz
Oui, ce module existe toujours mais il ne gêne plus eciadsl comme dans le passé donc ta ligne en mode commande ne sert à rien.
(tu demandes à décharger un module qui n'est pas chargé et ensuite tu l'effaces pour être sûr qu'il ne se chargera jamais plus ... c'est un peu bourrin).
Pour vérifier si le module est chargé :
#lsmod | grep dabusb
Si il n'y a pas de réponse, c'est qu'il ne l'est pas, cela doit être ton cas...

As-tu copié les fichiers synchro dans /etc/eciadsl ?
As-tu tapé eciadsl-config-tk pour rentrer tes paramètres de connection ?

flatt*
24/10/2005, 13h58
ben j' ai suivi le tuto cité plus haut.
Bon suse de démarre plus je peut plus rien faire.
http://www.cs-view.com/upload/view.php?choual=ee5532941b.jpg
voila où elle bloque.

est ce un rapport avec la suppréssion du fichier black list ?
si oui est ce qu avec le cd1 d' installer on peut réparer la manip ?
merci d'avance

james70
24/10/2005, 15h10
Je ne vois pas le rapport entre ta ligne de commande et le fichier blacklist ... tu as dû faire plusieurs manips qui ne vont pas bien ensemble ...
<div class='quotetop'>Citation </div>
si oui est ce qu avec le cd1 d' installer on peut réparer la manip ?[/b]
Essaie ! (modem débranché).