PDA

Afficher la version complète : [Réglé] Installation dongle USB TRENDNET TEW 424UB



Berlinois
04/11/2005, 22h32
Salut,

Je voudrais installer un dongle Trendnet Tew424UB avec la suse 10.0

J'ai essayé avec les pilotes Wiw et ndiswrapper.

Lorsque je fais ndiwrapper -l j'ai juste
Installed ndis drivers:
sis163u driver present

Pourtant la clé est bien connecté.

Est ce que quelqu'un pourrait m'aider j'aimerais bien me débarasser du cable ethernet.

J'ai bien tenter la méthode trouvée sur sourceforge.net avec le pilote ZD1211 mais pareil j'ai rien.

Petite question con, dois je désinstaller ma carte ethernet PCI ??

Merci pour vos réponses.

galagann
04/11/2005, 22h40
Salux,

Que donne la commande : hwinfo --usb et lsusb ? (Mode root dans une console).

Berlinois
04/11/2005, 22h45
Pour lsusb j'ai :
Bus 007 Device 006: ID 0ace:1211 ZyDAS 802.11b/g USB2 WiFi

Pour hwinfo --usb j'ai (je ne mets que ce qui concerne la clé Wifi car j'ai pas mal de choses en usb)
14: USB 00.0: 0000 Unclassified device
[Created at usb.122]
UDI: /org/freedesktop/Hal/devices/usb_device_ace_1211_noserial_if0
Unique ID: wzl7.1HPlSPIKalC
Parent ID: BSFT.lv3Z+UtPDpF
SysFS ID: /devices/pci0000:00/0000:00:08.3/usb7/7-4/7-4:1.0
SysFS BusID: 7-4:1.0
Hardware Class: unknown
Model: "USB 2.0 802.11 b+g WLAN"
Hotplug: USB
Vendor: usb 0x0ace "USB 2.0"
Device: usb 0x1211 "802.11 b+g WLAN"
Revision: "43.30"
Speed: 480 Mbps
Module Alias: "usb:v0ACEp1211d4330dcFFdscFFdpFFic*isc*ip*"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #13 (Hub)

galagann
04/11/2005, 23h04
Que donne la commande "iwconfig" ?

Berlinois
04/11/2005, 23h12
Ca me donne ceci :
lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.

galagann
04/11/2005, 23h24
En allant un peu plus loin sur le net, j'ai trouvé ce lien : http://zd1211.ath.cx/zd1211

Le driver est ici : http://sourceforge.net/projects/zd1211

Installation : Make sure you have your kernel sources in /usr/src/linux
Make sure your kernel is compiled with wireless extensions (CONFIG_NET_WIRELESS) and USB support
Make sure iwconfig is installed (Debian: wireless-tools package)
Download latest drivers
untar, make, make install
insmod zd1211_mod
ifconfig wlan0 up
iwconfig wlan0 essid youressid
dhclient wlan0

offworld
05/11/2005, 01h19
Salut, pour ndiswrapper regarde si /etc/ndiswrapper/sis163u/ tu as le fichier 0ace:1211.0.conf
Si c un autre nom renomme le.
ndiswrapper -l devrais t'afficher hardware present.
ensuite #depmod -a
et #modprobe ndiswrapper

Berlinois
05/11/2005, 09h50
Salut, pour ndiswrapper regarde si /etc/ndiswrapper/sis163u/ tu as le fichier 0ace:1211.0.conf
Si c un autre nom renomme le.
ndiswrapper -l devrais t'afficher hardware present.
ensuite #depmod -a
et #modprobe ndiswrapper[/b]
Le problème tient à ce que j'obtiens :

linux:/etc/ndiswrapper/sis163u # dir
total 300
drwxr-xr-x 2 root root 400 2005-11-05 08:39 .
drwxr-xr-x 3 root root 72 2005-11-05 08:39 ..
-rw-r--r-- 1 root root 797 2005-11-05 08:39 0457:0163.0.conf
-rw-r--r-- 1 root root 797 2005-11-05 08:39 0769:11F7.0.conf
-rw-r--r-- 1 root root 797 2005-11-05 08:39 0B3B:0163.0.conf
-rw-r--r-- 1 root root 797 2005-11-05 08:39 0D8E:0163.0.conf
-rw-r--r-- 1 root root 797 2005-11-05 08:39 1371:0021.0.conf
-rw-r--r-- 1 root root 797 2005-11-05 08:39 1371:0022.0.conf
-rw-r--r-- 1 root root 797 2005-11-05 08:39 1371:0023.0.conf
-rw-r--r-- 1 root root 797 2005-11-05 08:39 18E8:6171.0.conf
-rw------- 1 root root 24701 2005-11-05 08:39 sis163u.inf
-rw-r--r-- 1 root root 196608 2005-11-05 08:39 sis163u.sys
-rw-r--r-- 1 root root 49152 2005-11-05 08:39 unwlsdrv.exe

Lequel je dois renommer http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif

Edit : J'ai renommer le premier 0457:0163.0.conf et j'ai bien Harware present lors d'un ndiswrapper -l

<div class='quotetop'>Citation (galagann @ vendredi 04 novembre 2005 à 22:24) <{POST_SNAPBACK}> (index.php?act=findpost&pid=61937)</div>
En allant un peu plus loin sur le net, j'ai trouvé ce lien : http://zd1211.ath.cx/zd1211

Le driver est ici : http://sourceforge.net/projects/zd1211

Installation : Make sure you have your kernel sources in /usr/src/linux

Make sure your kernel is compiled with wireless extensions (CONFIG_NET_WIRELESS) and USB support

Make sure iwconfig is installed (Debian: wireless-tools package)

Download latest drivers

untar, make, make install

insmod zd1211_mod

ifconfig wlan0 up

iwconfig wlan0 essid youressid

dhclient wlan0
[/b]
Lorsque j'essaie ceci j'obtiens cela :

# make
make V=0 -C /usr/src/linux SUBDIRS=/home/joel/sf_zd1211_20050822_src/zd1211/src/modules-2.6.13-default modules
make[1]: Entering directory `/usr/src/linux-2.6.13-15'

WARNING: Symbol version dump /usr/src/linux-2.6.13-15/Module.symvers
is missing; modules will have no dependencies and modversions.

Building modules, stage 2.
MODPOST
make[1]: Leaving directory `/usr/src/linux-2.6.13-15'

http://www.alionet.org/style_emoticons/<#EMO_DIR#>/bang.gif

offworld
05/11/2005, 17h34
Utilise plutot ndiswrapper dans un premier temp, garde la compil des drivers pour quand tu aura plus de maitrise.

Dand /etc/ndiswrapper/sis163u, suprime:

-rw-r--r-- 1 root root 797 2005-11-05 08:39 0769:11F7.0.conf
-rw-r--r-- 1 root root 797 2005-11-05 08:39 0B3B:0163.0.conf
-rw-r--r-- 1 root root 797 2005-11-05 08:39 0D8E:0163.0.conf
-rw-r--r-- 1 root root 797 2005-11-05 08:39 1371:0021.0.conf
-rw-r--r-- 1 root root 797 2005-11-05 08:39 1371:0022.0.conf
-rw-r--r-- 1 root root 797 2005-11-05 08:39 1371:0023.0.conf
-rw-r--r-- 1 root root 797 2005-11-05 08:39 18E8:6171.0.conf

-rw-r--r-- 1 root root 49152 2005-11-05 08:39 unwlsdrv.exe

Ca ne sert a rien.
Comme il reconnais ta carte depmod -a
et modprobe ndiswrapper

Berlinois
06/11/2005, 11h41
Maintenant quand je lance modprobe ndiswrapper plantage digne de windows avec freeze total de l'ordi.

De plus j'ai fait une mise à jour hasardeuse et maintenant j'ai plus rien.

Plus qu'à sortir le ghost http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

adminlinux
06/11/2005, 11h57
driverloader.com http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

galagann
06/11/2005, 12h12
Salux,

Après plus de recherche, j'ai retrouvé le produit sur le site : http://www.trendnet.com/fr/products/TEW-424UB.htm
Cependant, il y a deux version différente, une A et une V2, http://www.trendnet.com/fr/downloads/info/TEW-424UB.htm, aucune information sur la différence dans les compossants.

En ce qui concerne "ndiswrapper", laisse tombé car chaque personne qui on fait le test, on complètement perdu leur système http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif

Cependant, la solution est bien sur le driver ZD1211 : http://sourceforge.net/projects/zd1211 et http://zd1211.ath.cx/zd1211

Berlinois
06/11/2005, 12h26
Salux,

Après plus de recherche, j'ai retrouvé le produit sur le site : http://www.trendnet.com/fr/products/TEW-424UB.htm
Cependant, il y a deux version différente, une A et une V2, http://www.trendnet.com/fr/downloads/info/TEW-424UB.htm, aucune information sur la différence dans les compossants.

En ce qui concerne "ndiswrapper", laisse tombé car chaque personne qui on fait le test, on complètement perdu leur système http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif

Cependant, la solution est bien sur le driver ZD1211 : http://sourceforge.net/projects/zd1211 et http://zd1211.ath.cx/zd1211[/b]
Ca sera pour une autre fois, faut d'abord que je fasse une copie du disque ghost que jeme suis fait et que je mette à jour via Yast avant.

Après on se lancera dans la recompilation du noyau.

Sinon question subsidiaire, quelle carte PCI WIFI fonctionne bien sous Linux (et plus généralement sous la Suse) ??

Autant acheter une solution qui fonctionne bien dès le départ.

Berlinois
06/11/2005, 13h55
driverloader.com http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif[/b]
Dès que le ghost est fini je vais tenter ces pilotes.

offworld
06/11/2005, 14h38
En vifi j'utilise une rt2500 pour le AP et deux rt2570 pour les portables. Aucun probleme, les modules se compile parfaitement.
Linux c'est pas windows, il peu se freeze le temp de charger les modules, tu lui as laissé combien de temp pour se defreezé seul?

Berlinois
06/11/2005, 15h41
En vifi j'utilise une rt2500 pour le AP et deux rt2570 pour les portables. Aucun probleme, les modules se compile parfaitement.
Linux c'est pas windows, il peu se freeze le temp de charger les modules, tu lui as laissé combien de temp pour se defreezé seul?[/b]
Cinq bonnes minutes.

Je n'avais plus aucune réponse même en voulant aller en console.

Driverloader ne donne rien malheureusement.

Je vais me lancer dans une recompilation on verra bien.

<div class='quotetop'>Citation (galagann @ vendredi 04 novembre 2005 à 22:24) <{POST_SNAPBACK}> (index.php?act=findpost&pid=61937)</div>
En allant un peu plus loin sur le net, j'ai trouvé ce lien : http://zd1211.ath.cx/zd1211

Le driver est ici : http://sourceforge.net/projects/zd1211

Installation : Make sure you have your kernel sources in /usr/src/linux

Make sure your kernel is compiled with wireless extensions (CONFIG_NET_WIRELESS) and USB support

Make sure iwconfig is installed (Debian: wireless-tools package)

Download latest drivers

untar, make, make install

insmod zd1211_mod

ifconfig wlan0 up

iwconfig wlan0 essid youressid

dhclient wlan0
[/b]
Et on fait comment pour le vérifier ceci ??

offworld
06/11/2005, 15h56
<div class='quotetop'>Citation </div>
Make sure you have your kernel sources in /usr/src/linux[/b]
A installer : kernel-header ou linux-header de la version de ton noyaux.
<div class='quotetop'>Citation </div>
Make sure your kernel is compiled with wireless extensions (CONFIG_NET_WIRELESS) and USB support[/b]
Devrai pas avoir de probleme
<div class='quotetop'>Citation </div>
Make sure iwconfig is installed (Debian: wireless-tools package)[/b]
Ca c le paquet qui contient iwconfig (entre autre), tu doit deja l'avoir.
<div class='quotetop'>Citation </div>
untar, make, make install[/b]
Procedure de fabrication du modulet
tar -xzf ton_archive.tar.gz
cd repertoire_creer_par _l'archive
make
make install (si aucune erreure a make).
<div class='quotetop'>Citation </div>
insmod zd1211_mod[/b]
Installation du module, tu peux aussi faire modprobe zd1211_mod
<div class='quotetop'>Citation </div>
ifconfig wlan0 up
iwconfig wlan0 essid youressid
dhclient wlan0[/b]
Oublie, passe par yast pour la configuration.

Berlinois
06/11/2005, 19h57
untar, make, make install


Procedure de fabrication du modulet
tar -xzf ton_archive.tar.gz
cd repertoire_creer_par _l'archive
make
make install (si aucune erreure a make).


J'ai pas d'erreur mais des warnings


insmod zd1211_mod
Installation du module, tu peux aussi faire modprobe zd1211_mod
[/quote]

Là ca bloque, j'ai comme message :

# modprobe zd1211_mod
FATAL: Module zd1211_mod not found.


ifconfig wlan0 up
iwconfig wlan0 essid youressid
dhclient wlan0


Je commence à me demander si c'est bien le bon pilote finalement.

Désolé pour le message mais là je ne comprends pas pourquoi il (je) quote pas correctement

offworld
07/11/2005, 00h14
J'ai marqué zd1211_mod mais c'est certainement pas le nom du module. regarde dans le repertoire fais une recherche de ton module, en recherchant zd1211. ton module dois finir par .ko

Berlinois
07/11/2005, 15h47
J'ai marqué zd1211_mod mais c'est certainement pas le nom du module. regarde dans le repertoire fais une recherche de ton module, en recherchant zd1211. ton module dois finir par .ko[/b]
Wich one ???

Je débute en matière de recompilation et d'intégration de pilote dans le noyau.

Jusque maintenant la seule fois où j'ai touché au noyau c'est pour intégrer le pilote ATI (enfin j'ai compris que ca faisait cela).

Berlinois
07/11/2005, 18h05
J'ai marqué zd1211_mod mais c'est certainement pas le nom du module. regarde dans le repertoire fais une recherche de ton module, en recherchant zd1211. ton module dois finir par .ko[/b]
Bon j'ai trouvé, j'ai deux références à un fichier zd1211_mod.ko un dans le répertoire ou j'ai décompressé le tar et un autre dans un autre répertoire où il fait mention du n° du noyau EDIT : exactement c'est ke répertoire /lib/modules/2.6.13-default/net/

Mais quand je fais modprobe zd1211_mod.ko (ou insmode) j'ai cette erreur :

# modprobe zd1211_mod.ko
FATAL: Module zd1211_mod.ko not found.

Bref je ne comprends pas trop. Je vais passer à une carte PCI ou rester avec un cable à la patte.

offworld
07/11/2005, 23h13
Etant donné qu'il est dans /lib/module/ tu ne devrais pas avoir a ecrir .ko.
Fais #lsmod|grep zd12
pour voir s'il ne serais pas charger.
sinon essai modprobe zd1211
les repertoires creer pendant la compillation dans /usr/src, tu peu les suprimer.

Berlinois
08/11/2005, 18h53
Fais #lsmod|grep zd12
pour voir s'il ne serais pas charger.[/b]

Quand je tapes cette commande j'ai.... rien il me redonne la main sans rien dire.

<div class='quotetop'>Citation </div>
sinon essai modprobe zd1211
les repertoires creer pendant la compillation dans /usr/src, tu peu les suprimer.[/b]
Voila la réponse de cette bone chère Suse

# modprobe zd1211
FATAL: Module zd1211 not found.

Est ce que la compilation s'est mal faite ???

Pourtant comme je te l'indiquais je l'ai dans lib/module effectivement

offworld
09/11/2005, 01h51
C'est pas normal, la commande devrais etre #modprobe zd1211_mod
Place toi dans /lib/modules/2.6.13-default/net/ et tape la commande #insmod zd1211_mod.ko

Poupine
09/11/2005, 14h25
Bonjour !!! Excusez moi de mettre un message dans ce post mais j'ai la même clef Usb et voila mes constatations :
avec ndiswrapper > il ne se passe rien ! il ne m'installe rien dans le repertoire nidiswrapper ??

avec les drivers zd1211 tout s'installe !!! une fois que j'ai fait iwconfig wlan0 up et que je fais ensuite hwinfo --usb il me met rien dans "lo" dans "eth0" il me met le descriptif de la clef Wifi " et dans "sit0" il n'y a rien !!

De plus quand je tappe iwconfig wlan0 essid "le nom de mon reseau" il me dit "essid error" tapper help pour plus d'option ??

maintenant que ma clef usb est installée je suis bloquée dans la config dans Yast car je ne sais pas quoi mettre dans les caracs du wlan0 pouvez-vous aider la pauvre Linuxienne débutante que je suis !!!

D'avance merci !!!

P.S : j'ai oublié de préciser que c'était la même clef Wifi et que j'étais sous Suse 10.0 Evaluation version

D'avance merci !!! et désolé de m'intégrer dans ce post mais je ne voyais pas l'utilité d'en crée un deuxieme !!

http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif

offworld
09/11/2005, 17h09
Salut, affiche le resultat de : iwconfig

Berlinois
09/11/2005, 18h28
Bon j'abandonne car je ne comprends pas pourquoi cela ne fonctionne pas chez moi.

Pour le fun j'ai retenter une compilation de zd1211 et j'obtiens ceci

# make
make V=0 -C /usr/src/linux SUBDIRS=/home/joel/zd1211/src/modules-2.6.13-default
modules
make[1]: Entering directory `/usr/src/linux-2.6.13-15'

WARNING: Symbol version dump /usr/src/linux-2.6.13-15/Module.symvers
is missing; modules will have no dependencies and modversions.

Building modules, stage 2.
MODPOST
make[1]: Leaving directory `/usr/src/linux-2.6.13-15'
linux:/home/joel/zd1211 # make install
make V=0 -C /usr/src/linux SUBDIRS=/home/joel/zd1211/src/modules-2.6.13-default modules
make[1]: Entering directory `/usr/src/linux-2.6.13-15'

WARNING: Symbol version dump /usr/src/linux-2.6.13-15/Module.symvers
is missing; modules will have no dependencies and modversions.

Building modules, stage 2.
MODPOST
make[1]: Leaving directory `/usr/src/linux-2.6.13-15'
mkdir -p /lib/modules/2.6.13-default/net
cp /home/joel/zd1211/src/modules-2.6.13-default/zd1211_mod.ko /lib/modules/2.6.1 3-default/net
depmod -a
gcc -o apdbg tools/apdbg.c
chmod +x apdbg
cp ./apdbg /usr/local/sbin/apdbg
linux:/home/joel/zd1211 # modprobe zd1211_mod.ko
FATAL: Module zd1211_mod.ko not found.

Et ce que je me mette dans /lib/modules/2.6.13-default/net où se trouve un fichier zd1211_mod.ko ou pas d'ailleurs.

Bref je ne comprends rien et je ne sais plus quoi faire.

offworld
09/11/2005, 18h33
# modprobe zd1211_mod
On ne met pas .ko quand on fait un modprobe.

Berlinois
09/11/2005, 18h47
# modprobe zd1211_mod
On ne met pas .ko quand on fait un modprobe.[/b]
Voila ce que j'obtiens quand je fais modprobe zd1211_mod dans le répertoire /lib/modules/2.6.13-default/net où se trouve donc le fichier zd1211_mod.ko

linux:/lib/modules/2.6.13-default/net # dir
total 204
drwxr-xr-x 2 root root 80 2005-11-06 14:08 .
drwxr-xr-x 3 root root 72 2005-11-06 14:08 ..
-rw-r--r-- 1 root root 206887 2005-11-09 17:26 zd1211_mod.ko
linux:/lib/modules/2.6.13-default/net # modprobe zd1211_mod
FATAL: Module zd1211_mod not found

Je plane totalement.

Poupine
09/11/2005, 19h42
Salut, affiche le resultat de : iwconfig[/b]

voici se qu'il me marque :

lo no wireless extensions.

wlan0 802.11b/g NIC ESSID:""
Mode:Managed Frequency=2.472 GHz Acces Point: 00:00:00:00:00:00
Bit Rate: 1 Mb/s
Retry:off RTS thr=2432b Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:161
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

Par contre je ne comprends pas pourquoi mais depuis aujourd'hui je suis obligée de faire un "ifconfig wlan0 up" pour activer la clef USb ?? Est-ce normal ??

Merci d'avance pour les réponses !!!

offworld
09/11/2005, 20h58
<div class='quotetop'>Citation (offworld @ mercredi 09 novembre 2005 à 17:33) <{POST_SNAPBACK}> (index.php?act=findpost&pid=62565)

# modprobe zd1211_mod
On ne met pas .ko quand on fait un modprobe.[/b]
Voila ce que j'obtiens quand je fais modprobe zd1211_mod dans le répertoire /lib/modules/2.6.13-default/net où se trouve donc le fichier zd1211_mod.ko

linux:/lib/modules/2.6.13-default/net # dir
total 204
drwxr-xr-x 2 root root 80 2005-11-06 14:08 .
drwxr-xr-x 3 root root 72 2005-11-06 14:08 ..
-rw-r--r-- 1 root root 206887 2005-11-09 17:26 zd1211_mod.ko
linux:/lib/modules/2.6.13-default/net # modprobe zd1211_mod
FATAL: Module zd1211_mod not found

Je plane totalement.
[/b][/quote]

Pareil pour moi.

<div class='quotetop'>Citation (Poupine @ mercredi 09 novembre 2005 à 18:42) <{POST_SNAPBACK}> (index.php?act=findpost&pid=62574)</div>
<div class='quotetop'>Citation (offworld @ mercredi 09 novembre 2005 à 16:09) <{POST_SNAPBACK}> (index.php?act=findpost&pid=62554)

Salut, affiche le resultat de : iwconfig[/b]

voici se qu'il me marque :

lo no wireless extensions.

wlan0 802.11b/g NIC ESSID:""
Mode:Managed Frequency=2.472 GHz Acces Point: 00:00:00:00:00:00
Bit Rate: 1 Mb/s
Retry:off RTS thr=2432b Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:161
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

Par contre je ne comprends pas pourquoi mais depuis aujourd'hui je suis obligée de faire un "ifconfig wlan0 up" pour activer la clef USb ?? Est-ce normal ??

Merci d'avance pour les réponses !!!
[/b][/quote]

Oui, iwconfig sert a parametrer l'interface. ifconfig sert a l'activer.
Pour ton erreur avec le essid, ca mais deja arriver en testant des drivers beta avec d'autre carte.

Question pour tous les deux : Quelle sont les pilotes que vous avez utilisé (lien vers l'archive)?
Quelle est la version de votre noyau, de kde, de modprobe?
Quelle sont les paquets que vous avez du rajouter pour compiller le driver?

Poupine
09/11/2005, 21h11
Comme driver j'ai utilise celui-ci : http://sourceforge.net/projects/zd1211

Quelle est la version de votre noyau, de kde, de modprobe?
Quelle sont les paquets que vous avez du rajouter pour compiller le driver?

Alors la j'ai la version de base 10.0 evaluation et je n'ai pas rajouter de paquets pour le driver....

Peux-tu me donner les commandes shell pour savoir les versions KDE, modprob .... comme ca je rebascule sous Linux et je note tout ça !!!

Je suis désolé mais je débute avec le shell ............ http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

offworld
09/11/2005, 21h32
modprove -V
Pour kde : C'est dans le centre de configuration
Fait dans une console ls -l /usr/src et affiche le resultat.

Download sf_zd1211_20050822_src.tar.gz

Download sf_zd1211_20050315_src.tar.gz

Download sf-zd1211-4916-src.tar.gz

Download sf-zd1211-4715-src.tar.gz

Quelle version exactement?

Ton lien me permet de voir que c'est des drivers en version beta.

Berlinois : Ton probleme est repertorier : http://sourceforge.net/tracker/index.php?f...083&atid=713754 (http://sourceforge.net/tracker/index.php?func=detail&aid=1311600&group_id=129083&atid=713754)

Poupine
09/11/2005, 22h41
Alors voila les résultats :

Modprobe -V > module-init-tools version 3.2-pre 8

kde > 3.4.2 level "B"

ls -l /usr/src > :

total 2

drwxr-xr-x 8 root root 280 2005-11-08 19:13
drwxr-xr-x 12 root root 344 2005-11-08 18:26
drwxr-xr-x 2 root root 128 2005-11-08 19:13 ATI
drwxr-xr-x 23 root root 776 2005-11-08 18:13 dicts
drwxr-xr-x 22 root root 672 2005-11-08 18:18 kernel-modules
lrwxrwxrwx 1 root root 15 2005-11-08 18:18 linux > linux-2.6.13-15
drwxr-xr-x 19 root root 752 2005-11-08 18:18 linux-2.6.13-15
drwxr-xr-x 3 root root 72 2005-09-13 20:14 linux-2.6.13-15-obj
lrwxrwxrwx 1 root root 19 2005-11-08 18:18 linux-obj > linux-2.6.13-15-obj
drwxr-xr-x 7 root root 168 2005-11-08 18:32 packages

pour le driver j'ai utilisé : sf_zd1211_20050822_src.tar.gz

voila les infos que tu m'as demandé ... Merci de me consacrer un peu de ton temps ........

offworld
09/11/2005, 23h15
J'attend la reponse de berlinois, et je compare tous ca.

Berlinois
10/11/2005, 09h37
modprove -V
Pour kde : C'est dans le centre de configuration
Fait dans une console ls -l /usr/src et affiche le resultat.

Download sf_zd1211_20050822_src.tar.gz

Download sf_zd1211_20050315_src.tar.gz

Download sf-zd1211-4916-src.tar.gz

Download sf-zd1211-4715-src.tar.gz

Quelle version exactement?

Ton lien me permet de voir que c'est des drivers en version beta.

Berlinois : Ton probleme est repertorier : http://sourceforge.net/tracker/index.php?f...083&atid=713754 (http://sourceforge.net/tracker/index.php?func=detail&aid=1311600&group_id=129083&atid=713754)[/b]

# modprobe -V
module-init-tools version 3.2-pre8

KDE > 3.4.3 level B

# ls -l /usr/src
total 1
drwxr-xr-x 6 root root 232 2005-10-25 18:48 .
drwxr-xr-x 12 root root 344 2005-10-24 17:38 ..
drwxr-xr-x 15 root root 456 2005-11-06 14:38 kernel-modules
lrwxrwxrwx 1 root root 15 2005-10-25 18:48 linux -> linux-2.6.13-15
drwxr-xr-x 19 root root 840 2005-10-25 20:06 linux-2.6.13-15
drwxr-xr-x 3 root root 72 2005-09-13 17:54 linux-2.6.13-15-obj
lrwxrwxrwx 1 root root 19 2005-10-25 18:48 linux-obj -> linux-2.6.13-15-obj
drwxr-xr-x 7 root root 168 2005-10-24 17:42 packages

Pour ZD1211 j'ai pris celui ci

sf_zd1211_20050822_src.tar.gz

offworld
10/11/2005, 21h15
Une commande suplementaire : <div class='quotetop'>Citation </div>
lsusb[/b]

Berlinois
10/11/2005, 22h03
Une commande suplementaire : <div class='quotetop'>Citation
lsusb[/b]
[/b][/quote]
Pour moi ça donne ceci :

# lsusb
Bus 007 Device 001: ID 0000:0000
Bus 006 Device 003: ID 046d:c283 Logitech, Inc. WingMan Force 3D
Bus 006 Device 002: ID 06a5:d001 Divio ProLink DS3303u WebCam
Bus 006 Device 001: ID 0000:0000
Bus 005 Device 002: ID 045e:008c Microsoft Corp. Wireless Intellimouse Explorer 2.0
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 002: ID 0ace:1211 ZyDAS 802.11b/g USB2 WiFi
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

MErci pour ton aide au fait.

Poupine
10/11/2005, 23h30
Et pour moi ça donne ça:

Bus 005 Device 002: ID 0ace:1211 ZyDAS 802.11b/g USB2 WiFi
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 002: ID 03f0:b202 Hewlett-Packard
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

offworld
11/11/2005, 00h38
Meme config, pas meme probleme.
Solution : attendre des pilotes stables, essayé une autre version de ndiswrapper.

Poupine
11/11/2005, 11h47
Merci pour ton aide mais je crois que je vais investir dans une carte ou un dongle a base de RT2500. Msi en propose 2 en pci : MSI US54G a 27€00 chez LDLC ou la clef usb : MSI PC54G2 a 25€00 toujours au même endroit !! Vu le prix je crois que je vais pas m'embeter la vie !!!!

Par contre derniere question : Sous Linux il vaut mieux que je prennes du PCI ou de l'USB (pour le Wifi ) ?????

Merci en core pour ton aide !!

offworld
11/11/2005, 15h16
Pour une tour vaut mieux mettre une carte pci.

Berlinois
11/11/2005, 17h30
Merci pour ton aide mais je crois que je vais investir dans une carte ou un dongle a base de RT2500. Msi en propose 2 en pci : MSI US54G a 27€00 chez LDLC ou la clef usb : MSI PC54G2 a 25€00 toujours au même endroit !! Vu le prix je crois que je vais pas m'embeter la vie !!!!

Par contre derniere question : Sous Linux il vaut mieux que je prennes du PCI ou de l'USB (pour le Wifi ) ?????

Merci en core pour ton aide !![/b]
Vais faire pareil, au moins je suis sûr qu'elle fonctionnera.

Merci pour le temps passé.

EDIT : Acheter ce matin une carte PCI Wifi Gygabyte à base de ralink RT 2560. Installée dans l'ordi, redémarrage et roule ma poule.

Avec une clé 128 bits 1 ko/s de perdu sur mire adsl et réseau fonctionnel.

Damien
13/08/2006, 14h35
En allant un peu plus loin sur le net, j'ai trouvé ce lien : http://zd1211.ath.cx/zd1211

Le driver est ici : http://sourceforge.net/projects/zd1211

Installation : Make sure you have your kernel sources in /usr/src/linux
Make sure your kernel is compiled with wireless extensions (CONFIG_NET_WIRELESS) and USB support
Make sure iwconfig is installed (Debian: wireless-tools package)
Download latest drivers
untar, make, make install
insmod zd1211_mod
ifconfig wlan0 up
iwconfig wlan0 essid youressid
dhclient wlan0
[/b]
Bonjour à tous,

Je rencontre le même souci. J'ai un dongle WiFi USB Trendnet que j'ai branché sur un vieux PC qui n'est pas raccordé à Internet. Je suis donc obligé de transférer les fichiers entre les 2 PCs via une clé USB. J'ai téléchargé le fichier en question mais après, je ne sais pas comment faire pour l'installer. Je l'ai installé dans /home mais impossible d'installer quoi que ce soit.

Pourriez-vous m'aider ?

Merci. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif