PDA

Afficher la version complète : config thinkpad sous suse OSS 10.0



LDen
16/11/2005, 19h59
bonjour

j'ai un thinkpad et j'ai remarque que suse me propose de le configurer; le probleme c'est qu'il me donne le message suivant :
impossible de lire dev/nvram charger le module nvram de linux insmod nvram et creer le noeud mknod/dev/nvram c 10 144 puis rendez visible le peripherique chmod 664 /dev/nvram ou modifiable chmod/dev/nvramje suis nouveua dans ce monde j'y comprends rien!! http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif
pouvez vous m'aider les amis!

merci

galagann
16/11/2005, 20h59
Salux,

Tu peux vérifier via ce Wiki : http://www.thinkwiki.org/wiki/Installing_S...nkPad_TransNote (http://www.thinkwiki.org/wiki/Installing_SUSE_10_on_a_ThinkPad_TransNote)

LDen
17/11/2005, 21h58
je viens de browser la page le pb ce que lorsque je me connecte en su il me demande mon mot de passe mais m'affiche que ma comande ne peut etre executée....
resultat je peux pas rajouter nvram dans le fichier kernel.!

merci d'avance
+

wapwap
04/01/2006, 22h31
En ce qui me concerne, j'ai obtenu que les boutons de mon thinkpad et une partie des touches de fonction "fonctionnent", c'est la cas de le dire...

Pour cela j'ai suivi partiellement les explications de ce lien... http://www.lastree.net/log/2005/10/installation_de.php

(à noter au passage l'adresse de http://www.thinkwiki.org une mine d'or pour nous...)

Les paquets nécessaires (tpb et xosd) sont installés par défaut...

Pour cela en root dans une console, j'ai tapé : chmod 666 /dev/nvram
ensuite il suffit de lancer tpb en console et l'appui sur les boutons hard ou les touches de fonctions remplissent à nouveau leurs fonctions et grâce à xosd, les infos s'affichent à l'écran...

On peut, après avoir copier /etc/tpbrc vers son home et édité cette copie procéder à quelques modifs... j'ai juste changé la couleur de l'affichage en rajoutant OSDCOLOR Green dans la section ad hoc

Par contre contrairement aux affirmations du tuto précité, le fait de le lancer le programme en démon avec l'option -d ne permet pas son rédémarrage automatique au boot suivant...

J'ai donc contourné le prob. en créant dans mon /home/.kde/autostart un lien vers une url (clic droit) vers /usr/bin/tpb et là ça roule...

Thinkpad powaaaa http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif