PDA

Afficher la version complète : [Réglé] [Réglé] Installation de Webcam



Mathieu147
25/11/2005, 00h29
Bonjour,

J'ai SuSE 10.0, et une Creative Webcam NX Pro. Je voudrais la faire fonctionner, sachant qu'elle est supportée par le driver spca5xx (http://mxhaard.free.fr) (ça marchait sous Fedora et Ubuntu). Problème: je n'arrive pas à compiler le driver. Quand je fais make, ça me donne ça:

Building SPCA5XX driver for 2.5/2.6 kernel.
Remember: you must have read/write access to your kernel source tree.
make -C /lib/modules/`uname -r`/build SUBDIRS=/root/spca5xx-20051001 CC=cc modules
make[1]: Entering directory `/usr/src/linux-2.6.13-15-obj/i386/default'
make -C ../../../linux-2.6.13-15 O=../linux-2.6.13-15-obj/i386/default modules
/usr/src/linux-2.6.13-15/scripts/gcc-version.sh: line 11: cc: command not found
/usr/src/linux-2.6.13-15/scripts/gcc-version.sh: line 12: cc: command not found
make[3]: cc : commande introuvable
CC [M] /root/spca5xx-20051001/drivers/usb/spca5xx.o
/bin/sh: cc: command not found
make[4]: *** [/root/spca5xx-20051001/drivers/usb/spca5xx.o] Erreur 127
make[3]: *** [_module_/root/spca5xx-20051001] Erreur 2
make[2]: *** [modules] Erreur 2
make[1]: *** [modules] Erreur 2
make[1]: Leaving directory `/usr/src/linux-2.6.13-15-obj/i386/default'
make: *** [default] Erreur 2
Je ne comprends pas bien les erreurs, je ne vois pas ce qui ne colle pas... J'ai pourtant bien installé les sources du noyau.

Existe-t-il un moyen plus simple pour installer ce driver que de devoir le compiler? Je n'ai pas trouvé de RPM... Par contre j'ai vu dans un autre sujet que quelqu'un d'autre l'avait installé donc ça doit être possible http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif

La commande hwinfo --camera ne donne rien, et la commande lsusb donne

Bus 001 Device 003: ID 041e:401e Creative Technology, Ltd WebCam NX Pro
Bus 001 Device 002: ID 046d:c00e Logitech, Inc. Optical Mouse
Bus 001 Device 001: ID 0000:0000

Merci d'avance pour votre aide et bonne fin de soirée!

galagann
25/11/2005, 01h14
Salux,

Télécharge ce fichier : http://mxhaard.free.fr/spca50x/Download/sp...20051105.tar.gz (http://mxhaard.free.fr/spca50x/Download/spca5xx-20051105.tar.gz)
Extract-le, vérifie que le kernel-source soit présent, dans une console, va dans le répertoire du driver, fait un ./configure, look si il n'y a pas d'erreur, make, make install http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

offworld
25/11/2005, 01h59
Apparemment il manque la commande cc sur ton système.
Regarde quelle version de gcc est installé, et celle qui est demandé pour compiller tes sources.
<div class='quotetop'>Citation </div>
/usr/src/linux-2.6.13-15/scripts/gcc-version.sh: line 11: cc: command not found
/usr/src/linux-2.6.13-15/scripts/gcc-version.sh: line 12: cc: command not found
make[3]: cc : commande introuvable[/b]

Mathieu147
25/11/2005, 19h39
Salux,

Télécharge ce fichier : http://mxhaard.free.fr/spca50x/Download/sp...20051105.tar.gz (http://mxhaard.free.fr/spca50x/Download/spca5xx-20051105.tar.gz)
Extract-le, vérifie que le kernel-source soit présent, dans une console, va dans le répertoire du driver, fait un ./configure, look si il n'y a pas d'erreur, make, make install http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif[/b]
C'est ce que j'avais déjà fait (enfin presque, parce que je faisais «make» sans faire «./configure»), mais de toutes façons:

bash: ./configure: Aucun fichier ou répertoire de ce type

<div class='quotetop'>Citation (offworld @ 25/11/2005 à 0:59) <{POST_SNAPBACK}> (index.php?act=findpost&pid=64791)</div>
Apparemment il manque la commande cc sur ton système.
Regarde quelle version de gcc est installé, et celle qui est demandé pour compiller tes sources.
<div class='quotetop'>Citation

/usr/src/linux-2.6.13-15/scripts/gcc-version.sh: line 11: cc: command not found
/usr/src/linux-2.6.13-15/scripts/gcc-version.sh: line 12: cc: command not found
make[3]: cc : commande introuvable[/b]
[/b][/quote]
Euh... On fait comment? http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif

Merci pour vos réponses http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

Mathieu147
25/11/2005, 21h30
J'ai résolu le problème! Il suffisait en fait d'installer SdlLib avec ses dépendances et ça roule http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

offworld
25/11/2005, 22h09
Pense a marqué réglé a coté du titre de ton premier message.