PDA

Afficher la version complète : [Réglé] [Réglé] SuSE 9.1 et Sagem F@st 1000



siegfried
06/11/2004, 15h40
Bonjour, je viens demander de l'aide.

Aprés avoir respecté les "règles de base" comme tout nouvel arrivant dans le monde LINUX (SuSE 9.1). C'est à dire lire des tas de pages, de forums (dont celui-ci qui est plutôt pas mal) et de tutoriaux concernant Linux avant de venir crier "A l'AIDEeeeeeeeee !!"

Voilà mon problème, Je suis trés ennuyé avec mon Modem Sagem F@st 1000, je dispose d'un connection ADSL 512 Ko/s avec le Neuf.

J'ai télécharger le driver Eagle 1.9.9 que j'ai installé avec Make, make install, ..., les packages aussi, tout comme selon l'aricle sur ce même forum, et ça marche. sauf que quand je fais eagleconfig, je configure avec mes paramètres et là il ne me donne comme choix que : "[FR05] 9online en 1024 et 2048 dégroupé" alors que pas moi je ne suis pas dégroupé. là c'est le HIC, j'ai un beau message d'érreur http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif)) Je pense que ce driver ne fonctionne qu'avec le modem F@st 800 http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

Alors j'ai une autre solution c'est un truc développé en Espagne "co800_static_IP_v1.0.0_beta.tar", dans le 'ReadMe' ils disent ça :

1. Config installation scripts for your own system configuration
1.1 Requirements
1.1.1 Kernel 2.4.20 sources. You must compile kernel with USB
support and ATM support. You can go to
http://sourceforge.net/projects/co800 and read docs about
this
1.1.2 ATM tools
1.1.3 GNU C compiler
1.2 Installation scripts edition. Only the edition of two files
is needed. One file is the Makefile in module directory. Edit
the variable LINUX_DIR from the first line with your own
kernel sources path.
The second file to edit is the path in wich we will install
the driver, tools and others. Is the first line of Makefile
in the root directory of package. The default is to install
package in /usr/local/co800

2. Driver sources compilation
2.1 Execute 'make' in the package root directory

3. Driver , tools and others installation
3.1 Execute 'make install', AS ROOT, in the package root directory

4. CO800 command
With the driver installation a new command is available in the
system: co800. With this command we can control our Copperjet 800.
You need to be root to execute co800 with all functionality.
If you want to connect the modem to the net, we can do that with
only two instructions:
a) Initialize modem with 'co800 -in' or 'co800 --init'
http://www.alionet.org/style_emoticons/<#EMO_DIR#>/cool.gif Connect it to the net with 'co800 -nu' or 'co800 --netup'
If you want to disconnect from the net: 'co800 -nd' or
'co800 --netdown'.
If you want to reboot the modem just type 'co800 -rs' or
'co800 --reset'.

KNOWN BUGS:
The reset command (co800 -rs or co800 --reset) is not working
well because co800 driver module can't be removed from memory in
many situations.

Voilà, je comprends à partir de '2. Driver sources compilation'

Mais le reste je ne vois pas ce que je dois faire ?

Alors si quelqu'un voulais bien me filer un coup de main, je promets de faire un article sur mon site perso http://siegfried.burgeot.free.fr pour aider ceux et celles qui sont dans mon cas.

Merci d'avance et à bientôt.

Siegfried

siegfried
10/11/2004, 13h02
Bonjour,
Pourquoi y'a personne qui me répond ? http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif
J'ai dis une bétise ? Ou alors c'est impossible !!

@ bientôt

Siegfried

Neolinux
10/11/2004, 18h31
Salux !

En principe, tu dois déjà te trouver dans le répertoire "/usr/local/co800" en tant que root ("su - root" + mot de passe) à partir du point 2 (à la limite, tu peux faire un "cd /usr/local/co800" pour être certain).

Il semble qu'il faille entrer dans un répertoire particulier, fais "ls" pour voir s'il existe un répertoire qui porte le nom indiqué : root, comme indiqué (in the package root directory). Si oui : "cd /usr/local/co800/le_nom_du_répertoire" et faire la commande "make" à cet endroit. Il ne reste plus qu'à faire "make install" dans ce même répertoire.

Le point 4 explique les différentes commandes à exécuter en root pour utiliser
le modem :
- "co800 -in" ou "co800 --init" pour activer le modem;
- "co800 -nd" ou "co800 --netdown" pour le désactiver;
- "co800 -rs" ou "co800 --reset" pour le relancer, mais ilsemble que cela ne fonctionne pas toujours en raison de l'utilisation de la mémoire.

Pour ce qui est de l'absence de réponse, sur un forum d'entraide, il faut souvent que les membres aient rencontré le même problème, avec la même configuration matérielle, pour pouvoir donner une réponse aussi précise que le cas rencontré. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

galagann
11/11/2004, 13h13
Originally posted by siegfried@Mercredi 10 Novembre 2004 12:02
Bonjour,
Pourquoi y'a personne qui me répond ? http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif
J'ai dis une bétise ? Ou alors c'est impossible !!

@ bientôt

Siegfried
Parce que tu étais dans la mauvaise rubrique, c'est pas un tutorial mais une demande d'aide

MOVED!!!

ilka
11/11/2004, 15h07
Tu as essayé le dernier pilote 2.0 ? Il a résolu pas mal de problèmes chez un de mes potes avec le même modem que toi.

http://www.eagle-usb.org/article.php3?id_article=46

siegfried
12/11/2004, 13h31
Bonjour,

Je vous remercie pour ces infos.
En fait j'ai trouvé un Sagem F@ast 800, alors je vais essayer le driver Eagle 2.0.0.

Désolé pour le post dans la mauvaise rubrique.

Siegfried

ilka
12/11/2004, 14h18
No problemo, ça arrive à tous à mon avis aux premiers posts ! Moi-mê:me j'ai claqué ma première question dans les news, en voulant aller trop vite ! http://www.alionet.org/style_emoticons/<#EMO_DIR#>/huh.gif
Après plusieurs visites sur alionet, tu verras que le classement est finalement logique et simple, ce qui rend le forum moins bordélique qu'ailleurs.
Mais c'est vrai qu'au début c'est assez déroutant.

Si tu as un pépin avec le 800, fais-le savoir, il marche super chez moi en usb
depuis 2 mois,, quelle que soit la distro essayée. Le pilote Eagle est vraiment bien fait.

Benabd
12/10/2007, 12h53
Bonjour,

Je viens d'installer SuSE 10.3 sans problème. Toutefois, je n'arrive pas à faire marcher le modem ADSL Sagem F@ast 800.

Je vous remercie beaucoup de m'indiquer une solution pas à pas facile à suivre vu mon niveau de débutant sur Linux.

Cordialement