PDA

Afficher la version complète : [Réglé] Pilote Wifi



njm
10/11/2004, 21h37
bonsoir tout le monde,

je viens de faire une install de la suse 9.2 mais celle-ci ne détecte pas mon aucune interface sans fil dans yast (carte réseau)

Pourtant Suse hardware tool me détecte bien les 2 controleur réseaux et donc mon wifi (Askey Network Controller)
Les détais disent pour l'état disponible oui / configuré non http://www.alionet.org/style_emoticons/<#EMO_DIR#>/unsure.gif
et bien sur je n'ai pas l'onglet pilote ...

Comment faut-il faire alors pour les installer ces pilotes ?

Spooky
10/11/2004, 21h54
je n'ai ce matériel, peut-être trouveras-tu de l'aide avec ce lien :

wifi (http://www.swisslinux.org/forums/ftopic89.php)

a+ Spooky

njm
13/11/2004, 13h29
Merci pour le spooky le lien http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif mais ça m'a beaucoup aidé http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

j'ai trouvé les spécifications de mon controlleur sur le site de PB
http://service.packardbell.fr/items/index....orm_NR1_DC#show (http://service.packardbell.fr/items/index.php?PibItemNr=spec_Askey_WLL3070&PibItemParent=platform_NR1_DC#show)

mais je suis même pas sur qu'il existe un driver pour linux http://www.alionet.org/style_emoticons/<#EMO_DIR#>/unsure.gif

SokariS
13/11/2004, 21h32
Salut NJM,
essaye ndiswrapper, tu peut le trouver directement sur le CD de suse.

Une fois installé, il faut que tu copie les fichiers du driver de ta carte Wi-Fi par example dans /tmp/driver (il te faut les fichiers .inf, .bin, .sys, etc...).

Ensuite, il te suffit de faire en root

# ndiswrapper -i /tmp/driver/XXXXX.inf (où XXXXX est le nom de ton fichier)

Si tout se passe bien, tu devait avoir

Installing XXXXX

Pour verifier si tout est bien installé (on est jamais trop prudent), tape

# ndiswrapper -l

Ce qui devrait te donner:

Installed ndis drivers:
XXXXX

Ensuite, tu n'a plus qu'à charger ton module fraîchement installé en tapant:

# dmesg

La réponse recherchée étant:

ndiswapper version 0.6+CVS loaded
ndiswrapper addind XXXXX.sys

Si tu as la bonne réponse, tu as gagné le plaisir d'utiliser le Wi-Fi sous Suse. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif

Dit moi déjà si ça ça marche.

La suite au prochain épisode. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif

njm
13/11/2004, 22h42
bonsoir Sokaris http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

Les drivers sont dispo que par .exe et je n'ai pas de windows sous la main donc j'ai tenté le coup avec wine

donc voila ce que j'ai fait
> wine agerewlan-82250804.exe
Updating drivers for PCI\VEN_11C1&DEV_AB34 from C:\windows\temp\is-VVSQI.tmp\wlaskall.inf.
fixme:newdev:UpdateDriverForPlugAndPlayDevicesW Stub! L"PCI\\VEN_11C1&DEV_AB34"L"C:\\windows\\temp\\is-VVSQI.tmp\\wlaskall.inf" 0x00000001

easynote:/home/njm/.wine/drive_c/windows/temp/is-VVSQI.tmp # ls
. WCASK48D.EXE WLASK48D.SYS WNASK48D.CPL wlags2x.cat
.. WDASK48C.DLL WLASKALL.INF WUASK48C.VXD
WAASK48C.DLL WDASK48D.DLL WNASK.CNT _shfoldr.dll
WAASK48D.DLL WIASK48C.DLL WNASK.HLP pbcnote_20040901.exe
WCASK48C.EXE WLASK48C.SYS WNASK48C.CPL pnptool.exe

easynote:/home/njm/.wine/drive_c/windows/temp/is-VVSQI.tmp # ndiswrapper -i WLASKALL.INF
Installing wlaskall
no vendor

easynote:/home/njm/.wine/drive_c/windows/temp/is-VVSQI.tmp # ndiswrapper -l
Installed ndis drivers:
wlaskall hardware NOT present

et finalement dmesg me donne rien sur ndiswrapper http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

alors que c'est le fait de passer par wine qui pose problème ? ou c'est les drivers qui sont supporté par ndiswrapper ?

SokariS
14/11/2004, 00h45
Bonsoir,
A priori, ta carte embarque un chipset Atheros qui est supporté par ndiswrapper.
Ce qui veut dire plus clairement que tu ne devrais pas avoir de problème pour l'installer. (ce qui est déjà une bonne nouvelle http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif)
Maintenant, je pense que wine n'est pas la meilleure solution pour extraire ton driver.
Je vais chercher une solution à ton problème, et je te réponds dès que j'ai trouvé.

Ne t'en fais pas, on va y arriver.

ps: il semblerait que la version 0.9 de ndiswrapper marche mieux avec les chipset Atheros; si tu peut faire une petite mise à jour...

njm
14/11/2004, 21h04
Sokaris mon sauveur http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif

bon là j'suis en partiel cette semaine donc j'ai pas le temps de m'occuper de ça mais je m'y remets à fond le week end prochain http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

njm
18/11/2004, 19h23
euh le problème est pas réglé http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif

en fait je sais même pas comment connaitre la version de ndiswrapper qui est installé http://www.alionet.org/style_emoticons/<#EMO_DIR#>/blushing.gif

Sokaris si tu repasses par là tu me dirais me dire ou tu as vu que c'était un chipset Atheros ? http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif