PDA

Afficher la version complète : [Réglé] suse10.0 eclipse 3.0.1 php4 trustudio



celtic34
11/01/2006, 22h52
Bonjour à tous,

Juste un petit problème, qui je pense n'est pas insurmotable.

Je veux utiliser Eclipse (3.0.1) avec le plug ins TruStudio afin de pouvoir programmer et debugger mes sources Php4 (4.4.0-6). En base TruStudio contient l'exécutable de l'interpréteur Php 5.0.2 avec le php.ini en rapport.
ayant installé les rpm suivants :
php4-dbx-4.4.0-6
php4-iconv-4.4.0-6
php4-mysql-4.4.0-6
php4-sysvsem-4.4.0-6
php4-4.4.0-6.6
php4-ctype-4.4.0-6
php4-gd-4.4.0-6
php4-mcrypt-4.4.0-6
php4-snmp-4.4.0-6
php4-yp-4.4.0-6
php4-bcmath-4.4.0-6
php4-curl-4.4.0-6
php4-gettext-4.4.0-6
php4-ldap-4.4.0-6
php4-mhash-4.4.0-6
php4-qtdom-4.4.0-6
php4-sockets-4.4.0-6
php4-unixODBC-4.4.0-6
php4-zlib-4.4.0-6
mod_php4-core-4.4.0-6
phpMyAdmin-2.6.3pl1-3.6
php4-fastcgi-4.4.0-6.6
php4-bz2-4.4.0-6
php4-dbase-4.4.0-6
php4-filepro-4.4.0-6
php4-gmp-4.4.0-6
php4-mime_magic-4.4.0-6
php4-session-4.4.0-6
php4-swf-4.4.0-6
php4-wddx-4.4.0-6
apache2-mod_php4-4.4.0-6.6
php4-mbstring-4.4.0-6.6
php4-calendar-4.4.0-6
php4-ftp-4.4.0-6
php4-mcal-4.4.0-6
php4-shmop-4.4.0-6
php4-xslt-4.4.0-6
selfphp-2.0-2
php4-servlet-4.4.0-6.6
php4-domxml-4.4.0-6
php4-imap-4.4.0-6
php4-pgsql-4.4.0-6
php4-sysvshm-4.4.0-6
php4-pear-4.4.0-6
php4-exif-4.4.0-6.6
=> le simple fait de mettre en interprèteur la version installé de Php avec le php.ini que je trouve dans /etc/ produit systématiquement la même erreur : eurreur inexpliquée au lancement : donc impossible pour moi de debugger.

Quand j'accède à une page php (phpinfo()) dans public_html : pas de problème, j'ai le bon rendu de page.

Merci de m'éclairer, je suis un peu perdu.

galagann
11/01/2006, 22h56
Tu as l'erreur en version complète ?

micke_suse
01/02/2006, 12h59
salut


Pour eclipse c'est rpm ou un zip

le zip pose aucun pb par contre le rpm génére des erreurs.

celtic34
01/02/2006, 23h01
mon problème ne vient pas d'Eclipse, mais plutôt du plugins TruStudio.

J'ai résolu la question sans chercher en passant de Php4 à Php5. Là pas de problème pour debugger. Mais cela me navre un peu, car même si Php5 est certifié entreprise, la plupart des serveurs (hébergement ou autre) utilisent plus Php4.

Je suis toujours preneur si quelqu'un peut me donner une solution pour utiliser Php4 avec TruStudio de xored

a+