PDA

Afficher la version complète : [Réglé] [Réglé] re-installer driver Nvidia



eric
15/11/2004, 22h07
voilà au debut de mon install de la suse 9.1 j'avais mis les drivers Nvidia, mais ya qques jours je ne sais pas ce que g fait il n'y sont +, du coup impossible de les re-installer depuis yast.

Qqun serait 'il assez sympa pour m'expliquer en détail la manip, parceque tout ce que g trouvé ce sont des sites en anglais où g cru vaguement comprendre qu'il fallait recompiler les sources du noyau etc...., mais avec des instructions anglaises je préfère pas me lancer, merci de votre compréhension.

alexmic
15/11/2004, 23h51
j'ai eu le meme problème faut passer par 'you' afficher tous les patchs installés et installables et trouver 'Download Nvidia drivers' et voila!

eric
16/11/2004, 00h03
ben justement c'est ce que j'ai fait (2 fois) et j'ai beau faire cette manip je n'ai + le logo Nvidia au démarrage et plus la possibilité d'acceder au 3D http://www.alionet.org/style_emoticons/<#EMO_DIR#>/huh.gif

lucienmathieu
16/11/2004, 15h05
Salut Eric, je ne suis pas sure a 100%, mais avec l'install du patch nvidia, j'ai eu une installe de kernel-source, je ne sais pas si ca peut t'aider.

eric
17/11/2004, 01h42
voilà à quoi j'ai droit quand je veux activer le 3D dans SAX:

http://www.divxmethode.com/images/nvidia-3d.jpg

petites précisions:

suis sous Xorg-x11
kernel 2.6.8-20041115094447-default

leur url c'est de l'anglais et c'est pas vraiment ce que je maîtrises le mieux et vu que la manip n'a pas l'air trés évidente , je recherche le même type de lien mais en fr http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif

merci

DavidDeTroyes
17/11/2004, 11h26
hellox,

J'ai eu ce problème ce matin et j'ai fait ca :
j'ai télécharger le dernier driver chez nvidia
j'ai ouvert une console
je me suis mis en root
j'ai fait init 3
j'ai lancer la commande sh le_driver.run
j'ai fait un sax2 -m 0=nvidia
et ca remarche !!! http://www.alionet.org/style_emoticons/<#EMO_DIR#>/laugh.gif

mais bon c'est c... y'as encore le zoli ecran tout moche à la fin de X !

eric
17/11/2004, 14h27
excuses mon ignorance mais qques eclaircissement pliz:

tu as une url pour le driver?? stp (suis fatigué et g mal à la tête excuse ma flemme)


<div class='quotetop'>Citation </div>
j'ai fait un sax2 -m 0=nvidia[/b]

c'est une ligne de commande?? ==> sax2 -m 0=nvidia

si oui peux tu me l'expliquer stp (dans les grandes lignes)

merci à toi, une fois que tu m'en auras dit plus j'essayes http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

DavidDeTroyes
17/11/2004, 15h06
tu va sur http://www.nvidia.fr/page/home
là tu télécharge le driver (section télécharger les pilotes)
tu récupére le fichier .run
tu as aussi un readme qui t'explique la procedure en francais
tu fait un "sh NVIDIA-Linux-x86-1.0-6111-pkg1.run"
et un "sax2 -m 0=nvidia" (commande en ligne)

et voilou ! http://www.alionet.org/style_emoticons/<#EMO_DIR#>/rolleyes.gif

suis je encore assez clair (mes amis disent que je parle vite mais à l'ecrit ca devrait pas se voir !!!)

eric
18/11/2004, 13h01
pourquoi avoir mis [réglé] ?? g pas fini lol http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif

alors voilà g ce message d'erreur de l'installer NVIDIA:

<div class='quotetop'>Citation </div>
ERROR: The kernel header file
'/lib/modules/2.6.8-20041116124251-default/build/include/linux/kernel.h'
does not exist. The most likely reason for this is that the kernel
source path '/lib/modules/2.6.8-20041116124251-default/build' is
incorrect. Please make sure you have installed the kernel source files
for your kernel; on Red Hat Linux systems, for example, be sure you have
the 'kernel-source' rpm installed. If you know the correct kernel
source files are installed, you may specify the kernel source path with
the '--kernel-source-path' commandline option.[/b]

Je confirme g bien installé le kernel-source avec apt. Chez moi le fichier 'kernel.h' se trouve dans /usr/include/linux. Le repertoire '/lib/modules/2.6.8-20041116124251-default/build' est un raccoucci vers ' /usr/src/linux-2.6.8-20041116124251-obj/i386/default' .


Vos conseils ?? un simple copie/coller du kernel.h??

merci encore, @+

eric
18/11/2004, 13h33
bon ben g fait mon copie/coller http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif , ça a marché , g retrouvé le 3D et mes screensavers open GL ,mais g quand même un avertissement de conflit, qqun pourrait 'il m'expliquer rivafb?? les anciens drivers installé avec yast?

<div class='quotetop'>Citation </div>
The rivafb driver conflicts with the NVIDIA driver; the
NVIDIA kernel module will still be built and installed,
but be aware that the NVIDIA driver will not be able to
function properly if the rivafb module is loaded!

*** Failed rivafb module sanity check, but continuing! ***[/b]
faut'il que je "décharge" rivafb, et si oui comment?

encore merci, @+

DavidDeTroyes
18/11/2004, 13h54
Alors là je suis largué ! http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

Je serai toi j'effacerai tout et j'installerai Windows... non, je deconne... http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif

Eh les pro du pot, y'as un problème ici !!!

eric
18/11/2004, 14h26
Pourtant tout re-fonctionne, ecran de veille open GL = nickel, jeux 3D style 'foobillard' nickel, comprends pas où peut être le bizz.

<div class='quotetop'>Citation </div>
linux:/home/eric # xdpyinfo | grep GLX
GLX
NV-GLX[/b]

ceci dit si faut désactiver ce module rivafb sans que ça ne nuise à mon systeme pas de bleme, le tout etant de savoir comment faire http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

@+

eric
18/11/2004, 14h34
g trouvé ceci :

<div class='quotetop'>Citation </div>
Si vous avez un message d'erreur concernant le support de rivafb activé et incompatible, vous pouvez l'ignorer. En effet bien que le support de rivafb soit activé dans le noyau, le module n'est pas chargé par défaut, donc il n'y a pas de problème. Si vous voulez vous en assurez, vous pouvez ajouter la ligne suivantes dans le fichier /etc/modprobe.conf ( noyau 2.6 ) ou /etc/modules.conf ( noyau 2.4) : alias rivafb off
Cette ligne empéchera le chargement du module rivafb.[/b]

Bon maintenant on peut vraiment dire que c'est "réglé" http://www.divxmethode.com/uploads/smil417353f6493d0.gif