PDA

Afficher la version complète : [Réglé] [Réglé] Questions sur apt-get



Asimov
26/05/2006, 20h09
J'ai télechargé les paquetages pour un upgrade, malheureusement il refuse de faire l'installation, car apparamment les signatures lui sont inconnue.

1 - J'aimerai savoir la ligne de commande à faire pour forcer apt-get à faire l'intallation sans tenir compte de cette foutu signature ... http://www.alionet.org/style_emoticons/<#EMO_DIR#>/mad.gif

2 - J'ai l'intention de faire ce genre d'opération dans le futur à partir des sources...

Pourriez me précisez la marche à suivre (les commandes précises) pour faire un upgrade et un update à partir des sources, ainsi que les site fiables.

3 - Est-ce que les compilations sont gérées par apt-get ?

P.S : j'ignore si je suis dans le bon forum puisque j'utilise apt4rpm .... http://www.alionet.org/style_emoticons/<#EMO_DIR#>/huh.gif

jolinfire
27/05/2006, 22h00
J'ai télechargé les paquetages pour un upgrade, malheureusement il refuse de faire l'installation, car apparamment les signatures lui sont inconnue.

1 - J'aimerai savoir la ligne de commande à faire pour forcer apt-get à faire l'intallation sans tenir compte de cette foutu signature ... http://www.alionet.org/style_emoticons/<#EMO_DIR#>/mad.gif[/b]

--force-yes

<div class='quotetop'>Citation </div>
2 - j'ai l'intention de faire ce genre d'opération dans le futur à partir des sources ...

Pourriez me précisez la marche à suivre ( les commandes précises )pour faire un upgrade et un update à partir des sources, ainsi que les site fiables.[/b]

Pour les sites, aucune idée.

Pour un upgrade : apt-get upgrade


<div class='quotetop'>Citation </div>
3 - Est-ce que les compilations sont gérées par apt-get ?

P.S J'ignore si je suis dans le bon forum puisque j'utilise apt4rpm .... http://www.alionet.org/style_emoticons/<#EMO_DIR#>/huh.gif[/b]

Ben ouais... On peut compiler les sources.

-b ou encore --compile ou encore --build

man apt-get sera ton ami http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

Neolinux
28/05/2006, 11h09
Salux !

Regarde le wiki pour APT4RPM/Synaptic, la section pour modifier le fichier gpg-checker.conf.

dom le vrai
28/05/2006, 12h41
Si jamais, tu n'es effectivement pas dans le bon forum. Ici, on parle de distributions basées sur le système de paquetage DEB, et donc pas d'apt4rpm. Mais les réponses données par jolinfire sont correctes.

Pour l'upgrade de la distribution, je sais que ce n'est pas recommandé sous SuSE de le faire avec apt-get. Mais la commande (une fois que tu as modifié les sources dans ton fichier /etc/apt/sources.list) c'est:

apt-get update && apt-get dist-upgrade

Asimov
04/06/2006, 20h55
Merci à tous, plus je lis les problèmes de la distribution 10.1 plus je pense à me convertir sur du Débians. le système de packetage a vraiment l'air plus solide.

dom le vrai
05/06/2006, 10h30
C'est la vérité, Asimov. Essaie une Ubuntu ou une Mepis si tu souhaites passer dans le monde Debian.