• Plasma 5.3 et KDE Applications 15.04 débarquent enfin sur openSUSE Tumbleweed !


    Après plus d'un mois d'efforts d'intégration et maints tests sur openQA, ça y est, la nouvelle version du bureau Plasma est enfin disponible sur Tumbleweed. Il s'agit plus qu'une simple évolution pour la variante en rolling release d'openSUSE, car Plasma est désormais le bureau KDE par défaut. Exit donc KDE 4 !


    Les nouveautés

    Par rapport à la version précédente de Plasma, la version 5.3 apporte notamment :

    • une amélioration de la gestion de l'énergie
    • une meilleure prise en charge du bluetooth
    • un nouveau module de configuration du pavé tactile
    • de nouvelles fonctionnalités pour le menu principal
    • plus de composants graphiques Plasma
    • une grande avancée concernant la prise en charge de Wayland (bien qu'un support complet n'est annoncé que pour la 5.4)


    En aperçu technologique, vous aurez droit au Plasma Media Center (relativement stable, mais des fonctionnalités sont manquantes).

    Le passage de la suite d'applications KDE à la version 15.04 apporte lui-aussi son lot de nouveautés, avec surtout des portages de programmes de KDE 4 vers le nouveau framework de KDE.

    Pour plus de détails, je vous invite à lire le résumé complet de Syvolc sur son blog.

    Comment installer tout ça ?

    Attention !

    KDE 4 et Plasma 5 ne sont pas coinstallables !

    Si vous utilisiez KDE 4, préparez-vous à perdre une partie de la configuration de votre bureau. Si vous rencontrez des problèmes, il vaut mieux repartir d'une configuration par défaut (le plus simple pour cela étant de créer un nouvel utilisateur).

    Notez aussi que, sous Tumbleweed, le passage à Plasma par défaut va faire que vos éventuels paquets KDE 4 seront tout simplement remplacés par ceux de Plasma et de KDE Applications.

    Sur Tumbleweed

    Plasma 5.3 et KDE Applications 15.04 sont intégrés au dépôt officiel principal donc vous n'avez pas besoin d'ajouter des dépôts.

    Si vous avez déjà la version précédente de KDE ou de Plasma installée, il suffit de lancer la mise à niveau :
    Code:
    # zypper dup
    Si vous utilisez un autre environnement de bureau (ou pas d'environnement du tout !) mais avez envie de tester cette nouvelle mouture de Plasma, vous pouvez installer une version « minimale » comme ça :
    Code:
    # zypper in -t pattern kde_plasma
    Si vous voulez une installation complète, vous pouvez installer le schéma kde tout court (qui devrait installer tous les autres schémas kde_*) :
    Code:
    # zypper in -t pattern kde

    Sur openSUSE 13.1 et openSUSE 13.2

    Il vous faudra d'abord rajouter les dépôts KDE:Frameworks5 et KDE:Qt5 (voir le wiki pour trouver l'URL correspondant à votre version d'openSUSE) puis lancer la commande d'installation :
    Code:
    # zypper in -t pattern plasma5_basis
    # zypper dup --from KDE:Qt5 --from KDE:Frameworks5
    Une fois tous les paquets installés, vous n'avez plus qu'à vous déconnecter (pas besoin de redémarrer !) puis à vous reconnecter en sélectionnant l'environnement de bureau Plasma 5 dans votre gestionnaire de session.

    Des captures !






    Have a lot of fun!


    Sources :
    Commentaires 8 Commentaires
    1. Avatar de Denebe
      Denebe -
      Plasma 5.3.1 vient de sortir (pas encore dans Tumbleweed, ça ne serait tarder, deux~huit jours),

      le petit bug que j'avais, à savoir "vue bureau" qui ne fonctionnait pas, a été fixé: fixed !

      Voilà la liste du changelog
      https://www.kde.org/announcements/pl...-changelog.php
    1. Avatar de PtitLu
      PtitLu -
      J'ai un souci avec ma 13.2, malgré les bons dépôts installés :
      Code:
      zypper in -t pattern plasma_basis
      Chargement des données du dépôt...
      Lecture des paquets installés...
      'plasma_basis' n'a pas été trouvé parmi les noms de paquets. Essai parmi les capacités.
      Aucun fournisseur de 'plasma_basis' trouvé.
      Résolution des dépendances des paquets...
      Rien à faire.
      Qu'ai-je loupé ?
    1. Avatar de jtro
      jtro -
      Je ne suis pas kdeiste,il ne s'agirait oas plutot de patterns opensuse plasma5_basis ?
      C'est présenté ainsi sous software opensuse
      https://software.opensuse.org/package/patterns-openSUSE-plasma5_basis
    1. Avatar de Antoine
      Antoine -
      Citation Envoyé par PtitLu Voir le message
      J'ai un souci avec ma 13.2, malgré les bons dépôts installés :
      Code:
      zypper in -t pattern plasma_basis
      Chargement des données du dépôt...
      Lecture des paquets installés...
      'plasma_basis' n'a pas été trouvé parmi les noms de paquets. Essai parmi les capacités.
      Aucun fournisseur de 'plasma_basis' trouvé.
      Résolution des dépendances des paquets...
      Rien à faire.
      Qu'ai-je loupé ?
      Rien loupé, fais un
      Code:
      zypper se -t pattern plasma
      pour voir le nom exact. Je n'ai pas de 13.2 sous la main, j'ai écrit ça de mémoire, j'ai dû me tromper ou ça a bougé. Sans doute plasma5_basis comme dit jtro.

      Je modifie si tu me confirmes que c'est ça
    1. Avatar de Denebe
      Denebe -
      denebe@linux-vnub:~> zypper se -t pattern plasma
      Repository 'openSUSE-13.2-Update' ist veraltet. Sie können 'zypper refresh' als root ausführen, um es zu aktualisieren.
      Daten des Repositories laden ...
      Installierte Pakete lesen ...

      S | Name | Zusammenfassung | Typ
      --+---------------+----------------------+-------
      i | plasma5_basis | Plasma 5 Base System | Schema
      denebe@linux-vnub:~>
    1. Avatar de Antoine
      Antoine -
      Citation Envoyé par Denebe Voir le message
      denebe@linux-vnub:~> zypper se -t pattern plasma
      Repository 'openSUSE-13.2-Update' ist veraltet. Sie können 'zypper refresh' als root ausführen, um es zu aktualisieren.
      Daten des Repositories laden ...
      Installierte Pakete lesen ...

      S | Name | Zusammenfassung | Typ
      --+---------------+----------------------+-------
      i | plasma5_basis | Plasma 5 Base System | Schema
      denebe@linux-vnub:~>
      OK, corrigé, merci
    1. Avatar de PtitLu
      PtitLu -
      J'ai, entre temps, utilisé cette technique : https://www.alionet.org/entry.php?58...sma-5-est-l%E0 et ça marche très bien. Il ne me reste plus qu'à patienter pour retrouver quelques plasmoids qui me servaient bien et ne semble pas encore disponibles sous Plasma5 mais j'aime beaucoup cette évolution.
      Merci.
    1. Avatar de Denebe
      Denebe -
      Je viens de mettre à jour Tumbleweed, c'et tout chaud.

      Bon par contre, j'ai toujours ce petit bug de "vue bureau", étrange... Mais vraiment pas gênant.
  • Dons / Adhésion


    Dons
    Si vous aimez notre site web et que vous voulez participer financièrement, vous pouvez nous faire un don grâce à PayPal.


    Choisissez votre somme, et cliquez sur le bouton "donate" ci-dessous.



    Adhésion
    Si vous désirez être membre de notre association, vous pouvez aussi adhérer grâce à PayPal.


    Cliquez sur le bouton "PayPal" ci-dessous.

  • SUSECon 2017

     
    SUSEcon 2017
     
     
  • Derniers commentaires d'articles

    pierrotbj

    Boutique Alionet sur EnVenteLibre

    Troll toi même :D
    KDE fonctionne pas mal et, gros avantage, il est moins dépaysant que Gnome pour... Voir le dernier message

    pierrotbj le 21/09/2018 17h15
    jtro

    Boutique Alionet sur EnVenteLibre

    [TROLL]bah oui,vaut mieux vendre quelque chose qui fonctionne bien![/FIN DE TROLL] Voir le dernier message

    jtro le 20/09/2018 08h41
    Grenouille

    Boutique Alionet sur EnVenteLibre

    Un live Gnome et pas de live KDE? Tssss... Voir le dernier message

    Grenouille le 19/09/2018 21h05
    sogal

    Extension de la durée de vie d'openSUSE Leap 42.3

    Tout à fait! C'est rectifié, merci. Voir le dernier message

    sogal le 10/09/2018 13h34