• Sortie de KDE Applications 17.04 !

    Une nouvelle version de la collection de logiciels libres de KDE a été publiée ce jeudi 20 avril. KDE Applications 17.04 apporte un certains nombre d'améliorations et nouveautés.

    Quoi de neuf ?

    En bref :
    • KAlgebra est maintenant disponible dans une version mobile qui s'appuie sur le framework Kirigami ; le moteur 3D de la version de bureau a été modifié.
    • Le logiciel de montage vidéo Kdenlive a reçu quelques changements ergonomiques au niveau de la boîte de dialogue de gestion du profil du film ; l'assistant DVD a été revu et des bugs entraînant des crashs ont été résolus ; un important refactoring est attendu pour la sortie de KDE Applications 17.08.
    • Le gestionnaire de fichiers Dolphin a reçu un coup de polish et fonctionne mieux sous Wayland.
    • Le gestionnaire de fichiers Ark dispose maintenant d'une fonction de recherche et prend mieux en charge le format zip.
    • L'application d'apprentissage de la musique Minuet s'est enrichie avec de nouveaux exercices.
    • La visionneuse de documents PDF Okular a reçu de nombreuses améliorations, notamment par rapport à son ergonomie sur écran tactile.
    • Plusieurs applications ont été portées vers KDE Frameworks 5.
    • Le logiciel de gravure K3b fait maintenant partie de la collection KDE Applications.
    • De nombreux bugs ont été corrigés !


    Vous trouverez tous les détails dans l'annonce de version publiée sur le site de KDE.






    Sur openSUSE

    L'intégration dans Tumbleweed est en cours dans Staging:I, le tout devrait arriver dans le dépôt principal d'ici quelques jours.

    Pour les utilisateurs de Leap 42.2, KDE Applications 17.04 ne sera pas proposé en tant que mise à jour officielle.

    Il est cependant possible de l'installer grâce au dépôt – non-officiel, non-supporté – KDE:Applications. Attention, ces applications nécessitent également le dépôt KDE:Frameworks5 car les paquets KDE Frameworks présents dans le dépôt principal de Leap sont malheureusement trop anciens pour suffire… et également le dépôt KDE:Qt5 car la dernière version de KDE Frameworks requiert Qt 5.8 :-/

    En résumé :
    Code:
    # zypper ar -f obs://KDE:Qt5 qt5
    # zypper ar -f obs://KDE:Frameworks5 kde_frameworks
    # zypper ar -f obs://KDE:Applications/KDE_Frameworks5_openSUSE_Leap_42.2 kde_apps
    # zypper dup --from qt5 --from kde_frameworks --from kde_apps
    Vous aurez peut-être quelques conflits à régler à la main. Attendez éventuellement quelques jours pour les éviter, que les packagers nettoient un brin leur boulot, là c'est tout chaud !
    Autre possibilité, plus simple : attendez la sortie de Leap 42.3 fin juillet !

    Have a lot of fun!


    Source : https://www.kde.org/announcements/an...ns-17.04.0.php
    Commentaires 2 Commentaires
    1. Avatar de Syvolc
      Syvolc -
      Super ! merci pour ces infos !
    1. Avatar de Denebe
      Denebe -
      Merci pour l'article.

      J'ai installé tout ça...

      Possédant déjà ces dépôts, en utilisant 'zypper up', j'ai dû choisir avec mes petites mains dans Yast2 la version 1.1 d'Okular (ainsi que son paquet 'lang' associé).

      Sinon il manque encore le paquet kio 5.33 pour installer correctement Dolphin 17.04.0, ainsi que le paquet 'libkgapi' 17.04.0 pour. J'ai ignoré le 'problème' de dépendance, sans déconvenue ultérieure.

      Quand à 'libkgapi lang', on peut ne pas l'installer.

      Bonne journée à vous chers alionistes.