• Les mises à jour de Thunderbird, YaST et Sudo arrivent dans Tumbleweed

    Article original paru le 29 novembre 2018, par Douglas DeMaio

    Trois instantanés openSUSE Tumbleweed ont été publiés depuis le dernier compte-rendu.


    Les trois instantanés Tumbleweed de cette semaine ont apporté un noyau Linux Kernel plus récent, des mises à jour de plusieurs paquets rubygem et des améliorations pour une bibliothèque annexe pour Xfce.


    L'instantané 20181126 a fourni le noyau Linux Kernel 4.19.4, qui corrigeait la gestion des VLAN et une fuite de mémoire avec le secure boot avec Nouveau.
    Le paquet YaST (Yet another Setup Tool) a mis à jour yast2-fonts 4.0.2 avec des polices qui modifient globalement les polices du bureau et plusieurs traductions ont également été mises à jour avec le paquet yast2-trans.


    La bibliothèque pour l’environnement de bureau Xfce desktop environment, exo est mise à jour vers la version 0.12.3; cela améliore l'espacement et l'alignement de la disposition et masque les lanceurs exo de GNOME Software.
    Le paquet de l'environment de développement intégré Kdevelop5 5.3.0, apporte une prise en charge améliorée du langage pour php, python et c++ et propose également un nouveau plugin analyseur clazy.


    Plusieurs autres bibliothèques ont été mises à jour, notamment libjansson 2.11, , libsemanage 2.8, libsepol 2.8, libzypp 17.9.0 et plus. Plusieurs paquets rubygem ont aussi été mis à jour dans la capture instantanée et rubygem-bundler 1.17.1 comportait une quantité importante d'ajouts et d'améliorations, notamment une option de configuration permettant de désactiver les avertissements de plate-forme.

    Le paquet mailutils 3.5 pour la gestion du courrier électronique a corrigé un bogue dans le codeur base64 encoder.
    Le générateur de parseur bison 3.2.2 3.2.2 a apporté d’énormes améliorations au squelette déterministe C ++, lalr1.cc et à la bibliothèque de manipulation des images TIFF, tiff 4.0.10 4.0.10, avec l’ajout de quelques correctifs qui traitent 10 patches de vulnérabilités Common Vulnerabilities and Exposures (Common Vulnerabilities and Exposures) qui ont pu être supprimés.


    Huit paquets ont été mis à jour dans l'instantané 20181122.
    Trois d'entre eux étaient des paquets associés à YaST, tels que yast2-ntp-client 4.1.6, qui alignait un bouton «Synchroniser maintenant» et une zone «Adresse du serveur NTP», qui ne cassaient pas le correctif précédent et ne masquaient pas la case à cocher manuelle dans TextMode.
    La quatrième version candidate de l'implementation libre du protocole RDP (Remote Desktop Protocol), freerdp 2.0.0, ajoutait la prise en charge permettant de définir le niveau de sécurité TLS (Transport Layer Security) pour openssl 1.1.0 1.1.0, ainsi que la prise en charge de la carte à puce pour les filtres de sous-chaîne. sudo 1.8.26 prend maintenant en charge les variables d'environnement LOGNAME et USER (ainsi que la variable LOGIN sous AIX) comme une seule unité avec la mise à jour vers sudo 1.8.26, qui a également ajouté la prise en charge du paramètre OpenLDAP TLS_REQCERT dans le fichier ldap.conf. Le paquet xapian-core 1.4.9 a corrigé un bogue pour gérer efficacement l’insertion d’un lot de positions supplémentaires par ordre croissant, ce qui pouvait entraîner des positions manquantes et la corruption des données de position codées.


    L'instantané Tumbleweed 20181120 a apporté Mozilla Thunderbird 60.3.1 et cette version corrige la suppression des cookies qui ne fonctionnait plus depuis la version 52 de Thunderbird. GNU Compiler Collection 8 a mis à jour la branche principale et supprimé un correctif. Le gobject-introspection 1.58.1 a supprimé un correctif pour warnlib et a ajouté de nouveau le fichier /usr/bin/env à python-cmd.

    La seule mise à jour majeure de cette semaine concerne la mise à jour du paquet d'iso-codes de la version 3.79 à la version 4.1, qui a mis à jour les langues d'Afrique du Sud et les traductions en italien et en estonien. Les paquets de vérification orthographique gtkspell3 3.0.10 et hunspell 1.7.0 ont reçu des mises à jour mineures. Le kit de développement logiciel (Plug-and-Play) Universal Plug and Play (libupnp 1.8.4), fourni des correctifs permettant de communiquer correctement avec certains téléviseurs et ainsi que des correctifs du compilateur. Skopeo 0.1.32, utilitaire en ligne de commande, a mis à jour des bibliothèques et mis à jour l’emplacement du projet depuis "projectatomic" à "conteneurs". Le paquet du système de fichiers xfsprogs 4.19.0 a supprimé le support de retpoline et apporté de nombreuses modifications de la libxfs 4.19 fusionnées depuis le noyau.


    D'après l'analyseur de snapshots Tumbleweed, l'instantané 20181120 a été gratifié d'un indice modérément stable de 83, l'instantané 20181122 a d'une note de 91 et l'instantané 20181126 d'un score de 88.
    Commentaires 1 Commentaire
    1. Avatar de passionlinux
      passionlinux -
      Coucou, merci de ce super exposé, juste un petit mot pour faire attention avec libuonp, depuis cette mise a jour mon système ne peut plus installer certain paquets et surtout VLC ne voit plus rien en UPnP et aussi minidlna qui fonctionnait tj très bien est pour le moment invisible, que ce soit localement sur la machine via VLC ou sur le réseau local avec mon appareil dlna ou encore la TV connectée qui jusqu'à présent fonctionnait parfaitement.

      Si vous pouvez bloquer juste le paquet libuonp pour le moment ça serait pas mal, un rapport de bug est en cours de correction.

      Bien amicalement les lézards