Afficher le flux RSS

Le coin de la bidouille, du packaging.......et de la bière !!!!!

Installation de Google-earth 7 sur opensuse 12.2

Noter ce billet
[ATTACH=CONFIG]1501[/ATTACH]
bon suite a beaucoup de problème avec google earth 7 je m'y suis penché

voici la procedure d'installation pour faire tourner Google-earth 7 sur openSUSE 12.2 en 64 Bit

1 Télécharger le paquet rpm X86-64 ici:
[LIST][*][URL]http://www.google.fr/intl/fr/earth/download/ge/agree.html[/URL] [/LIST]
Installer le via apper ou yast

2 Installer les librairies en 32 bits manquantes
[CODE]sudo zypper in libSM6-32bit Mesa-libGL1-32bit libXext6-32bit libXrender1-32bit libX11-6-32bit fontconfig-32bit[/CODE]

3 effacer/deplacer les fichiers de fonts qui mettent la grouille au démarrage
[CODE]sudo rm /etc/fonts/conf.d/65-fonts-persian.conf
sudo rm /etc/fonts/conf.d/11-suse-hinting.conf[/CODE]

ensuite vous pouvez relancer google-earth et il devrait fonctionner correctement

dans le cas ou lors du lancement vous n'auriez pas les maps, mais que tout le reste fonctionne, vous pouvez envisager de passer Mesa en version 9 avec toutes les librairies qui vont bien.

Source:
[LIST][*][URL]http://swyear.blogspot.tw/2012/11/google-earth-7.html[/URL] [/LIST]
Miniatures jointes Miniatures jointes Cliquez sur l'image pour l'afficher en taille normale

Nom : google-earth.jpg 
Affichages : 1313 
Taille : 67.2 Ko 
ID : 1501  

Mis à jour le 15/01/2013 à 12h17 par jluce

Catégorie
Sans catégorie

Commentaires

  1. Avatar de Syvolc
    Salut Jluce,

    Toujours rien pour moi.

    Comme tu peux voir, les dépendances que tu indiques sont bien installées :

    Code:
    @linux-dps2:~> sudo zypper in libSM6-32bit Mesa-libGL1-32bit libXext6-32bit
    root's password:
    Chargement des données du dépôt...
    Lecture des paquets installés...
    'Mesa-libGL1-32bit' est déjà installé.
    Pas de candidat à la mise à jour pour 'Mesa-libGL1-32bit-8.0.4-20.7.1.x86_64'. La version la plus récente est déjà installée.
    'libXext6-32bit' est déjà installé.
    Pas de candidat à la mise à jour pour 'libXext6-32bit-1.3.1-2.1.2.x86_64'. La version la plus récente est déjà installée.
    'libSM6-32bit' est déjà installé.
    Pas de candidat à la mise à jour pour 'libSM6-32bit-1.2.1-2.1.2.x86_64'. La version la plus récente est déjà installée.
    Résolution des dépendances des paquets...
    
    Rien à faire.
    @linux-dps2:~> google-earth
    Google Earth has caught signal 11.
    
    
    
    We apologize for the inconvenience, but Google Earth has crashed.
     This is a bug in the program, and should never happen under normal
     circumstances. A bug report and debugging data have been written
     to this text file:
    
        ~/.googleearth/crashlogs/crashlog-50e94d3e.txt
    
    Please include this file if you submit a bug report to Google.
    Google earth est bien à jour.

    Dans ~/.googleearth/crashlogs/crashlog-50e94d3e.txt il y a :

    Code:
    Major Version 7
    Minor Version 0
    Build Number 0002
    Build Date Dec 13 2012
    Build Time 17:54:43
    OS Type 3
    OS Major Version 3
    OS Minor Version 4
    OS Build Version 11
    OS Patch Version 16
    Crash Signal 11
    Crash Time 1357466942
    Up Time 0,005087
    
    Stacktrace from glibc:
    ./libgoogleearth_free.so(+0x1e9fab)[0xf75e3fab]
    ./libgoogleearth_free.so(+0x1ea1f3)[0xf75e41f3]
    linux-gate.so.1(__kernel_sigreturn+0x0)[0xf779a400]
    :-(

    Syvolc
  2. Avatar de jluce
    t'as viré les deux fichiers qui vont bien ??

    quelle carte graphique ??

    fais un
    Code:
    ldd /opt/google/earth/free/googleearth-bin
    a+
    Mis à jour le 08/01/2013 à 11h20 par jluce
  3. Avatar de Syvolc
    Oui, j'ai bien viré les fichiers.

    Code:
    @linux-dps2:~> sudo rm /etc/fonts/conf.d/65-fonts-persian.conf
    rm: impossible de supprimer « /etc/fonts/conf.d/65-fonts-persian.conf »: Aucun fichier ou dossier de ce type
    @linux-dps2:~> sudo rm /etc/fonts/conf.d/11-suse-hinting.conf
    rm: impossible de supprimer « /etc/fonts/conf.d/11-suse-hinting.conf »: Aucun fichier ou dossier de ce type
    
    @linux-dps2:~> ldd /opt/google/earth/free/googleearth-bin
            linux-gate.so.1 (0xf7766000)
            libpthread.so.0 => /lib/libpthread.so.0 (0xf7721000)
            libdl.so.2 => /lib/libdl.so.2 (0xf771c000)
            libgoogleearth_free.so => not found
            libglobalnew.so => not found
            libQtGui.so.4 => /usr/lib/libQtGui.so.4 (0xf6c39000)
            libQtNetwork.so.4 => /usr/lib/libQtNetwork.so.4 (0xf6af7000)
            libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xf6ac1000)
            libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xf6a37000)
            libcurl.so.4 => /usr/lib/libcurl.so.4 (0xf69d3000)
            libX11.so.6 => /usr/lib/libX11.so.6 (0xf6898000)
            libXrender.so.1 => /usr/lib/libXrender.so.1 (0xf688d000)
            libXext.so.6 => /usr/lib/libXext.so.6 (0xf687a000)
            libGL.so.1 => /usr/X11R6/lib/libGL.so.1 (0xf679e000)
            libGLU.so.1 => /usr/lib/libGLU.so.1 (0xf6728000)
            librt.so.1 => /lib/librt.so.1 (0xf671f000)
            libQtCore.so.4 => /usr/lib/libQtCore.so.4 (0xf6439000)
            libQtWebKit.so.4 => /usr/lib/libQtWebKit.so.4 (0xf4d0c000)
            libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xf4c20000)
            libm.so.6 => /lib/libm.so.6 (0xf4bf4000)
            libc.so.6 => /lib/libc.so.6 (0xf4a4e000)
            libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xf4a30000)
            /lib/ld-lsb.so.3 (0xf7767000)
            libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xf4933000)
            libpng14.so.14 => /usr/lib/libpng14.so.14 (0xf4908000)
            libz.so.1 => /lib/libz.so.1 (0xf48f1000)
            libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xf48a2000)
            libSM.so.6 => /usr/lib/libSM.so.6 (0xf4899000)
            libICE.so.6 => /usr/lib/libICE.so.6 (0xf487e000)
            libXi.so.6 => /usr/lib/libXi.so.6 (0xf486e000)
            libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xf4865000)
            libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xf485f000)
            libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xf4854000)
            libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xf4850000)
            libexpat.so.1 => /usr/lib/libexpat.so.1 (0xf4826000)
            libidn.so.11 => /usr/lib/libidn.so.11 (0xf47f3000)
            liblber-2.4.so.2 => /usr/lib/liblber-2.4.so.2 (0xf47e3000)
            libldap-2.4.so.2 => /usr/lib/libldap-2.4.so.2 (0xf4797000)
            libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0xf4759000)
            libssl.so.1.0.0 => /lib/libssl.so.1.0.0 (0xf46f6000)
            libcrypto.so.1.0.0 => /lib/libcrypto.so.1.0.0 (0xf453f000)
            libssh2.so.1 => /usr/lib/libssh2.so.1 (0xf4515000)
            libxcb.so.1 => /usr/lib/libxcb.so.1 (0xf44f2000)
            libnvidia-tls.so.304.64 => /usr/lib/tls/libnvidia-tls.so.304.64 (0xf44ee000)
            libnvidia-glcore.so.304.64 => /usr/lib/libnvidia-glcore.so.304.64 (0xf27e7000)
            libsqlite3.so.0 => /usr/lib/libsqlite3.so.0 (0xf2725000)
            libgstapp-0.10.so.0 => /usr/lib/libgstapp-0.10.so.0 (0xf2717000)
            libgstinterfaces-0.10.so.0 => /usr/lib/libgstinterfaces-0.10.so.0 (0xf2705000)
            libgstpbutils-0.10.so.0 => /usr/lib/libgstpbutils-0.10.so.0 (0xf26e2000)
            libgstvideo-0.10.so.0 => /usr/lib/libgstvideo-0.10.so.0 (0xf26c3000)
            libgstbase-0.10.so.0 => /usr/lib/libgstbase-0.10.so.0 (0xf2660000)
            libgstreamer-0.10.so.0 => /usr/lib/libgstreamer-0.10.so.0 (0xf2576000)
            libpcre.so.1 => /usr/lib/libpcre.so.1 (0xf2517000)
            libffi.so.4 => /usr/lib/libffi.so.4 (0xf250f000)
            libuuid.so.1 => /usr/lib/libuuid.so.1 (0xf2508000)
            libresolv.so.2 => /lib/libresolv.so.2 (0xf24f1000)
            libsasl2.so.2 => /usr/lib/libsasl2.so.2 (0xf24d4000)
            libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0xf2402000)
            libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0xf23d8000)
            libcom_err.so.2 => /lib/libcom_err.so.2 (0xf23d2000)
            libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0xf23c7000)
            libXau.so.6 => /usr/lib/libXau.so.6 (0xf23c3000)
            liborc-0.4.so.0 => /usr/lib/liborc-0.4.so.0 (0xf2333000)
            libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xf232e000)
            libxml2.so.2 => /usr/lib/libxml2.so.2 (0xf21db000)
            libkeyutils.so.1 => /lib/libkeyutils.so.1 (0xf21d6000)
            libselinux.so.1 => /lib/libselinux.so.1 (0xf21b8000)
            liblzma.so.5 => /usr/lib/liblzma.so.5 (0xf218e000)

    Ma carte est une PALIT NVIDIA GeForce GTX 560 Ti Twinlight Turbo
    Pilote 3D : NVIDIA 304.64 (proprio)

    Si tu ne trouves ne te prends pas trop la tête, une mise à jour corrigera peut-être le problème, et au pire ça me forcera à utiliser Marble :p
  4. Avatar de jluce
    yop oui j'ai vu

    non par contre regarde le post de vicky la partie avec le echo et le ldconfig, ca te remettra le ldd en place normalement

    a+