Aller au contenu principal

Sujets

Cette espace vous permet de voir toutes les Sujets réalisées par ce membre. Vous ne pouvez voir que les Sujets réalisées dans les espaces auxquels vous avez accès.

Sujets - yoman

1
Internet, réseaux et serveurs / streaming impossible dernière maj tumbleweed
  
Bonjour

La dernière maj de Tumbleweed, empêche la lecture streaming sur certains sites.

Il faut annuler le changement de vendeur de multimédia (opensuse) et revenir a Packman

sudo zypper dup --allow-vendor-change --from Packman

Voilà vous pourrez a nouveau surfer sur les sites streamings.

ps : certains paquets seront downgraded , mais je pense qu'ils seront mise à jour rapidement.
3
Programmes et logiciels / PulseEffects plugins manquants
Bonjour

Amoureux du bon son,  vous utilisez sur OpenSuse Tumbleweed, l'outils remarquable "PulseEffects" pour le traitement sonore.

Et bien, il se peut que vous ne puissiez pas utiliser tous les plugins de cette applications.

Le coupable 😠: des plugins manquants.

  • lv2-lsp-plugins
  • calf
  • lsp-plugins

Maintenant vous devriez avoir l'accès aux nombreux plugins audios après installation.

Attention :
  • gstreamer-1.0 doit être installer
  • droits accès au répertoire
rwxr-xr-x /usr/lib64/gstreamer-1.0
[1]
problème similaire sur : manjaro, linux-mint, tumbleweed-opensuse
4
Général / Fix paramètres d'affichage des applications QT KDE
Bonjour

Lorsque vous essayez d'utiliser une application pour ajuster les paramètres d'affichage des applications QT, le message d' erreur suivant peut s'afficher :



Voici comment y remédier:

1. Installez
  • libqt5-qtstyleplugins
  • qt5ct
2. Editez le fichier "environnement" avec votre éditeur personnel
sudo nano /etc/environment 

3. et ajoutez la ligne suivante:
  • QT_QPA_PLATFORMTHEME = qt5ct

4. Redémarrez le système.

Vous devriez maintenant pouvoir ouvrir les paramètres QT5 et ajuster les éléments visuels de vos applications QT afin qu'ils correspondent au reste de votre système.

5
Sécurité / Tumbleweed, bug mot de passe depuis octobre
Bonjour

Un bug dans le programme d’installation existant depuis au moins un mois signifie que, dans certains cas, le premier utilisateur normal créé (et non root) sur une nouvelle installation de Tumbleweed utilise le hachage DES comme mot de passe. Ce hachage est obsolète depuis 20 ans et n'utilise que les 8 premiers caractères de votre mot de passe.

Pour vérifier si vous êtes affecté, vous pouvez notamment vérifier les premiers caractères du hachage du mot de passe de votre utilisateur  dans le fichier  :
/etc/shadow

Si cela ne commence pas par un $, vous devez re-hacher votre mot de passe ou un autre hachage moderne.

Exemple

john:$6$Quie7lei....
Mot de passe Secure
john:Quie7lei...
Mot de passe Insecure

Sinon, vérifiez simplement si le système accepte une version abrégée à 8 caractères de votre mot de passe.

Si vous êtes concerné, assurez-vous que votre fichier

/etc/login.defs

contient ENCRYPT_METHOD sha512 ou un autre hachage moderne.

Correction en attendant la maj

Utilisez passwd dans un ternminal en non-root et suivez les instructions :

passwd

Vous pouvez le changer pour qu'il s'agisse du même mot de passe, mais vous devez suivre toutes les étapes pour réorganiser votre mot de passe maintenant .


Il s'agit d'un problème de sécurité important dans la mesure où une fuite de mot de passe par hachage DES permet aux attaquants de procéder à un reverse engineering très simple des 8 premiers caractères de votre mot de passe (et ainsi de pénétrer dans votre système ou d'utiliser ces informations ailleurs).

Le programme d'installation sera corrigé sous peu, mais il n'existe pas de moyen facile de mettre à jour le hachage du mot de passe pour les utilisateurs concernés, mis à part leur demander de "changer" leur mot de passe comme indiqué ci-dessus.

Par conséquent, toute personne ayant installé une nouvelle version de Tumbleweed ou créé un nouvel utilisateur dans YaST depuis le 22 octobre 2019 devrait vérifier le hachage de son mot de passe et réinitialiser son mot de passe si nécessaire (voir les instructions dans cet article).


Source :

reddit OpenSuse
[1]
[2]
[3]
6
Programmes et logiciels / Openshot ne se lance pas
Bonjour.

La cohabitation des applications gtk sous environnement qt, ne se passent pas toujours bien.

Prenons notre ami  Editeur de Vidéo "Openshot" écrit en pyGtk, (écrit en Python pour des applications utilisant des bibliothèques Gtk).

Citer
Et Bien M. KDE Plasma, n'est pas content, et refuse de lancer Openshot, dans la majeur partie des cas.

(Voilà une chose que les windowsiens et macOS fuient, : C'est de mettre la main dans le cambouis, ils ont bien autres choses a faire en sortant du taff). Propriétaire Vs Opensource...
 

Si vous avez un refus d'openshot de se lancer, avec pour erreur :


  • vérifier que vous avez installer -python3-setuptools (qui fournit pkg_ressources)
  • vérifier les droits d'accés au dossier "site-packages" :
/usr/lib/python3.7/site-packages


Si vous avez un refus de permission d'accès
changez les droits d'accès au dossier "site-packages'
sudo chmod -R 755 site-packages
Ceci permettra l'accès Lecture & exécution pour
  • groupe
  • et autres

et ainsi l'accès necéssaire au dossier :
  • wheel-0.33.6.dist-info

et aux fichiers
  • PKG-INFO
  • entry.points.txxt
du répertoir : openshot_xxxx-xxx.egg-info

Et voilà , vous aurez Openshot Editor Vidéo gratuitement qui fonctione sous KDE Plasma  ;D

[1]

Vous pouvez faire chmod récurssif  2 répertoires  cités
7
Programmes et logiciels / Mise a jour fichier conf resolveur dns Unbound
Bonjour a tous

Depuis 1 an je mets a jour le tuto que j'ai fais sur le Wiki d'OpenSuse, concernrant le résolveur dns Unbound.

Pour ceux que ça interesse, j'ai mis a jour le fichier conf aujourd'hui.

La modification du fichier conf :

  • Optimisation requettes, dns, udp, tpc, ttl
  • Sécurité : ddos, dnssec, flood
  • Corrections configurations

Les liens :

👉 Wiki Unbound
  👉 Fichier conf Unbound
[1]
Après test, les requettes dns sont rapide et la  navigation internet et lecture sequence vidéo fluide.
9
Programmes et logiciels / GoogleEarthPro Positionnement erroné
Bonjour

Petit tuto pris sur le Forum Ubuntu applicable pour les OS Suse / OpenSUSE

Lors d'une recherche d'un lieu ou de l'utilisation de fichier GPS au format gpx ou klm, GoogleEarth ne vous positionne pas du tout au bon endroit (en Afrique pour une recherche en France !). En fait, GE utilise les informations (waypoints, trace…) sur des coordonnées arrondi à l'entier le plus proche. Cela peut également se traduire par l'incapacité de voir les fichiers ouverts. C'est lié au non respect par Google Earth de variables d'environnement.

Depuis un terminal avec les droits d'administration, éditer l'application GoogleEarth avec votre éditeur de text . (nano pour moi)

Version 7.1 de GoogleEarth
sudo nano opt/google/earth/free/googleearth

Version 7.3 nommée GoogleEarth Pro, le chemin est légèrement modifié :
sudo nano opt/google/earth/pro/googleearth

Au dessus de la dernière ligne : LD_LIBRARY_PATH=.:$LD_LIBRARY_PATH ./googleearth-bin "$@"

ajouter la ligne :

export LC_NUMERIC=en_US.UTF-8

Enregistrer le fichier .

Et le tour est joué, vous pourrez désormais avoir un positionnement précis d'après votre critère de recherche.


10
Débat, sondages et tribune... / le 30 novembre OpenSUSE journée de la CyberSécurité et du Logiciel Libre
Bonjour

Un RDV intéressant

Une nouvelle édition de l’événement communautaire est programmée le 30 novembre prochain à la Maison St Sever à Rouen. Voici le programme.

Pour l’édition de novembre, les organisateurs vous invitent à faire connaissance avec la toute dernière version d’openSUSE Leap 15.1, mais aussi GNOME 3.32, LibreOffice 6.2.3 et beaucoup d’autres distributions Linux. SUSE Linux Enterprise 15 SP1 sera aussi de la partie. Les organisateurs distribueront sur place des versions DVD d’openSUSE 15.1 (64 bits) aux visiteurs, dans la limite du stock disponible.
L'atelier de cybersécurité reprendra les sujets abordés cette année, à savoir clés gpg, DNS RPZ, openVAS, osquery. Le Raspberry Pi 3 ainsi que les Raspberry Pi 2 seront aussi à votre disposition pour votre plaisir de coder.

Pour participer, rendez-vous le samedi 30 novembre de 14 à 18h.

Pour les informations pratiques, rendez-vous sur le site web NUI


11
Sécurité / Ransomware crypte les données sur les serveurs Linux NextCloud
Bonjour à tous

Un nouveau logiciel ransomware a été trouvé dans la nature qui n'est actuellement pas détecté par les moteurs antivirus sur les plates-formes d'analyse publiques. Son nom est NextCry en raison de l'extension ajoutée aux fichiers cryptés et du fait qu'il cible les clients du service de synchronisation et de partage de fichiers NextCloud.

Le lien de l'article 
Ransomware serveur NextCloud
12
Internet, réseaux et serveurs / explorateur réseau accès NAS impossible
Bonjour à tous


Voilà je traine un soucis depuis pas mal d'année avec opensuse.. je n'arrive pas a avoir accès à mon NAS branché sur ma Box.

Est-ce un soucis de KDE ou d'opensuse ?

ps : sous LMDE3 , Fedora gnome, arch et manjaro , je n'ai pas soucis... (ni sous ubuntu 🤔)
13
Programmes et logiciels / Tumbleweed : impossible de supprimer un paquet
Bonjour

Je fais une maj d'une résolution de bug trouvé sur l'ancien Forum.

Lors de la mise à jour de Trumbleweed, j'obtiens le message suivant:
Les 4 paquets suivants vont être SUPPRIMÉS : 
  chromium             78.0.3904.87-1.1
  NetworkManager       1.18.4-1.1      
  NetworkManager-lang  1.18.4-1.1      
  typelib-1_0-NM-1_0   1.18.4-1.1      
 
4 paquets à supprimer.
Après l'opération, 307,6 MiB d'espace disque sera libéré.
Continuer ? [o/n/v/...? affiche toutes les options] (o): 
(1/4) Suppression de NetworkManager-1.18.4-1.1.x86_64 .....................................[erreur]
Échec de la suppression de (234106)NetworkManager-1.18.4-1.1.x86_64(@System) :
Erreur: Subprocess failed. Error: Échec RPM : error: package NetworkManager-1.18.4-1.1.x86_64 is not installed                                                
                                                                                                                                                              
Abandonner, réessayer, ignorer ? [a/r/i] (a): a
Un problème s'est produit pendant ou après l'installation ou la suppression des paquets :
L'installation a été abandonnée comme demandé.                                                                                                                
Veuillez consulter le message d'erreur ci-dessus pour une indication.

Finalement, il s'agit d'un problème de corruption de la base de données rpm, qui peut se résoudre par:

sudo rpm --rebuilddb

Voilà si ça peut aider, ça a permis de résoudre mon bug.