Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: Python 3.8 ou plus (Lu 543 fois) sujet précédent - sujet suivant

Python 3.8 ou plus

Il y a t'il un moyen, d'installer Python 3.8 (ou 3.9, 3.10) avec Opensuse 15.4 ?

Re : Python 3.8 ou plus

Répondre #1
Salut,

Tu as quelle version de Python 3 sur Leap 15.4 ?

Re : Python 3.8 ou plus

Répondre #2
La 3.6.15 et il me faut au minimum la 3.8 pour un logiciel.

Re : Python 3.8 ou plus

Répondre #3
Salut,
J'ai eu le même besoin.
Voici comment installer la version 3.9 de Python :

sudo zypper in python39

Re : Python 3.8 ou plus

Répondre #4
 J'ai essayé voici la fin du retour:

Recherche de conflits de fichiers : ...........................................................................[fait]
(1/7) Installation de : python39-base-3.9.16-150300.4.24.1.x86_64 .............................................[fait]
/sbin/ldconfig: /usr/lib64/libgfortran.so.3 is not a symbolic link
(2/7) Installation de : libpython3_9-1_0-3.9.16-150300.4.24.1.x86_64 ..........................................[fait]
(3/7) Installation de : python39-3.9.16-150300.4.24.1.x86_64 ..................................................[fait]
(4/7) Installation de : python39-curses-3.9.16-150300.4.24.1.x86_64 ...........................................[fait]
(5/7) Installation de : python39-dbm-3.9.16-150300.4.24.1.x86_64 ..............................................[fait]
update-alternatives: using /usr/bin/easy_install- to provide /usr/bin/easy_install (easy_install) in auto mode
(6/7) Installation de : python39-setuptools-44.1.1-150300.7.6.1.noarch ........................................[fait]
(7/7) Installation de : python39-pip-20.2.4-7.8.1.noarch ......................................................[fait]
Un problème s'est produit pendant ou après l'installation ou la suppression des paquets :
Failed to cache rpm database (1).
Historique :
 - 'rpmdb2solv' '-r' '/' '-D' '/usr/lib/sysimage/rpm' '-X' '-p' '/etc/products.d' '/var/cache/zypp/solv/@System/solv' '-o' '/var/cache/zypp/solv/@System/solv0sGIp5'
   rpmdb2solv: inconsistent rpm database, key 1392 not found. run 'rpm --rebuilddb' to fix.


Re : Python 3.8 ou plus

Répondre #5
Bon e nfaisant
rpm --rebuilddb
puis zypper inpython39
Cela s'est installé.
Merci