Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: Une erreur de packetage qui "traine"...  (Lu 1317 fois) sujet précédent - sujet suivant

Une erreur de packetage qui "traine"...

Bonjour tous,

Depuis plusieurs jours j'ai l'erreur ci-dessous dans les dépendances lors de la mise à jour avec Tumbleweed.
J'ai choisi Cancel car je me disais, comme assez souvent, c'est urgent d'attendre....
Et là, c'est quand même un changement de fournisseur qui me semble pas pertinent : les package PACMAN étant toujours meilleurs que les zotres...
Citer
Problem: problem with the installed libsox3-14.4.2-1599.7.pm.137.x86_64
Problem: problem with the installed sox-14.4.2-1599.7.pm.137.x86_64
Problem: the to be installed pipewire-alsa-0.3.70-1.1.x86_64 conflicts with 'alsa-plugins-pulse' provided by the to be installed alsa-plugins-pulse-1.2.7.1-4.4.x86_64
Problem: the to be installed gcc11-11.3.1+git2076-3.1.x86_64 requires 'libtsan0 >= 11.3.1+git2076-3.1', but this requirement cannot be provided

Problem: problem with the installed libsox3-14.4.2-1599.7.pm.137.x86_64
 Solution 1: install libsox3-14.4.2-6.1.x86_64 from vendor openSUSE
  replacing libsox3-14.4.2-1599.7.pm.137.x86_64 from vendor http://packman.links2linux.de
 Solution 2: keep obsolete libsox3-14.4.2-1599.7.pm.137.x86_64

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c/d/?] (c):


Vous en pensez quoi vous ?
Y a quelqu'un.e qui a rencontré ce problème récemment ?
Merci d'avance
Amicalement
Philippe

Re : Une erreur de packetage qui "traine"...

Répondre #1
Comme d'habitude, je choisi de garder la version soi-disant obsolète.

Re : Une erreur de packetage qui "traine"...

Répondre #2
Bonsoir @sobkowiak

Et tu as eu ce problème aussi ?
Je me lasse un peu d'attendre vu que ça va faire une semaine et que le nombre de package à mettre a jour grossi ... 640 ce matin...
Je pense que je vais faire comme tu dis
Amicalement
Philippe

PS : Mais je me méfie car c'est le son cette histoire ...

Re : Une erreur de packetage qui "traine"...

Répondre #3
Salut,

Perso j'ai choisi la solution 1. Ça n'a rien cassé et le son est toujours là. Je suppose qu'une prochaine mise à jour demandera de faire le chemin inverse... :)


à plus,
oh!rocks

Re : Une erreur de packetage qui "traine"...

Répondre #4
Je plussoie oh!rocks

Re : Une erreur de packetage qui "traine"...

Répondre #5
Citer
Et tu as eu ce problème aussi ?
Je me lasse un peu d'attendre vu que ça va faire une semaine et que le nombre de package à mettre a jour grossi ... 640 ce matin...
Je pense que je vais faire comme tu dis
Je n'ai pas eu votre problème. Mais je procède comme ça régulièrement. Après vous avoir répondu, j'ai fais une m-à-j de Tumbleweed de 509 paquets, mais 5 ou 6 paquets étaient en conflit, qui m'auraient poussé à rétrograder plus grosse partie de cette m-à-j. J'ai choisi de conserver ces paquets, sachant qu'un jour il sera possible de les mettre à jour. Il y a régulièrement cette situation avec Leap 15.4, mais là, c'est parce que j'utilise le dépôt KDE Framework version 5.106.0

Re : Une erreur de packetage qui "traine"...

Répondre #6
Bonjour à tous,

Encore merci de vos réponses, c'est toujours un plaisir ce forum !
Alors ce matin, je voulais mettre en place la solution de @sobkowiak mais au fur et à mesure que je répondais en mettant l'option "keep obsolete ..." il m'en sortait un autre ... puis un autre ... puis encore jusqu'à plus de 10 et dedans il y a eu GCC ... du coup là j'ai franchement pétoché... J'ai fait Cancel et je suis ... revenu ici...
Et là je lis la proposition de @oh!rocks ...
Ok, je vais tester ça pour voir si c'est moins "angoissant" pour mon PC et moi...  :))
Je reviens dire soon
Amicalement
Philippe

Re : Une erreur de packetage qui "traine"...

Répondre #7
Update ...
Bon, c'est un poil plus ennuyant...
Les deux problèmes (SOX et GCC) ne sont pas liés...
Autant pour SOX et ses deux amis j'ai choisi 1 ... autant pour le GCC et plusieurs de ses amis il me parle de désinstallation ...
Bref...
J'ai plus le temps la mais je reviens ASAP avec des copies des messages
Amicalement
Philippe

Re : Une erreur de packetage qui "traine"...

Répondre #8
Re bonjour,

Donc j'ai ça en plus maintenant :
Problem: the to be installed gcc11-11.3.1+git2076-3.1.x86_64 requires 'libtsan0 >= 11.3.1+git2076-3.1', but this requirement cannot be provided
  not installable providers: libtsan0-gcc11-11.3.1+git2076-3.1.x86_64[http-download.opensuse.org-4f295538]
                   libtsan0-gcc11-11.3.1+git2076-3.1.x86_64[repo-oss]
 Solution 1: Following actions will be done:
  keep obsolete gcc11-11.3.1+git2076-2.3.x86_64
  keep obsolete cpp11-11.3.1+git2076-2.3.x86_64
  keep obsolete libtsan0-11.3.1+git2076-2.3.x86_64
 Solution 2: deinstallation of gcc11-11.3.1+git2076-2.3.x86_64
 Solution 3: deinstallation of libtsan0-11.3.1+git2076-2.3.x86_64
 Solution 4: break gcc11-11.3.1+git2076-3.1.x86_64 by ignoring some of its dependencies

Urgent d'attendre ? ou pas ?
Philippe

Re : Une erreur de packetage qui "traine"...

Répondre #9
À mon avis oui,et attendre une prochaine maj

Re : Une erreur de packetage qui "traine"...

Répondre #10
Vous n'auriez pas installé un bureau supplémentaire genre Lxde ? Sur mon pc, seul Amarok est un paquet git.

Re : Une erreur de packetage qui "traine"...

Répondre #11
Salut,
Problem: problem with the installed libsox3-14.4.2-1599.7.pm.137.x86_64

Problem: problem with the installed sox-14.4.2-1599.7.pm.137.x86_64
Ces paquets sont-ils toujours disponibles dans packman ?
D'après ceci https://lists.opensuse.org/archives/list/support@lists.opensuse.org/thread/KBTPWQ5MGGCVY5FDJJ3Z7OZONUW3ZBOD/ ce n'était plus le cas il y a quelques jours.
Toujours d'après cette discussion, ton problème de gcc11 serait dû à un miroir pas à jour...

Re : Une erreur de packetage qui "traine"...

Répondre #12
Ces paquets sont-ils toujours disponibles dans packman ?

Bonjour,

Pas chez moi.

Re : Une erreur de packetage qui "traine"...

Répondre #13
Donc le paquet sox etc doit être repassé sur openSUSE au besoin en le rétrogradant s'il est nécessaire.

Re : Une erreur de packetage qui "traine"...

Répondre #14
Bonsoir à tous,

Ben ... ça a marché sur mon fixe mais ... J'ai un peu trainé sur le portable et là je me retrouve avec 600 packets à mettre à jour mais ... Tout KDE qu'il veut désinstaller....
Bizarre bizarre....
Je vais pas vous envoyer la copie d'écran des erreurs car là, franchement ça fait 10 km de long...
Pour l'instant j'ai fait "Cancel" et j'attends ...
Sauf si l'un de vous a une vraiment bonne raison à me donner qui m'obligerait à me prendre par la main et modifier plein de packets
...
J'ai la pétoooooooche ....  :o  :o  :o  :o  :o  :o
Je vais encore tout casser !!!
Philippe