Aller au contenu principal
Sujet: Maj Tumbleweed et gstreamer-plugins-libav (packman) (Lu 4144 fois) sujet précédent - sujet suivant

Maj Tumbleweed et gstreamer-plugins-libav (packman)

Bonjour,

Les dernières tentatives pour mettre à jour Tumbleweed (zypper dup) avec le dépôt Packman actif, font apparaître une question qui peut être embarrassante :

Problème : problème avec l'élément gstreamer-plugins-libav-1.22.2-1699.86.pm.3.x86_64 installé
 Solution 1 : installer gstreamer-plugins-libav-1.22.2-1.2.x86_64 du fournisseur openSUSE
en remplaçant gstreamer-plugins-libav-1.22.2-1699.86.pm.3.x86_64 du fournisseur http://packman.links2linux.de
 Solution 2 : conserver l'élément gstreamer-plugins-libav-1.22.2-1699.86.pm.3.x86_64 obsolète

Il n'y a aucun inconvénient à choisir la solution 1 et celle-ci est d'ailleurs la plus recommandée car l'élément gstreamer-plugins-libav a été supprimé du dépôt Packman. Aucune incidence sur la lecture des vidéos.

Source : https://www.reddit.com/r/openSUSE/comments/13pubfn/media_codecs_update_annoyance/

Pour info et surtout à destination des nouveaux utilisateurs de Tumbleweed dont le nombre me semble croître ici.

Re : Maj Tumbleweed et gstreamer-plugins-libav (packman)

Répondre #1
Merci @Chumi:)
J'en profiote pour rappeler que packman n'est plus indispensable pour la majorité des usages. Il y a un nouveau dépôt qui propose le codec h264 et ne rentre pas en conflit avec les paquets des dépôts officiels.
Source : https://news.opensuse.org/2023/01/24/opensuse-simplifies-codec-install/

Re : Maj Tumbleweed et gstreamer-plugins-libav (packman)

Répondre #2
@chalu : J'ai une palanquée de paquets de Packman qui est installée chez moi. Hormis un ou deux qui ne me sont pas essentiels et que j'ai installés en plus, tous les autres proviennent de l'installation des codecs telle qu'elle est décrite ici ou là. Comment faire pour revenir à une situation initiale, sans Packman, sans rien casser, afin d'utiliser ultérieurement le nouveau dépôt et voir s'il me suffit? Je n'ai pas de gros besoins... juste ne pas être empêché de voir n'importe quel type de vidéo sur internet ou avec VLC.

Re : Maj Tumbleweed et gstreamer-plugins-libav (packman)

Répondre #3
Si je me souviens bien, j'avais fait comme pour passer sur packman (mais dans l'autre sens) avec YaST.
J'ai choisi le dépôt principal et j'ai cliqué sur le lien "Remplacer les paquets système par ceux de ce dépôt".
Après on doit pouvoir vérifier ceux qui reste sur packman, au besoin les désinstaller si on ne les utilise pas.
Ensuite j'ai supprimé le dépôt.

Re : Maj Tumbleweed et gstreamer-plugins-libav (packman)

Répondre #4
Si je me souviens bien, j'avais fait comme pour passer sur packman (mais dans l'autre sens) avec YaST.
J'ai choisi le dépôt principal et j'ai cliqué sur le lien "Remplacer les paquets système par ceux de ce dépôt".
Après on doit pouvoir vérifier ceux qui reste sur packman, au besoin les désinstaller si on ne les utilise pas.
Ensuite j'ai supprimé le dépôt.

Je viens d'essayer sur mon portable en passant par Yast et une question délicate surgit. Pour la retranscrire ici j'ai refait la même chose en lignes de commande :

sudo zypper dup --allow-vendor-change --from http://download.opensuse.org/tumbleweed/repo/oss/
Chargement des données du dépôt...
Lecture des paquets installés...
Calcul de la mise à niveau de la distribution...

Problème : l'élément vlc-codecs-3.0.18-1699.10.pm.9.x86_64 installé nécessite 'libavcodec58_134(unrestricted)', mais cette exigence ne peut pas être remplie
 Solution 1 : désinstallation de vlc-codecs-3.0.18-1699.10.pm.9.x86_64
 Solution 2 : conserver l'élément libavcodec58_134-4.4.4-1699.1.pm.9.x86_64 obsolète
 Solution 3 : installer vlc-beta-20230511.6fbf34d454-1699.7.pm.1.x86_64 à partir du dépôt exclu
 Solution 4 : casser vlc-codecs-3.0.18-1699.10.pm.9.x86_64 en ignorant certaines de ses dépendances

Choisir une des solutions ci-dessus en tapant son numéro ou bien annuler en tapant 'a' [1/2/3/4/a/d/?] (a):
Un, je ne sais pas quelle est la bonne réponse et de deux, j'ai des doutes quant à l'utilisation ultérieure de VLC quand j'aurai activé le nouveau dépôt et le nouveau paquet qui va bien pour les codecs.

Re : Maj Tumbleweed et gstreamer-plugins-libav (packman)

Répondre #5
solution 1
Voici les paquets installés liés à vlc chez moi :

S | Name                        | Type   | Version       | Arch         | Repository 
--+-----------------------------+--------+---------------+--------------+----------------------
i | libvlc5                     | paquet | 3.0.18-7.1    | x86_64       | Dépôt principal (OSS)
i | libvlccore9                 | paquet | 3.0.18-7.1    | x86_64       | Dépôt principal (OSS)
i | vlc                         | paquet | 3.0.18-7.1    | x86_64       | Dépôt principal (OSS)
i | vlc-codec-gstreamer         | paquet | 3.0.18-7.1    | x86_64       | Dépôt principal (OSS)
i | vlc-lang                    | paquet | 3.0.18-7.1    | noarch       | Dépôt principal (OSS)
i | vlc-noX                     | paquet | 3.0.18-7.1    | x86_64       | Dépôt principal (OSS)
i | vlc-qt                      | paquet | 3.0.18-7.1    | x86_64       | Dépôt principal (OSS)
i | vlc-vdpau                   | paquet | 3.0.18-7.1    | x86_64       | Dépôt principal (OSS)
Je n'ai pas de souci de lecture. Tu notes le paquet vlc-codec-gstreamer qui doit faire le job.


Re : Maj Tumbleweed et gstreamer-plugins-libav (packman)

Répondre #6
Je n'ai pas de souci de lecture. Tu notes le paquet vlc-codec-gstreamer qui doit faire le job.

Oui je note. J'ai procédé au nettoyage et à la neutralisation de Packman sur mon portable (dépôt désactivé pour l'instant). Une petite visite des paquets orphelins n'a pas non plus été inutile pour ce faire. Et j'ai, c'était le but, activé le nouveau dépôt et installé le paquet pour les codecs. La question était pour moi de savoir comment rétropédaler proprement avec Packman pour repartir sur du neuf en termes de codecs. Après on verra si je me contente de cette nouvelle configuration ou s'il manque quelque chose de plus exotique. Packman offre beaucoup et n'est pas désuet  je pense mais combien sommes-nous qui pourraient peut-être s'en passer aujourd'hui? L'actualisation du guide multimédia dont tu parles dans un autre fil est une bonne idée.

Re : Maj Tumbleweed et gstreamer-plugins-libav (packman)

Répondre #7
Ça fait un moment et je n’ai pas eu de souci. Alors je croise les doigts ;)
Sinon j’utilise les flatpaks si je veux un logiciel qui n’existe pas dans les dépôts officiels et distrobox. Jusqu’à présent Packman ne m’a pas manqué :)

 

Re : Maj Tumbleweed et gstreamer-plugins-libav (packman)

Répondre #8
@chalu : Bonjour. Oui... mais non  :( Il y a des vidéos que je ne peux plus lire avec VLC dans cette nouvelle configuration. Une vidéo .mp4 pour laquelle j'ai le son mais pas l'image et des films en .avi provenant de dvds rippés (je m'en fiche de ceux là aujourd'hui mais le fait est que je ne peux plus les lire, ni son ni image et ils plantent VLC). J'ai essayé SMPlayer, il lit bien mon mp4 mais plante avec les films avi.

Re : Maj Tumbleweed et gstreamer-plugins-libav (packman)

Répondre #9
mp4 , avi c'est un conteneur. Donne les codecs utilisés.
Chez moi, j'ai des vidéos en mp4 et pas de soucis. J'ai lu un DVD acheté dans le commerce avec ses protections (j'ai bien sûr installé libdvdcss2).
Citer
J'ai essayé SMPlayer, il lit bien mon mp4
alors ce n'est pas un problème du système, il doit manquer des paquets.
Je redonne les paquets vlc et gstreamer installés chez moi :
S | Name                | Summary                                          | Type
--+---------------------+--------------------------------------------------+-------
i | libvlc5             | Shared code for the VLC media player program     | paquet
i | libvlccore9         | Shared code for the VLC media player program     | paquet
i | vlc                 | Graphical media player                           | paquet
i | vlc-codec-gstreamer | GStreamer integration for the VLC media player   | paquet
i | vlc-lang            | Translations for package vlc                     | paquet
i | vlc-noX             | VLC without X dependencies                       | paquet
i | vlc-qt              | Qt interface for the VLC media player            | paquet
i | vlc-vdpau           | Additional vdpau codecs for the VLC media player | paquet
S  | Name                              | Summary                                                         | Type
---+-----------------------------------+-----------------------------------------------------------------+-------
i  | gstreamer                         | Streaming-Media Framework Runtime                               | paquet
i  | gstreamer-lang                    | Translations for package gstreamer                              | paquet
i  | gstreamer-libnice                 | GStreamer plugin for the Interactive Connectivity Establishment | paquet
i+ | gstreamer-plugin-openh264         | Gstreamer openh264 plugin                                       | paquet
i+ | gstreamer-plugin-pipewire         | Gstreamer Plugin for PipeWire                                   | paquet
i+ | gstreamer-plugins-bad             | GStreamer Streaming-Media Framework Plug-Ins                    | paquet
i+ | gstreamer-plugins-bad-lang        | Translations for package gstreamer-plugins-bad                  | paquet
i  | gstreamer-plugins-base            | GStreamer Streaming-Media Framework Plug-Ins                    | paquet
i  | gstreamer-plugins-base-lang       | Translations for package gstreamer-plugins-base                 | paquet
i  | gstreamer-plugins-farstream       | GStreamer Plug-Ins for videoconferencing                        | paquet
i  | gstreamer-plugins-good            | GStreamer Streaming-Media Framework Plug-Ins                    | paquet
i  | gstreamer-plugins-good-gtk        | Gtksink plugin for gstreamer-plugins-good                       | paquet
i  | gstreamer-plugins-good-lang       | Translations for package gstreamer-plugins-good                 | paquet
i+ | gstreamer-plugins-libav           | A ffmpeg/libav plugin for GStreamer                             | paquet
i+ | gstreamer-plugins-ugly            | GStreamer Streaming-Media Framework Plug-Ins                    | paquet
i+ | gstreamer-plugins-ugly-lang       | Translations for package gstreamer-plugins-ugly                 | paquet
i  | gstreamer-plugins-vaapi           | Gstreamer VA-API plugins                                        | paquet
i  | libgstreamer-1_0-0                | Streaming-Media Framework Runtime                               | paquet
i  | libgupnp-dlna-backend-gstreamer   | GUPnP-DLNA GStreamer meta-extraction backend                    | paquet
i  | PackageKit-gstreamer-plugin       | Install GStreamer codecs using PackageKit                       | paquet
i+ | phonon4qt5-backend-gstreamer      | Phonon Multimedia Platform Abstraction                          | paquet
i  | phonon4qt5-backend-gstreamer-lang | Translations for package phonon4qt5-backend-gstreamer           | paquet
i  | vlc-codec-gstreamer               | GStreamer integration for the VLC media player                  | paquet
et pour ffmepg (peut-être pas utile, c'est un logiciel je ne sais plus lequel qui le demande chez moi) :
i  | ffmpeg-5     | Set of libraries for working with various multimedia formats | paquet
i+ | ffmpegthumbs | FFmpeg-based thumbnail creator for video files               | paquet

Re : Maj Tumbleweed et gstreamer-plugins-libav (packman)

Répondre #10
Je te rajoute une piste si tu as tous ces paquets installés, j'ai eu un problème de lecture avec VLC, pas d'image mais le son et ça provenait de la sortie vidéo qui n'était pas réglé comme il faut. 
Tu regarderas pour ton mp4 avec VLC si dans Outils > préférences > entrées/codecs, tu as du changement en réglant différemment le décodage matériel.

Re : Maj Tumbleweed et gstreamer-plugins-libav (packman)

Répondre #11
@chalu : VLC, j'ai les mêmes paquets. Gstreamer, il m'en manque visiblement (notamment gstreamer-plugin-pipewire) mais tous ne me semblent pas utiles pour moi. ffmpeg, j'ai ffmpeg4.

Pas trouvé la piste de la sortie vidéo sur VLC pour mon mp4. Pour mes films .avi, ce sont des XviD.

Là j'ai survolé car je n'ai pas trop le temps avant demain ou après-demain.

Re : Maj Tumbleweed et gstreamer-plugins-libav (packman)

Répondre #12
ah oui alors ça vient peut-être du xvid. C'est vieux ça, j'en avais il y a longtemps quand je rippais des dvd pour les mettre sur CD :)
Maintenant mes mp4 sont avec H264 et il n'y a pas de problème.
Je vais essayer de faire une video avec xvid en avi et de voir comment ça peut être lu. En plus c'est bizarre, xvid ça semble libre donc je ne vois pas pourquoi ça poserait problème de l'avoir par défaut dans openSUSE.
Édit : je ne lis pas non plus les xvid. Je ne sais pas si c’est normal car xvid est libre me semble-t-il.
Avec la version flatpak de vlc, pas de souci de lecture.
À toi de voir si lire des xvid est indispensable, j’ai l’impression que h264 a pris le dessus, mais bon…
Tu peux encoder ton xvid en h264 sinon tu installes manuellement le paquet xvidcore de Packman.

Re : Maj Tumbleweed et gstreamer-plugins-libav (packman)

Répondre #13
@chalu : Bonjour,

Alors j'ai comparé ta liste de paquets gstreamer et la mienne. Par rapport à toi il me manque :

gstreamer-plugin-pipewire
gstreamer-plugins-farstream       | GStreamer Plug-Ins for videoconferencing
gstreamer-plugins-vaapi           | Gstreamer VA-API plugins
libgupnp-dlna-backend-gstreamer   | GUPnP-DLNA GStreamer meta-extraction backend

Je crois bien que gstreamer-plugins-farstream et libgupnp-dlna-backend-gstreamer ne me sont pas utiles. J'ai donc installé les deux autres, gstreamer-plugin-pipewire et gstreamer-plugins-vaapi.

Ma vidéo en .mp4 pour laquelle je n'avais que le son était bien encodée en H264. J'ai à présent le son et l'image. À mon avis c'est le paquet gstreamer-plugins-vaapi qui me manquait.

Pour mes vidéos .avi encodées en XviD, VLC en flatpak les lit sans problème. Par contre la version VLC des dépôts, même en ayant installé libxvidcore4 de Packman, n'y parvient pas.

Oui, XviD est un vieux truc. C'était la réponse libre au DivX. Et ça date pour moi aussi d'une époque où je rippais des DVDs (j'ai oublié tout ça). Ces vidéos, ces films encodés en XviD, ne me sont pas essentiels. Ils pourraient un jour ou l'autre rejoindre la corbeille.

Maintenant nous savons que ces vidéos encodés en XviD nécessitent d'installer VLC en flatpak si on veut se contenter du nouveau dépôt pour les codecs. As-tu essayé libxvidcore4 de Packman qui ne fonctionne pas chez moi?

Si tu comptes modifier le guide multimédia en faveur du nouveau dépôt pour les codecs, penses-tu émettre quelques réserves en rapport avec ces vieux encodages?

Je vais conserver cette configuration sur mon portable et garder Packman pour le moment sur mon fixe pour les codecs, le temps de digérer tout ça et de voir ce qui me convient le mieux.

Re : Maj Tumbleweed et gstreamer-plugins-libav (packman)

Répondre #14
Je conseillerais volontiers à un débutant de ne pas utiliser le dépôt Packman, mais celui qui fournit le codec h264 et s’ils ont besoin de logiciels ou codecs multimédia qui n’existent pas dans les dépôts de chercher dans les flatpaks. Pour moi le problème essentiel était l’impossibilité de lire une vidéo avec Firefox sur certains sites de replay tv ou sur les sites de streaming payants comme Disney plus ou autre. Ajouter ce dépôt et installer les codecs qu’il contient règle le problème. En plus, je crois que la procédure est intégrée dans YaST comme pour les dépôts Nvidia ou Packman sur les nouvelles ISOS.
En listant les derniers soucis avecPackman sur les discussions Telegram, j’ai l’impression que c’est comme pour Debian avec le dépôt multimédia, à ne pas utiliser quand on débute, c’est vraiment le meilleur moyen d’avoir des soucis et de se décourager d’utiliser openSUSE.
Perso, j’ai obs-studio en flatpak, pdfarranger, Geogebra, Telegram… Et je ne regrette pas ce choix d’avoir supprimé Packman.
J’ai même découvert distrobox qui permet l’installation dans un conteneur d’une distribution, comme Debian par exemple et l’installation sur celle-ci d’un logiciel. C’est ce que j’ai fait pour avoir un logiciel Geophar, non empaqueté pour openSUSE. C’est un script python, mais ça me posait problème de l’exécuter directement sur ma TW à cause de versions de Python différente, y avait des bugs que je ne savais pas résoudre. Là je profite de la maintenance Debian :)