Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: GLIBC_2.27 not found (Lu 105 fois) sujet précédent - sujet suivant

GLIBC_2.27 not found

Bonjour tout le monde

Je pose cette question car je n'ait vraiment rien trouver sur le sujet alors voila mon problème : quand j’essaye de démarrer Audacity ou d'autre appli comme Kmail ou Simplescreenrecorder j'ai l'erreur suivante :

audacity: /lib64/libc.so.6: version `GLIBC_2.27' not found (required by /usr/lib64/libavformat.so.57)
audacity: /lib64/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib64/libavformat.so.57)
audacity: /lib64/libc.so.6: version `GLIBC_2.33' not found (required by /usr/lib64/libavformat.so.57)

Voila je suis sur leap 5.3 en tout cas j’espère que vous pourrez m’aider merci d'avance.

PS : Je ne mis connais pas trop sur le sujet.

Re : GLIBC_2.27 not found

Répondre #1
Bonjour et bienvenue sur le forum :)
As-tu ajouté le dépôt packman et fais ce qu'il fallait pour les codecs ?
voir https://guide-opensuse.alionet.org/codecs
en adaptant car tu utilises 15.3 et non 15.2

Re : GLIBC_2.27 not found

Répondre #2
Bonjour.

Pas sûr que les dépôts pacman existent pour la 15.3 qui est en béta.
Sinon bizarre que glic ne soit pas présent de base??
Regarde dans le gestionnaire de paquet si "glibc", "glibc-extra", "glibc-32bit" et glibc-locale sont bien installé?

Re : GLIBC_2.27 not found

Répondre #3
Bonjour.

Pas sûr que les dépôts pacman existent pour la 15.3 qui est en béta.
Sinon bizarre que glic ne soit pas présent de base??
Regarde dans le gestionnaire de paquet si "glibc", "glibc-extra", "glibc-32bit" et glibc-locale sont bien installé?
 
 

Je pense qu'il existe
https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.3/

Re : GLIBC_2.27 not found

Répondre #4
Bonjour

Oui j'ai bien ajouté les dépôt packman et les paquet glibc sont bien installer.

Re : GLIBC_2.27 not found

Répondre #5
Avec Leap 15.3 sur une machine virtuelle avec virtualbox, j'ai un paquet d'erreur mais pas de messages sur glibc
Tu fais tes mises à jour avec zypper dup ?
sudo zypper dup
que donne la commande
zypper info glibc

Re : GLIBC_2.27 not found

Répondre #6
Résulta de la commende # zypper dup (pas en entier)

Citer
Les 5 éléments suivants sont verrouillés et ne seront modifiés par aucune action :
 Installé:
  libavcodec56 libavcodec58_91 libavdevice56 libavformat56 vlc-codecs

Les 14 NOUVEAUX paquets suivants vont être installés :
  clamav-milter gstreamer-plugins-bad-lang gstreamer-plugins-ugly-lang kernel-default-5.3.18-lp152.69.1
  libbox2d2 libfdk-aac2 libhogweed6 libIexMath-2_2-23 libixion-0_16-0 libnettle8 liborcus-0_16-0 libtiger5
  openSUSE-release-ftp virtualbox-kmp-default-6.1.18_k5.3.18_lp152.69-lp152.2.18.1

Les 212 paquets suivants vont être mis à jour :
  autoyast2-installation clamav cups cups-client cups-config curl dracut ffmpeg-3 filesystem flatpak fwupd
  fwupd-lang gdb git-core glib2-devel glib2-lang glib2-tools grub2 grub2-i386-pc grub2-snapper-plugin
  grub2-systemd-sleep-plugin gzip hwdata irqbalance kernel-firmware kglobalaccel5 kio kio-core kio-lang
  libass9 libavcodec57 libavdevice57 libavfilter6 libavresample3 libavutil55 libcap2 libcap2-32bit
  libchromaprint1 libclamav9 libcups2 libcups2-32bit libcupscgi1 libcupsimage2 libcupsmime1 libcupsppdc1
  libcurl4 libcurl4-32bit libdca0 libefivar1 libflatpak0 libfreshclam2 libfwupd2 libgio-2_0-0
  libgio-2_0-0-32bit libglib-2_0-0 libglib-2_0-0-32bit libgmodule-2_0-0 libgmodule-2_0-0-32bit libgnutls30
  libgnutls30-32bit libgobject-2_0-0 libgobject-2_0-0-32bit libgstadaptivedemux-1_0-0 libgstbadaudio-1_0-0
  libgstbasecamerabinsrc-1_0-0 libgstcodecs-1_0-0 libgstisoff-1_0-0 libgstmpegts-1_0-0 libgstsctp-1_0-0
  libgsturidownloader-1_0-0 libgstvulkan-1_0-0 libgstvulkan-1_0-0-32bit libgstvulkan-1_0-0-32bit-debuginfo
  libgstvulkan-1_0-0-debuginfo libgstwayland-1_0-0 libgstwebrtc-1_0-0 libgthread-2_0-0 libicu65_1-ledata
  libicu-suse65_1 libIlmImf-2_2-23 libKF5GlobalAccel5 libKF5GlobalAccel5-lang libKF5GlobalAccelPrivate5
  libldap-2_4-2 libldap-2_4-2-32bit libldap-data libldb2 libldb2-32bit libmariadb3 libmediainfo0 libminizip1
  libmwaw-0_3-3 libnghttp2-14 libnghttp2-14-32bit libnumbertext-1_0-0 libnumbertext-data libopencore-amrnb0
  libopencore-amrnb0-32bit libopencore-amrwb0 libopencore-amrwb0-32bit libopenssl1_0_0 libopenssl1_0_0-steam
  libopenssl1_0_0-steam-32bit libopenssl1_1 libopenssl1_1-32bit libostree libostree-1-1 libpostproc54 libpq5
  libpython2_7-1_0 libreoffice libreoffice-base libreoffice-calc libreoffice-draw
  libreoffice-filters-optional libreoffice-icon-themes libreoffice-impress libreoffice-l10n-en
  libreoffice-l10n-fr libreoffice-mailmerge libreoffice-math libreoffice-pyuno libreoffice-qt5
  libreoffice-writer librtmp1 libruby2_5-2_5 libstaroffice-0_0-0 libswresample2 libswscale4 libsystemd0
  libsystemd0-32bit libudev1 libudev1-32bit libudev-devel libunwind libunwind-32bit libvo-amrwbenc0
  libwps-0_4-4 libX11-6 libX11-6-32bit libX11-data libX11-devel libX11-xcb1 libX11-xcb1-32bit libz1
  libz1-32bit libzen0 libzstd1 libzstd1-32bit mediainfo MozillaFirefox MozillaFirefox-translations-common
  obs-studio OpenIPMI openldap2-client openssl-1_1 psmisc psmisc-lang python2-six python3-cryptography
  python3-ldb python3-PyJWT python3-PyYAML python3-requests python3-six python-base ruby2.5 ruby2.5-stdlib
  sane-backends sane-backends-32bit sane-backends-autoconfig systemd systemd-32bit systemd-bash-completion
  systemd-presets-common-SUSE systemd-sysvinit system-user-flatpak tar tar-lang tar-rmt teamviewer-suse
  typelib-1_0-Flatpak-1_0 typelib-1_0-GstVulkan-1_0 typelib-1_0-GstVulkanWayland-1_0
  typelib-1_0-GstVulkanXCB-1_0 ucode-amd udev vim vim-data vim-data-common vlc-vdpau wpa_supplicant
  xdg-desktop-portal xdg-desktop-portal-gtk xdg-desktop-portal-gtk-lang xdg-desktop-portal-lang xdm xen-libs
  xorg-x11-server xorg-x11-server-extra xorg-x11-server-sdk xorg-x11-server-source xorg-x11-server-wayland
  yast2-bootloader yast2-installation yast2-iscsi-client yast2-network yast2-security yast2-storage-ng
  youtube-dl youtube-dl-bash-completion zlib-devel

Les 6 paquets suivants vont être remis à une version inférieure :
  avidemux gstreamer-plugins-bad gstreamer-plugins-libav gstreamer-plugins-ugly
  gstreamer-plugins-ugly-orig-addon libavformat57

Les 13 paquets suivants vont changer de fournisseur :
  avidemux         obs://build.opensuse.org/home:happenpappen -> http://packman.links2linux.de
  ffmpeg-3         openSUSE -> http://packman.links2linux.de
  libavcodec57     openSUSE -> http://packman.links2linux.de
  libavdevice57    openSUSE -> http://packman.links2linux.de
  libavfilter6     openSUSE -> http://packman.links2linux.de
  libavresample3   openSUSE -> http://packman.links2linux.de
  libavutil55      openSUSE -> http://packman.links2linux.de
  libchromaprint1  openSUSE -> obs://build.opensuse.org/home:ecsos
  libpostproc54    openSUSE -> http://packman.links2linux.de
  libswresample2   openSUSE -> http://packman.links2linux.de
  libswscale4      openSUSE -> http://packman.links2linux.de
  obs-studio       obs://build.opensuse.org/home:ecsos -> http://packman.links2linux.de
  vlc-vdpau        openSUSE -> http://packman.links2linux.de

Les 5 paquets suivants requièrent un redémarrage du système :
  kernel-default-5.3.18-lp152.69.1 kernel-firmware libopenssl1_0_0 libopenssl1_1 systemd

212 paquets à mettre à jour, 6 à rétrograder, 14 nouveaux, 13 à changer de fournisseur.
Taille de téléchargement totale : 573,2 MiB. Déjà en cache : 0 B. Après l'opération, 417,9 MiB d'espace
disque supplémentaire sera utilisé.

    Note : Redémarrage du système requis.
Continuer ? [o/n/v/...? affiche toutes les options] (o):

Re : GLIBC_2.27 not found

Répondre #7
le dépôt packman existe mais ce qu'il contient n'est pas arrivé au niveau des dépôts officiels d'où les downgrade.

 

Re : GLIBC_2.27 not found

Répondre #8
Resultat de la commende # zypper info glibc

Citer
# zypper info glibc
Récupération des métadonnées du dépôt 'Virtualization (openSUSE_Leap_15.2)' ...[fait]
Construction du cache du dépôt 'Virtualization (openSUSE_Leap_15.2)' ...[fait]
Chargement des données du dépôt...
Lecture des paquets installés...


Informations sur paquet glibc :
-------------------------------
Dépôt                     : openSUSE:Leap:15.2:Update
Nom                       : glibc
Version                   : 2.26-lp152.26.6.1
Architecture              : x86_64
Fabricant                 : openSUSE
Taille une fois installé  : 6,7 MiB
Installé                  : Oui
État                      : à jour
Paquet source             : glibc-2.26-lp152.26.6.1.src
Résumé                    : Standard Shared Libraries (from the GNU C Library)
Description               :
    The GNU C Library provides the most important standard libraries used
    by nearly all programs: the standard C library, the standard math
    library, and the POSIX thread library. A system is not functional
    without these libraries.

Re : GLIBC_2.27 not found

Répondre #9
Mon problème a été régler avec la commende # zypper dup merci pour vautre aide.

Je croyais que les mise a jour se ferai toute seule enfin merci pour tout.