Aller au contenu principal
Sujet: Gros problème Webcam qui plante au bout de 10 minutes (Lu 2019 fois) sujet précédent - sujet suivant

Re : Gros problème Webcam qui plante au bout de 10 minutes

Répondre #15
Bonjour

Je n'ai utilisé Discord qu'une fois mais pendant au moins 1 heure et sans problème. J'étais sous Manjaro mais je ne suis pas convaincu que changer de distribution soit la raison.
Au-delà du noyau, comment as-tu installé Discord sur openSUSE (d'ailleurs tumbleweed ou leap ?) ?
Ce que j'ai en tête : j'avais installé Discord en utilisant Flatpak. Si tel n'est pas ton cas, cela peut valoir le coup de voir si une installation par Flatpak résoud ton problème.

A+

Re : Gros problème Webcam qui plante au bout de 10 minutes

Répondre #16
Bonjour

Je n'ai utilisé Discord qu'une fois mais pendant au moins 1 heure et sans problème. J'étais sous Manjaro mais je ne suis pas convaincu que changer de distribution soit la raison.
Au-delà du noyau, comment as-tu installé Discord sur openSUSE (d'ailleurs tumbleweed ou leap ?) ?
Ce que j'ai en tête : j'avais installé Discord en utilisant Flatpak. Si tel n'est pas ton cas, cela peut valoir le coup de voir si une installation par Flatpak résoud ton problème.

A+
Bonjour,

J'ai utilisé le RPM / Repository pour OpenSUSE Leap. Jamais essayé la partie Flatpak (que je ne connais pas). Mais je vais tenter.

Re : Gros problème Webcam qui plante au bout de 10 minutes

Répondre #17
Après que micro soit branché : Discord ou le contrôleur de son voient-ils bien le micro ? Il y a un menu pour le configurer avec Discord : il faut vérifier sa configuration.

Re : Gros problème Webcam qui plante au bout de 10 minutes

Répondre #18
Après que micro soit branché : Discord ou le contrôleur de son voient-ils bien le micro ? Il y a un menu pour le configurer avec Discord : il faut vérifier sa configuration.
Oui la caméra et le micro sont bien détectées au début, on peut même faire des tests. Mais au bout de quelques minutes le driver plante

Re : Gros problème Webcam qui plante au bout de 10 minutes

Répondre #19
Je viens d'essayer Discord sur le zBook de ma femme, même distrib (OpenSUSE 15.2 Leap), même version de Discord.

Là aucun problème, ça ne plante pas avec la caméra intégrée.

Je pense que le souci vient du type de caméra qui fait appel à un driver spécifique et qui fait planter. Mais c'est étrange que Zoom ne cause aucun problème, peut-être que Discord et Zoom gèrent la caméra différemment.

Re : Gros problème Webcam qui plante au bout de 10 minutes

Répondre #20
Bonjour

Est-ce que c'est sur un PC tour que tu as le problème ?
Si oui, est-ce que la webcam est connectée en façade ou à l'arrière, directement sur la carte mère ?
Si la webcam est branchée en façade, as-tu essayé en la branchant directement sur la carte mère à l'arrière (et sur un port USB2 de préférence) ?

A+

Re : Gros problème Webcam qui plante au bout de 10 minutes

Répondre #21
Bonjour

Est-ce que c'est sur un PC tour que tu as le problème ?
Si oui, est-ce que la webcam est connectée en façade ou à l'arrière, directement sur la carte mère ?
Si la webcam est branchée en façade, as-tu essayé en la branchant directement sur la carte mère à l'arrière (et sur un port USB2 de préférence) ?

A+
C'est bien branché à un PC tour, à l'arrière

Re : Gros problème Webcam qui plante au bout de 10 minutes

Répondre #22
Ok. Tu as essayé la version flatpak ?
Vu que flatpak rend « transparent » l’environnement, peut-être que la gestion de la webcam sera différente.

A+

Re : Gros problème Webcam qui plante au bout de 10 minutes

Répondre #23
Oui la caméra et le micro sont bien détectées au début, on peut même faire des tests. Mais au bout de quelques minutes le driver plante
Quel driver plante ?? il faut vérifier la bonne configuration de la carte son alors.

Re : Gros problème Webcam qui plante au bout de 10 minutes

Répondre #24
Oui la caméra et le micro sont bien détectées au début, on peut même faire des tests. Mais au bout de quelques minutes le driver plante
Quel driver plante ?? il faut vérifier la bonne configuration de la carte son alors.

Le son ne plante pas car on entend encore les gens parler dans Discord. C'est bel et bien le module USB qui gère la Caméra qui plante. Je vais essayer FlatPak

Re : Gros problème Webcam qui plante au bout de 10 minutes

Répondre #25
[Le son ne plante pas car on entend encore les gens parler dans Discord. C'est bel et bien le module USB qui gère la Caméra qui plante. Je vais essayer FlatPak
Et maintenant c'est le module USB de la caméra qui bugge ?! Vous semblez pas savoir ce que vous cherchez à résoudre !!

Re : Gros problème Webcam qui plante au bout de 10 minutes

Répondre #26
Hello ;=)


Pour résumer et bien identifier le matériel concerné :

> System:    Host: linux-815u Kernel: 5.3.18-lp152.47-default x86_64 bits: 64
> Desktop: KDE Plasma 5.18.5
>            Distro: openSUSE Leap 15.2


> [19563.481204] usb 1-7: Product: HD Web Camera
> [19563.481207] usb 1-7: Manufacturer: Ingenic Semiconductor CO., LTD.
> [19563.481210] usb 1-7: SerialNumber: Ucamera001
> [19563.488049] uvcvideo: Found UVC 1.00 device HD Web Camera (18d1:0002)


J'ai contacté la liste linux-usb@vger.kernel.org trouvée ici https://bugzilla.kernel.org/show_bug.cgi?id=203763

La réponse de  Greg Kroah-Hartman (un des développeurs du noyau) explique ceci  :

- Il faudrait en principe mettre à jour le noyau pour une version plus récente, de la série 5.9.

- Si cela ne suffit pas les développeurs linux-media sont les plus susceptibles d'aider ; via les messages de log.

Ca se situe ici sauf erreur https://github.com/hvaibhav
je l'ai contacté pour voir si c'est le bon canal (en cas de soucis non résolu par un noyau récent)

Par curiosité : quel est le noyau le plus récent que tu ais essayé ?

Re : Gros problème Webcam qui plante au bout de 10 minutes

Répondre #27
Bonjour

Si tu veux tester un autre noyau sous Leap, voici un post de @chalu qui peut t'aider.

Tu peux aussi essayer d'utiliser un noyau plus récent sur Leap si on regarde cette page https://en.opensuse.org/Main:Dell_Precision_5530_Setup
en utilisant un dépôt pour les noyaux et firmwares
 sudo zypper ar --refresh https://download.opensuse.org/repositories/Kernel:/stable/standard/ kernel_stable
sudo zypper in -f kernel-default
sudo zypper in -f kernel-firmware

A+

Re : Gros problème Webcam qui plante au bout de 10 minutes

Répondre #28
Bonjour

Si tu veux tester un autre noyau sous Leap, voici un post de @chalu qui peut t'aider.

Tu peux aussi essayer d'utiliser un noyau plus récent sur Leap si on regarde cette page https://en.opensuse.org/Main:Dell_Precision_5530_Setup
en utilisant un dépôt pour les noyaux et firmwares
 sudo zypper ar --refresh https://download.opensuse.org/repositories/Kernel:/stable/standard/ kernel_stable
sudo zypper in -f kernel-default
sudo zypper in -f kernel-firmware

A+
Merci pour l'information !

Je n'ai jamais essayé avec la 5.9 mais je vais tenter ce week-end.

Re : Gros problème Webcam qui plante au bout de 10 minutes

Répondre #29
Hello ;=)


Pour résumer et bien identifier le matériel concerné :

> System:    Host: linux-815u Kernel: 5.3.18-lp152.47-default x86_64 bits: 64
> Desktop: KDE Plasma 5.18.5
>            Distro: openSUSE Leap 15.2


> [19563.481204] usb 1-7: Product: HD Web Camera
> [19563.481207] usb 1-7: Manufacturer: Ingenic Semiconductor CO., LTD.
> [19563.481210] usb 1-7: SerialNumber: Ucamera001
> [19563.488049] uvcvideo: Found UVC 1.00 device HD Web Camera (18d1:0002)


J'ai contacté la liste linux-usb@vger.kernel.org trouvée ici https://bugzilla.kernel.org/show_bug.cgi?id=203763

La réponse de  Greg Kroah-Hartman (un des développeurs du noyau) explique ceci  :

- Il faudrait en principe mettre à jour le noyau pour une version plus récente, de la série 5.9.

- Si cela ne suffit pas les développeurs linux-media sont les plus susceptibles d'aider ; via les messages de log.

Ca se situe ici sauf erreur https://github.com/hvaibhav
je l'ai contacté pour voir si c'est le bon canal (en cas de soucis non résolu par un noyau récent)

Par curiosité : quel est le noyau le plus récent que tu ais essayé ?


Merci pour le coup de main. Je vais envoyer  ce que j'ai à la liste et on verra bien. En tout cas, pas énormément de logs quand le pilote crash, juste le message qui boucle mentionné ci-dessus.

J'ai acheté une autre Webcam, plus moderne et plus sophistiquée, et je vais voir si ça fait le même problème.