Aller au contenu principal
Sujet: Prestashop ne fonctionne pas bien sous Leap 15.2 (Lu 388 fois) sujet précédent - sujet suivant

Prestashop ne fonctionne pas bien sous Leap 15.2

Prestashop fonctionne parfaitement sous Debian ;
Informations sur votre serveur Linux #1 SMP Debian 5.4.19-1~bpo10+1 (2020-03-09) x86_64
Version du logiciel serveur : Apache/2.4.25 (Debian)
Version de PHP : 7.1.33
Limite de mémoire : 128M
Temps maximal d'exécution : 60
Taille max. pour envoi de fichiers : 64M

Par contre il buggue sous Leap 15.2 : les menus et autres js ne fonctionnent pas correctement

Linux #1 SMP Thu Oct 15 16:05:25 UTC 2020 (41f7396) x86_64
Version du logiciel serveur :Apache
Version de PHP :7.4.6
Limite de mémoire :128M
Temps maximal d'exécution :30
Taille max. pour envoi de fichiers :16M

Avez-vous une idée sur ce qu'il manque à apache pour bien fonctionner?
cordialement

Re : Prestashop ne fonctionne pas bien sous Leap 15.2

Répondre #1
Pour avoir plus d'info.

Editer le fichier /etc/php7/apache2/php.ini
changer la valeur error_reporting en  E_ALL (ligne 465 normalement) et relancer le serveur.
Il devrait y avoir des messages d'erreur d'afficher.

Re : Prestashop ne fonctionne pas bien sous Leap 15.2

Répondre #2
Voici l'exemple d'erreurs que je rencontre ;
[Thu Oct 29 16:59:16.388237 2020] [php7:warn] [pid 1844] [client 127.0.0.1:60414] PHP Warning:  "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /srv/www/htdocs/shop/vendor/doctrine/orm/lib/Doctrine/ORM/UnitOfWork.php on line 2636

ou encore

[Thu Oct 29 17:09:50.157633 2020] [php7:notice] [pid 2802] [client 127.0.0.1:32784] PHP Notice:  Trying to access array offset on value of type null in /srv/www/htdocs/shop/vendor/doctrine/annotations/lib/Doctrine/Common/Annotations/DocParser.php on line 995, referer: http://haku.ddns.net/shop/admin***/index.php/sell/catalog/products/20?_token=txl3NKpRbqLE9xXZ4UgNH8KtGjhK_iBmtf3bTJBpy6k

pourtant les champs ne sont pas null, c'est ce genre de bug qui m'énerve le plus.
Merci pour votre réponse


Re : Prestashop ne fonctionne pas bien sous Leap 15.2

Répondre #4
Ce sont des nouveaux messages/warnongs de PHP 7.4
.
PrestaShop n'a pas l'air de supporter la version 7.4

Re : Prestashop ne fonctionne pas bien sous Leap 15.2

Répondre #5
pour sa fait quelle temps, que j'utilise docker, avec docker-compose pour mes développement web.

perso, une foi, que j'ai testé, j'ai l'ai adopté. sa offre pas mal d'avantage :
* choix de la version des logiciels (il possible d'avoir plusieurs version d'un même logiciel sur un projet)
* facilité d'installation, (ajouté une base mariadb sur un projet ce fait moins de 5 minute)
* portabilité de la configuration des serveurs (c'est juste quelle fichier)

david

Re : Prestashop ne fonctionne pas bien sous Leap 15.2

Répondre #6
Salut,

Tu as quelle version de Prestashop ?
Seule la dernière version fonctionne sur php 7.4

https://stackoverflow.com/questions/58831791/errorexception-trying-to-access-array-offset-on-value-of-type-null
https://devdocs.prestashop.com/1.7/basics/installation/system-requirements/


à plus,
oh!rocks
j'utilise la dernière version