Aller au contenu principal
Sujet: Pas de sortie son sur HDMI (Lu 3090 fois) sujet précédent - sujet suivant

Pas de sortie son sur HDMI

Bonjour,

Sur mon pc portable secondaire ASUS UX310ua, je n'ai pas de sortie audio sur le HDMI.
Concrètement dans les sources de sorties lorsque je branche le HDMI, je n'ai jamais de possibilité de choisir HDMI pour l'audio, pour l'image aucun soucis.

J'ai fais le tests sur 2 écrans différents, un écran de pc avec baffles sur lequel je sais que le tout fonctionne pour un autre pc portable (pc portable amd en signature), et sur une tv sur laquelle ça fonctionnait aussi parfaitement avec un autre pc portable.
La sortie image elle est bien ok, mais impossible d'envoyer le flux audio.

Le pc portable en question est un ASUS UX310ua à base de i5-6200U donc uniquement un gpu intel HD 520.

Auriez vous une idée de ce qui pourrait manquer pour pouvoir récupérer la sortie audio HDMI?


Niveau audio voici ce qui est détecté:
Citer
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
   Subsystem: ASUSTeK Computer Inc. Device 1280
   Flags: bus master, fast devsel, latency 32, IRQ 131
   Memory at dfb28000 (64-bit, non-prefetchable) [size=16K]
   Memory at dfb00000 (64-bit, non-prefetchable) [size=64K]
   Capabilities: <access denied>
   Kernel driver in use: snd_hda_intel
   Kernel modules: snd_hda_intel, snd_soc_skl

sudo lspci | grep -i audio
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)

aplay -l
**** Liste des périphériques matériels PLAYBACK ****
carte 0 : PCH [HDA Intel PCH], périphérique 0 : Generic Analog [Generic Analog]
  Sous-périphériques : 0/1
  Sous-périphérique #0 : subdevice #0
carte 0 : PCH [HDA Intel PCH], périphérique 3 : HDMI 0 [HDMI 0]
  Sous-périphériques : 1/1
  Sous-périphérique #0 : subdevice #0
carte 0 : PCH [HDA Intel PCH], périphérique 7 : HDMI 1 [HDMI 1]
  Sous-périphériques : 1/1
  Sous-périphérique #0 : subdevice #0
carte 0 : PCH [HDA Intel PCH], périphérique 8 : HDMI 2 [HDMI 2]
  Sous-périphériques : 1/1
  Sous-périphérique #0 : subdevice #0
carte 0 : PCH [HDA Intel PCH], périphérique 9 : HDMI 3 [HDMI 3]
  Sous-périphériques : 1/1
  Sous-périphérique #0 : subdevice #0
carte 0 : PCH [HDA Intel PCH], périphérique 10 : HDMI 4 [HDMI 4]
  Sous-périphériques : 1/1
  Sous-périphérique #0 : subdevice #0

AU boot je vois bien:
Citer
19.713376] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1f.3/sound/card0/input13
[   19.713658] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input16
[   19.715407] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input17
[   19.715524] input: HDA Intel PCH HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input18
[   19.715619] input: HDA Intel PCH HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input19
[   19.715692] input: HDA Intel PCH HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input20

Mais en pratique que ça soit pavucontrol ou l'écran de kde, je n'ai pas de hdmi dans les choix pour l'audio.

Re : Pas de sortie son sur HDMI

Répondre #1
Bon, via pavu contrôle en changeant de profil, j'arrive à envoyer tout sur le port HDMI.
Par défaut c'est sur "Duplex stéréo analogique".
Si je switch sur:
Sortie digital HDMI2 + entrée stéréo analogique" j'ai bien le son sur le port hdmi.

En gros j'arrive à avoir:
* Son sur le port HDMI mais du coup la prise casque n'est plus détectée.
* Ou son sur le port casque mais du coup rien sur le port HDMI, les deux en même temps ne semblent pas possible.
Au moins je peux envoyer du son sur le HDMI maintenant à défaut de pouvoir croiser les deux.

Re : Pas de sortie son sur HDMI

Répondre #2
Bonjour,
Chez moi, je peux par exemple faire sortir le son sur hdmi ou alors sur les haut-parleurs du portable mais pas les deux en même temps.
ça me semble donc normal.

Re : Pas de sortie son sur HDMI

Répondre #3
Bonjour,

En fait pour expliquer le contexte,
Dans le panneau kde ou autre je n'ai pas la possibilité de switcher pour le hdmi.
La seule possibilité pour le faire c'est via pavucontrol et c'est général pour tous les programmes.


Sur mon deuxième pc portable (à base d'igp amd VEGA) c'est beaucoup plus simple, au niveau du son de l'os je peux switcher hdmi ou casque/haut parleur, ET pour chaque programme je peux choisir de partir sur la prise hdmi ou le casque. Donc je peux avoir le son général sur le HDMI mais garder teams dans le casque.

Surement une limite logiciel de cette vielle config. 

Re : Pas de sortie son sur HDMI

Répondre #4
Tu veux dire que quand tu cliques sur l'icone du haut-parleur dans la barre de menu de KDE, tu n'as pas la possibilité de selectionner la sortie hdmi ?

Re : Pas de sortie son sur HDMI

Répondre #5
Voilà exactement, sur ce pc portable là je n'ai aucun choix de possible dans ce menu, je peux juste régler le volume du micro ou de la sortie audio.
La seule solution pour arriver à avoir la sortie hdmi, c'est via pavucontrol en changeant dans les options avancées et dans ce cas ben tout est basculé sur le hdmi.

Sur mon autre pc portable (ou sur mon pc fixe) j'ai comme toi, plusieurs sorties que je peux directement choisir, ce qui fait qu'il en est de même pour chaque programme donc teams peut partir sur le casque même si par défaut tu as mis hdmi.

Re : Pas de sortie son sur HDMI

Répondre #6
Et ce portable sans choix, il est avec quel système ?

Re : Pas de sortie son sur HDMI

Répondre #7
Leap 15.4 KDE à jour comme les autres :D

Re : Pas de sortie son sur HDMI

Répondre #8
à jour mais avec des paquets en moins ? Je ne vois pas trop ce qui pourrait manquer, ou un incompatibilité ?
sur TW, je n'ai pas pavucontrol

Re : Pas de sortie son sur HDMI

Répondre #9
Installation identique et tout est bien à jour.
Pavucontrol je l'ai rajouté justement parce que j'avais croisé des gens évoquant la seule possibilité de le gérer avec.

Je n'ai pas essayé en livecd sur d'autre distrib voir ce que ça donne. Je pense que c'est un bug du pilote intel dans cette version.

Re : Pas de sortie son sur HDMI

Répondre #10
Coucou les gens,

Je vais peut être raconter une connerie plus grosse que moi mais ça serait pas le même genre de problème que celui décrit dans le thread ci-dessous :
https://www.alionet.org/index.php?topic=1425.0
D'accord, c'etait à propos d'une enceinte BT mais il manquait bien un "morceau" de pilote ou un truc dans le genre non ?
Amicalement
Philippe

Re : Pas de sortie son sur HDMI

Répondre #11
:hello:

Il ne s'agit pas de bluetooth donc pas sûr que ça soit le même pb.
Dans la procédure conseillé c'est remplacer pulse audio par pipewire, ce n'est pas anodin.

Je pourrais tester mais je ne sais pas si le rollback est facilement réalisable.
Après vu que c'est un pc portable d'appoint que je prends en déplacement quand j'ai un risque de vol au final le switch via pavucontrol reste supportable.