Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: Experience installation 15.5 pas réussie (Lu 4572 fois) sujet précédent - sujet suivant

Experience installation 15.5 pas réussie

Bonjour,

Après avoir, au cours de ces années, installé les diverses versions d'opensuse jusqu'à la 15.4 que j'utilise couramment, j'ai voulu tenter la 15.5
L'installation de base a fonctionné avec l'image réseau  openSUSE-Leap-15.5-NET-x86_64-Build491.1-Media.iso bootée sur une clé USB
Le système a démarré avec une résolution graphique basique.
Jusqu'ici, tout allait bien.

Vu que j'ai une carte NVIDIA GTX1660, je me suis dit que j'allais faire comme d'habitude :
Aller sur le site : https://opensuse-community.org/
pour récupérer les pilotes Nvidia, ainsi que tout le nécessaire pour le multimedia.

Je vais sur le site en question, je clique sur "1 Click Install" des Geforce 700 series, et là, ô surprise, j'obtiens le message :
Pas d'infos pour la distribution en question.
Alors que openSUSE Leap 15.5 est bien listée sur la page.
Je télécharge la cible du "1 Click Install", qui est le fichier nvidia_G06.ymp, et l'ouvre avec l'éditeur Kate.
Et là je vois que 15.5 n'est pas listée. Ce qui explique le message d'erreur.

C'est la première fois que je tombe sur une page de opensuse-community.org avec ce genre de lien invalide, pas à jour pour une nouvelle distribution.

J'ajoute donc le serveur https://download.nvidia.com/opensuse/leap/15.5/ manuellement en tant que dépôt.
Cela me permet d'installer les pilotes NVIDIA, et de pouvoir gérer ainsi les écrans multiples.

Toujours sur https://opensuse-community.org/, je teste les KDE Codecs : même problème, le 15.5 n'est pas listée dans le fichier codecs-kde.ymp

En attendant d'installer les codecs, j'installe quelques paquetages de la 15.5, et à l'un des redémarrages du système, l'interface graphique ne démarre plus.
La commande startx donne un message indiquant "impossible de se connecter à un serveur X"
Un autre message dit que /usr/bin/Xorg n'a pas le setuid. Je corrige cela, mais le premier message est toujours là.
Je désinstalle et résintalle les pilotes nvidia : rien à faire.

Quelqu'un saurait comment relancer l'interface graphique sans tout réinstaller ?

Avez-vous connu ces bizarreries de opensuse-community.org ?

A+

Wallace

Re : Experience installation 15.5 pas réussie

Répondre #1
Il y avait différentes façons de passer à Leap 15.5, soit comme je le fais en modifiant l'url des dépôts avec Yast->Dépôts de logiciels, soit avec le dvd qui inclut presque tous les paquets dont k3b, Vlc etc... On peut aussi, toujours avec Yast ajouter des dépôts complémentaires comme Packman ou Nvidia.
Vous pouvez démarrer la version de secours de Leap et lancer Yast en root.  L'interface est en curl (je crois que c'est comme ça que ça s'appelle). A partir de là regardez si les paquets X11 sont installés. Pour votre carte graphique, c'est le pilote gfx-G05 qui doit être installé, d'ailleurs il est plus que possible que le problème vient de là.

Re : Experience installation 15.5 pas réussie

Répondre #2
Bonjour,
Merci pour les tuyaux.
J'ai regardé si j'avais un paquet X11  : aucun n'est installé.
Mais j'ai regardé dans la 15.4 fonctionnelle : il n'y en a aucun X11 non plus d'installé.
Et le pilote nvidia est le G06.
J'ai alors enlevé les paquets G06 pour installer les G05 : toujours pas de graphique.
Je remets les G06 : rien.
Pour être sûr d'avoir les bons pilotes, je passe par la page https://www.nvidia.com/Download/Find.aspx?lang=en-us et je choisi ma carte GTX1660
J'obtiens le fichier :
NVIDIA-Linux-x86_64-535.104.05.run
Je désinstalle à nouveau les paquets G06 installés précédemment, et je lance ce .run.
Je n'ai pas de message d'erreur, mais toujours pas d'interface graphique.

Du coup, vu que j'en étais au début, je réinstalle la 15.5 entièrement.
En ajoutant le dépôt Nvidia, Yast installe les pilotes G06, et ça fonctionne.
Remarque : pas d'installation de pilotes X11.

Les découvertes ne sont pas terminés.
Via Packman, installation VLC : OK
Installation Kaffeine : OK
Installation de vlc-codecs : OK
Carte HVR-5525 : OK avec les firmwares additionnels.
Avec Kaffeine, je lance la rechercher des canaux TNT sur la HVR : toutes les chaines sont trouvées.
Sauf que ...
Kaffeine affiche le nom de la chaîne, mais pas d'image.
L'enregistrement d'une chaîne donne bien un fichier vidéo. Lisible par Avidemux.
Mais si on veut le lire avec VLC, ça donne :
"Codec non pris en charge : VLC ne peut pas décoder le format "eac3"(A/52 B Audio (aka E-AC3))"
Il semble donc que vlc-codecs ne couvre pas tous les codecs pour la 15.5.

Avez-vous réussi à visualiser la TNT française avec Kaffeine en Leap15.5 ?

A+

wallace

Re : Experience installation 15.5 pas réussie

Répondre #3
"Codec non pris en charge : VLC ne peut pas décoder le format "eac3"(A/52 B Audio (aka E-AC3))"
Vous pouvez convertir le son dans un autre format avec Vlc ou Avidemux. Ce qui est bizarre, c'est que Vlc est censé lire le format A/52 ou E-AC3 puisque celui-ci figure dans les formats de conversion audio.

Re : Experience installation 15.5 pas réussie

Répondre #4
Il faut peut-être aussi installer a52dec.

Re : Experience installation 15.5 pas réussie

Répondre #5
Bonjour,

J'ai installé a52dec : ça ne marche pas mieux !

Et je suis d'accord sur le mot "bizarre" : la 15.5 est bizarre. J'ai installé toutes les précédentes Leap 15 lorsqu'elles ont sorties, et je n'ai jamais eu ces problèmes.

A+

wallace

Re : Experience installation 15.5 pas réussie

Répondre #6
Bonjour,

Je viens de trouver la solution. Il s'agit de l'origine de VLC.

La version installée est 3.0.18-bp155.1.12-x86-64 de SUSE:SLE-15:Update fournisseur openSUSE
Yast ne propose pas mieux pour le  fournisseur openSUSE. Cette version date de novembre 2022
Notons que le paquetage vlc-codecs est 3.0.18-150500.2.pm.7-x86_54

Yast propose le fournisseur packman.links2linux.de, pour la version 3.0.18-150500.2.pm.7-x86_54 (bizarrement, c'est la même version que vlc-codecs)

Si je le choisis, Yast propose de changer également 4 paquetages.

Une fois ces changements validés, sont installés :
vlc                 version     3.0.18-150500.2.pm.7-x86_54
vlc-codecs   version     3.0.18-150500.2.pm.7-x86_54
Les deux paquetages datent tous les deux de novembre 2022

Et Kaffeine fonctionne.

Il faut donc utiliser le VLC de Packman, et pas celui de openSUSE.

A+

wallace