Aller au contenu principal
Messages récents
21
Général / Re : SQUID + FIREWALL + YAST
Dernier message par ricobolo -
Bonjour Denebe,

Heu oui il est bien dans  /etc/firewalld/services/. Et en fait squid fonctionne bien. Mais c'est pas très normal quand même.

zypper se firewall renvoi ceci :

edport:~ # sudo zypper se firewall
Loading repository data...
Reading installed packages...

S  | Name                       | Summary                                                             | Type
---+----------------------------+---------------------------------------------------------------------+-----------
   | SuSEfirewall2              | Stateful Packet Filter Using iptables and netfilter                 | package
   | SuSEfirewall2-fail2ban     | Files for integrating fail2ban into SuSEfirewall2 via systemd       | package
i+ | firewall-applet            | Firewall panel applet                                               | package
i+ | firewall-config            | Firewall configuration application                                  | package
i  | firewall-macros            | FirewallD RPM macros                                                | package
i+ | firewalld                  | A firewall daemon with D-Bus interface providing a dynamic firewall | package
i  | firewalld-lang             | Translations for package firewalld                                  | package
   | firewalld-rpcbind-helper   | Tool for static port assignment of NFSv3, ypserv, ypbind services   | package
i  | python3-firewall           | Python3 bindings for FirewallD                                      | package
   | susefirewall2-to-firewalld | Basic SuSEfirewall2 to FirewallD migration script                   | package
   | susefirewall2-to-firewalld | Basic SuSEfirewall2 to FirewallD migration script                   | srcpackage
i  | yast2-firewall             | YaST2 - Firewall Configuration                                      | package
   | yast2-firewall             | YaST2 - Firewall Configuration                                      | srcpackage
22
Internet, réseaux et serveurs / Re : YAST FIREWALL QUE 2 ONGLETS ?
Dernier message par ricobolo -
Salut denebe,

Voilà  la commande sudo zypper se firewall

edport:~ # sudo zypper se firewall
Loading repository data...
Reading installed packages...

S  | Name                       | Summary                                                             | Type
---+----------------------------+---------------------------------------------------------------------+-----------
   | SuSEfirewall2              | Stateful Packet Filter Using iptables and netfilter                 | package
   | SuSEfirewall2-fail2ban     | Files for integrating fail2ban into SuSEfirewall2 via systemd       | package
i+ | firewall-applet            | Firewall panel applet                                               | package
i+ | firewall-config            | Firewall configuration application                                  | package
i  | firewall-macros            | FirewallD RPM macros                                                | package
i+ | firewalld                  | A firewall daemon with D-Bus interface providing a dynamic firewall | package
i  | firewalld-lang             | Translations for package firewalld                                  | package
   | firewalld-rpcbind-helper   | Tool for static port assignment of NFSv3, ypserv, ypbind services   | package
i  | python3-firewall           | Python3 bindings for FirewallD                                      | package
   | susefirewall2-to-firewalld | Basic SuSEfirewall2 to FirewallD migration script                   | package
   | susefirewall2-to-firewalld | Basic SuSEfirewall2 to FirewallD migration script                   | srcpackage
i  | yast2-firewall             | YaST2 - Firewall Configuration                                      | package
   | yast2-firewall             | YaST2 - Firewall Configuration                                      | srcpackage

Mais je n'ai pas désinstallé SuSEfirewall2.

Pour l'essentiel j'ai à peu près résolu mes problèmes. J'ai fail2ban qui bloque des ip externes sur samba, mais on ne les voit pas les règles de blocage dans firewalld ( ce qui est étonnant ou qui m’échappe ) mais on les voit bien dans iptables -L.
J'ai réussi a installer munin, et je ne savais pas qu'il avait un graphe pour fail2ban. Grace au graphe je vois un peu mieux ce qui se passe, et j'ai quand même banni 2300 IP en 24heures rien que sur samba.
Mais comme je n'ai qu'une carte réseau je n'arrive pas a bloquer les ports 445/139/138 d'un point de vue du routeur (ip publique) sans bloquer le local, je crois que ce n'est pas possible. C'est a dire que si j'autorise pas le service samba sur mon interface reseau, j'ai plus de samba local. J'ai essayé de désactiver le partage freebox, mais c'est pareil, on atteint ma machine en 445 depuis l’extérieur.
Et d'ailleurs les ports ne sont a ma connaissance pas redirigés  depuis le routeur (freebox) sur cette machine,  seul les ports 80,443 sont redirigés, c'est pour ça que je ne comprends pas que ces ip atteignent ma machine. J'ai même fait une redirection factice depuis le routeur, c'est à dire vers une ip qui n'existe pas, mais j'ai toujours autant de visites indésirables... Mais bon heureusement fail2ban + le firewalld plus la config de samba semble bien bloquer tout ce monde, sans me bloquer moi en local.
SuSEfirewall2 dans tout ça ? Il est désactivé.



24
Programmes et logiciels / Re : Logiciels installés qui ne se lancent pas !
Dernier message par Chumi -
Bonsoir,
J'ai installé geogebra 6 depuis leur site web et il ne se lançait pas ..
Je viens d'installer geogebra (communautaire) avec https://software.opensuse.org/package/geogebra
ça marche mais geogebra est en version 5 (au lieu de 6)..
c'est mieux que rien !

Bonsoir,

Il y a peut-être encore mieux que mieux que rien : La version Linux Portable (GeoGebra Classic 6).

Je l'ai trouvée sur le site de l'application : https://wiki.geogebra.org/en/Reference:GeoGebra_Installation#Other_GeoGebra_Classic_6_versions

Je l'ai testée vite fait, enfin... je me suis contenté de la lancer et elle s'est ouverte immédiatement.

À voir de ton côté si elle répond à tes attentes.

Edit : Je viens de lire plus haut, Chalu m'a précédé à propos de cette version portable. Bref, ça vaut le coup d'essayer à mon avis.
28
Général / Re : Lancement d'applications
Dernier message par Chumi -
J ai mal configuré les depots  ?

Bonsoir,

Pas dit, et je ne le crois pas, que tu sois le responsable.

openSUSE Leap 15.3 a amorcé un changement dans la construction de la distribution, principalement au niveau de son rapport à SUSE Linux Enterprise. Je te passe les détails qui m'échappent mais cela a occasionné des surprises lors de la mise à niveau de Leap 15.2 vers 15.3 et des désagréments lors d'une nouvelle installation, notamment en ce qui concerne les dépôts.

Discover d'abord  :(  mais tu comprendras assez rapidement que c'est négligeable, si ce n'est pas déjà le cas. Et maintenant les dépôts, là oui je reconnais que ce n'est pas très engageant. Mais je pense sincèrement que ça vaut le coup d'insister car Leap ne nécessite ni une grande attention pour se maintenir en bon état de fonctionnement, ni des connaissances approfondies.

Une commande à passer pour lister tes dépôts (il faudra certainement faire du ménage après) :

sudo zypper lr -u

Copie le résultat ici (tu as le symbole # dans l'éditeur du forum pour insérer du code).
29
Programmes et logiciels / Re : Logiciels installés qui ne se lancent pas !
Dernier message par chalu -
Je ne vais pas pouvoir beaucoup t'aider. Je n'ai jamais eu de carte nvidia sous linux et encore moins les configurations avec deux cartes.
Je ne sais pas trop comment sont géré sous openSUSE les deux cartes.
Certains ici utilisent prime pour pouvoir sélectionner entre la carte intel et la nvidia mais il semble y avoir des bugs dernièrement.

à ta place, j'essaierais de supprimer les pilotes propriétaires nvidia pour voir si ça peut fonctionner avec le pilote libre nouveau.
si ça marche pas, je réinstallerais les pilotes nvidia et essaierais prime ...
Désolée de ne pouvoir être plus précise mais plusieurs membres ont ce type de configuration et pourront te donner des pistes sur la gestion de ces deux cartes.

Edit : sinon pour Geogebra que j'utilise aussi. J'utilise la version Linux portable en zip :
https://wiki.geogebra.org/en/Reference:GeoGebra_Installation#GeoGebra_Classic_6
J'ai décompressé l'archive dans le dossier bin de mon répertoire personnel.
L'application fonctionne sans problème mais je n'ai pas de nvidia.
30
Matériel / Re : DISQUE DUR EXTERNE
Dernier message par sobkowiak -
Citer
Je sais bien pour la distribution, mais je me suis aperçu que certains DD externes ne sont pas compatible avec Linux.
D'où l'intérêt DD classique + boîtier externe.
J'ai pour ma part un SSD Crucial de 2 To pour Linux et 2 DD externes avec la configuration que j'ai indiquée et il n'y a pas de souci.