Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: scanner HP ne scanne plus depuis mise à jour Tumbleweed (Lu 300 fois) sujet précédent - sujet suivant

scanner HP ne scanne plus depuis mise à jour Tumbleweed

Il n'y a pas si longtemps que ça (1 ou 2 semaines) mon scanner réseau HP fonctionnait encore sans problème avec Xsane.
Comme cela arrive parfois après des mises à jour, lorsque je lance Xsane il me demande d'installer un plugin... mais cette fois-ci l'installation foire avec un message peu éloquent, du genre "ça marche pas".

Je sais que lorsqu'il télécharge ce plugin il le range dans /home/[user]/.hplip.
En l'occurrence : hplip-3.20.11-plugin.run
En faisant une copie du plugin avant que celui-ci ne soit supprimé, j'arrive à le lancer à la main et à avoir un message d'erreur plus clair, bien que très suprenant : "Error importing HPLIP modules.  Is HPLIP installed?"

Ben oui il est installé, hplip... en version 3.20.11-2.5 d'après Yast. Ca semble cohérent.

J'ai essayé de télécharger la dernière version depuis le site de HP, mais il m'informe que tumbleweed n'est pas supporté.

Une idée ?
J'espère que ça n'est pas encore une histoire de dépendance implicite, j'ai déjà bien ramé sous Leap 15.2...

Re : scanner HP ne scanne plus depuis mise à jour Tumbleweed

Répondre #1
Bon alors, problème résolu, mais, comment dire... pas vraiment de manière académique !

1/ récupérer le plugin
Quand on lance Xsane, l'installeur HP propose gentiment de mettre à jour automatiquement le plugin. Puis il le télécharge dans /home/[user]/.hplip, tente de l'installer, échoue, et finalement le supprime. Entre la fin du téléchargement et la suppression se passent quelques courtes secondes pendant lesquelles on peut faire une copie du fichier.
Pas trivial, il m'a fallu plusieurs tentatives

2/ installation
On relance Xsane, l'installeur HP demande à nouveau l'installation du plugin
Sélectionner alors l'option "installer un plugin local (avancé)" plutôt que "télécharger automatiquement (recommandé)"
Là... attention
- si on sélectionne le plugin dans son emplacement initial (/home/[user]/.hplip/hplip-3.20.11-plugin.run), il supprime le fichier et se plaint "fichier non trouvé" (gonflé, quand même  >:( )
- si on renomme le fichier, le bouton "next" est désactivé, pas possible d'aller plus loin  :(
Il faut donc copier le fichier dans un autre répertoire, mais sans le renommer ( :o !?!)
Là on peut cliquer sur "Next" et on voit l'install du plugin commencer. Ca se termine par 2 messages contradictoires indiquant et l'échec et le succès de l'opération. Allez comprendre.
Mais le plugin est installé et le scanner scanne

Décidément, plus ça va et plus hplip regorge de surprises, pas toujours agréables !