Aller au contenu principal
Sujet: Mise à jour Tumbleweed : conflit tlp et tuned (Lu 1001 fois) sujet précédent - sujet suivant

Mise à jour Tumbleweed : conflit tlp et tuned

Bonjour,
Deux paquets tlp et tuned sont installés sur le système via des patterns et une mise à jour les met en conflit, car on ne peut pas utiliser les deux en même temps. J'ai choisi de désinstaller tuned, le fil correspondant sur le forum anglais indiquant que tlp était mieux pour un portable et tuned pour un serveur (https://forums.opensuse.org/t/tlp-conflict-with-tuned/175203/13)
zypper dup 
Chargement des données du dépôt...
Lecture des paquets installés...
Avertissement : Vous êtes sur le point d'exécuter une mise à niveau de distribution avec tous les dépôts activés. Assurez-vous que
 ces dépôts sont compatibles avant de continuer. Reportez-vous à 'man zypper' pour obtenir plus d'informations sur cette commande.
Calcul de la mise à niveau de la distribution...
 
Problème : 1: l'élément tlp-1.6.1-2.1.noarch à installer est en conflit avec 'tuned' fourni par l'élément tuned-2.22.1.2+git.86ac9
77-3.1.noarch installé
 Solution 1 : désinstallation de tlp-1.6.1-1.3.noarch
 Solution 2 : désinstallation de tuned-2.22.1.2+git.86ac977-3.1.noarch
 Solution 3 : conserver l'élément tlp-1.6.1-1.3.noarch obsolète
 
Choisir une des solutions ci-dessus en tapant son numéro ou bien annuler en tapant 'a' [1/2/3/a/d/?] (a): 2
 

Re : Mise à jour Tumbleweed : conflit tlp et tuned

Répondre #1
Merci de l'info, j'avais pas encore regardé les MAJ du jour ...

Re : Mise à jour Tumbleweed : conflit tlp et tuned

Répondre #2
Bonsoir,

J'ai été confronté à cette interrogation ce matin sur mon ThinkPad, je n'avais pas le temps alors de m'y consacrer mais ça m'a rappelé cette ancienne discussion :

https://www.alionet.org/index.php?topic=1342.msg11062#msg11062

TLP est particulièrement recommandé pour les ThinkPads postérieurs à 2011 dès lors que le kernel est supérieur à la version 5.17 (mon cas donc). Voir cette partie de la documentation de TLP en relation avec openSUSE :

https://linrunner.de/tlp/installation/opensuse.html

Je me suis renseigné vite fait sur TuneD et il semblerait en effet que son utilisation soit plus destinée aux serveurs :

https://tuned-project.org/
https://fr.linux-console.net/?p=268

J'ai donc moi aussi conservé tlp et désinstallé tuned.

Après redémarrage de l'ordinateur il n'est pas inutile d'aller vérifier que le service tlp est toujours actif (il l'était chez moi), soit dans Yast, soit en ligne de commande :
sudo systemctl status tlp.service 

S'il ne l'est plus :
sudo systemctl enable --now tlp.service

On peut aussi redémarrer le service avec Yast.

Re : Mise à jour Tumbleweed : conflit tlp et tuned

Répondre #3
Hello ;=)

A combien estimez vous la fréquence de ce genre de problématique ?

Quelles sont les anomalies typiques ?

Est ce que vous bloquez les paquets pour qu'ils ne reviennent plus ?
C'est respecté ?

Merci ;=)

Re : Mise à jour Tumbleweed : conflit tlp et tuned

Répondre #4
Il n’y a pas à bloquer les paquets. Le paquet tlp étant installé et mis en conflit avec tuned, il ne sera pas proposé à l’installation comme paquet recommandé d’un pattern lors d’une prochaine maj.
Si j’ai bien suivi, les deux ne peuvent pas être activés en même temps. Il y a d’ailleurs une interrogation sur le fait que jusqu’à présent les deux paquets étaient installés en paquets recommandés de deux patterns qui doivent être assez basique et installé chez beaucoup d’utilisateurs.
Le choix de la mise en conflit des paquets, c’est pour forcer à choisir l’un ou l’autre.
Je pense que ça arrive une à deux fois par an, c’est lié aussi ,je crois, à l’évolution des méthodes pour gérer telles ou telles choses.