Aller au contenu principal

Messages

Cette espace vous permet de voir toutes les Messages réalisées par ce membre. Vous ne pouvez voir que les Messages réalisées dans les espaces auxquels vous avez accès.

Messages - nigihayami

2
Internet, réseaux et serveurs / Re : Prestashop ne fonctionne pas bien sous Leap 15.2
Voici l'exemple d'erreurs que je rencontre ;
[Thu Oct 29 16:59:16.388237 2020] [php7:warn] [pid 1844] [client 127.0.0.1:60414] PHP Warning:  "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /srv/www/htdocs/shop/vendor/doctrine/orm/lib/Doctrine/ORM/UnitOfWork.php on line 2636

ou encore

[Thu Oct 29 17:09:50.157633 2020] [php7:notice] [pid 2802] [client 127.0.0.1:32784] PHP Notice:  Trying to access array offset on value of type null in /srv/www/htdocs/shop/vendor/doctrine/annotations/lib/Doctrine/Common/Annotations/DocParser.php on line 995, referer: http://haku.ddns.net/shop/admin***/index.php/sell/catalog/products/20?_token=txl3NKpRbqLE9xXZ4UgNH8KtGjhK_iBmtf3bTJBpy6k

pourtant les champs ne sont pas null, c'est ce genre de bug qui m'énerve le plus.
Merci pour votre réponse
3
Internet, réseaux et serveurs / Prestashop ne fonctionne pas bien sous Leap 15.2
Prestashop fonctionne parfaitement sous Debian ;
Informations sur votre serveur Linux #1 SMP Debian 5.4.19-1~bpo10+1 (2020-03-09) x86_64
Version du logiciel serveur : Apache/2.4.25 (Debian)
Version de PHP : 7.1.33
Limite de mémoire : 128M
Temps maximal d'exécution : 60
Taille max. pour envoi de fichiers : 64M

Par contre il buggue sous Leap 15.2 : les menus et autres js ne fonctionnent pas correctement

Linux #1 SMP Thu Oct 15 16:05:25 UTC 2020 (41f7396) x86_64
Version du logiciel serveur :Apache
Version de PHP :7.4.6
Limite de mémoire :128M
Temps maximal d'exécution :30
Taille max. pour envoi de fichiers :16M

Avez-vous une idée sur ce qu'il manque à apache pour bien fonctionner?
cordialement
8
Internet, réseaux et serveurs / Apache ne sert pas les images
Après investigation il apparait qu'Apache reçoit bien les demandes "GET" mais ne donne pas les images et css. La configuration est au point niveau DNS. De plus il ne prend pas en charge les fonctions rewriting, ce qui m'ennuie beaucoup car je l'ai activé dans les modules. Quelqu'un a une idée?
10
Internet, réseaux et serveurs / Re : Probleme d'acces avec un nom de domaine dynamique
Salut chalu, je suis finalement repassé à Leap 15.1-1 car les versions de php n'étaient pas à jours, je ne veux pas cumuler les bugs.
En effet c'est un double bug sur wordpress :
1/ les permaliens ne sont pas reconnus par le serveur, que ce soit sous Leap 15.0-1 ou 15.1-1
2/ sous Leap 15.1-1 les thèmes, images et css ne sont pas donnés à distance, il n'y a qu'en localhost qu'on peut travailler.
3/ je continue de chercher.
11
Internet, réseaux et serveurs / Re : Probleme d'acces avec un nom de domaine dynamique
Mon avis est que Leap 15.1-1 est bugué, mon problème n'existe pas sous Leap 15.0-1, donc tant que c'est du développement sous wordpress, je peux me permettre d'avoir une version non mise à jour, ce qui compte c'est que je puisse travailler sereinement sous wordpress sans être ennuyé par des défauts du système d'exploitation. Après je récupère mes données et je les réinjecte sous OVH par exemple.
15
Internet, réseaux et serveurs / Re : Probleme d'acces avec un nom de domaine dynamique
access_log ;

78.115.12.35 - - [14/Feb/2020:12:01:23 +0100] "GET /wp-content/themes/coeur/screenshot.png HTTP/1.1" 200 198844 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0"

78.115.12.35 - - [14/Feb/2020:12:10:07 +0100] "GET /wp-content/themes/coeur/screenshot.png HTTP/1.1" 200 198844 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0"
error_log ;
[Fri Feb 14 12:01:17.689367 2020] [mpm_prefork:notice] [pid 27024] AH00163: Apache/2.4.33 (Linux/SUSE) PHP/7.2.5 configured -- resuming normal operations
[Fri Feb 14 12:01:17.689640 2020] [core:notice] [pid 27024] AH00094: Command line: '/usr/sbin/httpd-prefork -D SYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -D SYSTEMD -D FOREGROUND'

on voit bien qu'il a eu le get mais il ne note aucune erreur.