Aller au contenu principal
Sujet: Dual-boot mageia Leap 15.3 impossible problème EFI (Lu 570 fois) sujet précédent - sujet suivant - Sujet provenant de Leap 15.3 Beta : Impo...

Dual-boot mageia Leap 15.3 impossible problème EFI

Bonjour,
Citation de: Mimosas
Bon je jette l'éponge après une matinée d'embrouille, ne voulant pas perdre ce qui est acquis.
Je ne suis pas arrivé à installer le dual-boot: mga/Suse.
Suse15.3 activant systématiquement : l'amorçage sécurisé et il est alors impossible de lancer mga.
J'ai réparé mga, et c'est Suse qui ne démarre plus.
Apparemment un problème entre /boot/efi imposé par Suse et le /boot/EFI imposé par Mga ..

Que l'on désactive le secure boot via le bios ne change rien, j'ai même réinstallé Suse et décoché amorçage sécurise à l’installation je me suis retrouvé dans la même situation !
J'y suis depuis tôt ce matin et j'en ai franchement marre ! J'ai essayé d'autres distros qui elles sont compatibles .
Je vais bien voir ...

Mais bon comme le PC sert à toute la famille je reste sur ce qui marche : MGA que j'ai dû réinstaller...
je ne pense pas (sauf miracle) que la version stable de juin (de Leap 15.3) change quelque chose puisque c'est le principe d'installation.
Voir ce tuto MicroLinux
Ou il est dit :
>>une partition /boot/efi de 500 Mo, formatée en vfat et étiquetée efi
comparé à cette page : Installation de Mageia ou il est dit
>>le chargeur d'amorçage UEFI de 300 Mo, monté sur /boot/EFI.

Je m'use les yeux à fouiller le web, c'est dingue ça : suis-je le seul à utiliser deux OS Linux via UEFI ?

Parce que je n'ai rien trouvé concernant cette particularité d'un /boot/efi (en minuscules) et d'un /boot/EFI (majuscules).
Comment faites-vous au moment de l'installation dans ce cas ?
Y a-t-il un moyen de contournement ?
Je sais que je pourrais installer en GSM mais c'est reculer pour mieux sauter.
Voyez cela comme une bouteille à la mer ...

Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #1
Bonjour Mimosas :)
J'ai scindé ton dernier message depuis ce fil de discussion car le problème évoqué n'est plus le même.
Je ne peux pas t'aider car je n'ai pas d'expérience de dual-boot UEFI, le PC acheté dans ma signature était sans système préinstallé.
Cependant, il était "préparé" pour une installation de windows ::)  Je n'ai pas eu de souci particulier pour installer Tumbleweed, j'ai laissé l'installateur faire pour le partitionnement en acceptant le "recommandé". J'ai aussi laissé coché dans le BIOS les options fast-boot et secure-boot.
Je te donne des commandes et leur retours sur mon PC sous Tumbleweed.
Ce serait bien que tu donnes les mêmes commandes depuis mageia pour que l'on ait quelque chose de précis et clair sur le forum concernant l'installation de mageia.

sudo fdisk -l
Disque /dev/nvme0n1 : 476,94 GiB, 512110190592 octets, 1000215216 secteurs 
Modèle de disque : Micron_2210_MTFDHBA512QFD               
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : gpt
Identifiant de disque : DEC5CCD3-9A50-44B9-BD46-366236C32A7E
 
Périphérique       Début        Fin  Secteurs Taille Type
/dev/nvme0n1p1      2048     718847    716800   350M Données de base Microsoft
/dev/nvme0n1p2    718848    1767423   1048576   512M Système EFI
/dev/nvme0n1p3   1767424  996020223 994252800 474,1G Système de fichiers Linux
/dev/nvme0n1p4 996020224 1000215182   4194959     2G Partition d'échange Linux
 
En utilisateur normal, pour voir les partitions montées :
df -h
Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur
devtmpfs           3,8G    4,0K  3,8G   1% /dev
tmpfs              3,8G       0  3,8G   0% /dev/shm
tmpfs              1,5G    2,1M  1,5G   1% /run
tmpfs              4,0M       0  4,0M   0% /sys/fs/cgroup
/dev/nvme0n1p3     475G     27G  447G   6% /
/dev/nvme0n1p3     475G     27G  447G   6% /.snapshots
/dev/nvme0n1p3     475G     27G  447G   6% /boot/grub2/i386-pc
/dev/nvme0n1p3     475G     27G  447G   6% /usr/local
/dev/nvme0n1p3     475G     27G  447G   6% /srv
/dev/nvme0n1p3     475G     27G  447G   6% /opt
/dev/nvme0n1p3     475G     27G  447G   6% /var
/dev/nvme0n1p3     475G     27G  447G   6% /root
/dev/nvme0n1p3     475G     27G  447G   6% /boot/grub2/x86_64-efi
/dev/nvme0n1p3     475G     27G  447G   6% /home
tmpfs              3,8G       0  3,8G   0% /tmp
/dev/nvme0n1p2     511M    7,7M  504M   2% /boot/efi
tmpfs              765M     48K  765M   1% /run/user/1000
Edit : ajout de cette commande
sudo parted -l
Modèle : Micron_2210_MTFDHBA512QFD (nvme)
Disque /dev/nvme0n1 : 512GB
Taille des secteurs (logiques/physiques) : 512B/512B
Table de partitions : gpt
Drapeaux de disque :

Numéro  Début   Fin    Taille  Système de fichiers  Nom                   Drapeaux
 1      1049kB  368MB  367MB   fat32                Basic data partition  msftdata
 2      368MB   905MB  537MB   fat32                                      démarrage, esp
 3      905MB   510GB  509GB   btrfs
 4      510GB   512GB  2148MB  linux-swap(v1)                             swap

Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #2
Bonjour,

Oui tu as raison, je me suis laissé embarqué ! J'étais déçu et dépité, sans compter la pression de la «family» .
Bien pour répondre a ton interrogation de matériel , voici mon sdnvme :
Disque /dev/nvme0n1 : 232,89 GiB, 250059350016 octets, 488397168 secteurs
Modèle de disque : Samsung SSD 970 EVO Plus 250GB         
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : gpt
Identifiant de disque : CFDE50DA-9BC4-459E-B836-EC8EA39AC39D

Périphérique       Début       Fin  Secteurs Taille Type
/dev/nvme0n1p1      2048   1228833   1226786   599M Système EFI
/dev/nvme0n1p2   1230848  54276095  53045248  25,3G Système de fichiers Linux
/dev/nvme0n1p4  54276096 243019775 188743680    90G Système de fichiers Linux
/dev/nvme0n1p5 243019776 295448575  52428800    25G Système de fichiers Linux
/dev/nvme0n1p6 295448576 488396799 192948224    92G Système de fichiers Linux

Je pense que les autres disques n'ont pas d'importance étant utilisés pour le stockage sauf un "swap", sans conséquence.

Les partitions montées:
➜ Pour info :/OMA correspond à OpenMandriva (Dual-Boot) et /Perso : contient les extension du /home de chacun
Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur
devtmpfs            32G       0   32G   0% /dev
tmpfs               32G     95M   32G   1% /dev/shm
tmpfs               32G    1,3M   32G   1% /run
/dev/nvme0n1p5      25G    9,4G   14G  41% /
tmpfs               32G    8,0K   32G   1% /tmp
/dev/nvme0n1p1     598M    436K  598M   1% /boot/EFI
/dev/nvme0n1p2      25G    5,8G   18G  25% /OMA
/dev/nvme0n1p6      91G     12G   79G  13% /home
/dev/sda2          632G     85G  516G  15% /StockMobil
/dev/nvme0n1p4      89G     50M   84G   1% /OMA/home
/dev/sda1          284G     61G  209G  23% /Perso
/dev/sdb1          909G     41G  822G   5% /Sauvegardes
tmpfs              6,3G     92K  6,3G   1% /run/user/1008
On remarque par comparaison que tu as un : /dev/nvme0n1p2     511M    7,7M  504M   2% /boot/efi et deux /boot/grub2/.
Quand j'ai :  /dev/nvme0n1p1     598M    436K  598M   1% /boot/EFI sans aucun grub .
Et, pour être plus précis Suse réclame un format boot/efi en fat 32, ce que ne reconnait pas Mageia qui impose 0xEF.
Bon je dis ça que je n'ai pas essayé toutes les combinaisons, c'est déjà assez "chaud" de formater et installer un systeme sur un ordi que l'on découvre. Inutile de tenter le diable par des manipes du genre «pour voir»
 ;)
Je ne lâche pas l'affaire il y a surement une explication ou, et ça je me doute: Un truc que je n'ai pas ou mal fait.

Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #3
Salut,

Je n'ai pas tout suivi donc je vais peut-être dire une bêtise mais as-tu essayé de monter le boot/efi d'openSUSE sur celui de Mageïa lors de l'installation puis de réactualiser le grub Mageïa pour la prise en compte d'openSUSE ?

(Il me semble difficile d'avoir deux partitions de boot/efi sur le même disque mais peut-être que c'est faisable ?)


à plus,
oh!rocks

Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #4
Bonjour,

Je comprends, mais le souci vient du fait que «à 'l’installation» chaque distribution (Suse/Mageia) impose un format différent et donc efface le précédent ➜ du moins à ce que j'ai compris et je n'ai pas trouvé comment prendre la main sur ce sujet.

Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #5
Bonjour

Le fait que la partition /boot/efi soit de type 0xEF, c'est normal. C'est le type de partition pour l'amorçage EFI.
Par contre ce qui m'étonne beaucoup c'est qu'il n'y ai que 436kio d'utilisé sur cette partition. Elle est vide c'est bizarre !!
 Qu'est qu'il y a dedans??

Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #6
Bonjour,

Je comprends, mais le souci vient du fait que «à 'l’installation» chaque distribution (Suse/Mageia) impose un format différent et donc efface le précédent ➜ du moins à ce que j'ai compris et je n'ai pas trouvé comment prendre la main sur ce sujet.
Bonjour,
Si tu fais un montage "manuel", tu peux ne pas formater le boot/uefi.
C'est ce que j'ai fais quand j'ai installé opensuse avec windows.
Mais il est possible que cela implique de faire les partitions à la main.
PErso c'est ce que je fais toujours par sécurité.

Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #7
Bonjour,
Par contre ce qui m'étonne beaucoup c'est qu'il n'y ai que 436kio d'utilisé sur cette partition. Elle est vide c'est bizarre !!
 Qu'est qu'il y a dedans??
Alors pour te répondre :
Il y a 4 dossiers dans /EFI respectivement
Un dossier BOOT de 143 360Kio contenant : bootx64.efi
Un dossier mageia de 147 456kio contenant : grubx64.efi
Un dossier openmandriva de 4 096kio : vide
Un dossier OpenMandriva_Lx_[GRUB] de 143 360Kio contenant : grubx64.efi
Donc non il n'est pas vide et, doit correspondre à ce qui est installé il me semble.

Si tu fais un montage "manuel", tu peux ne pas formater le boot/uefi.
C'est ce que j'ai fait quand j'ai installé opensuse avec windows.
Mais il est possible que cela implique de faire les partitions à la main.
;) Itou! Je fais mon partitionnement en manuel ceci afin d'éviter des surprises =  (vécues ! merci les sauvegardes)
Seulement là; que j'installe Suse en premier sans formater, ou Mageia en premier je n'ai systématiquement que la dernière distribution qui se lance même si l'autre s'affiche dans le grub, elle ne démarre pas.
C'est pourquoi j'ai essayé avec Openmandriva et là que ce soit en première installe ou en seconde avec ou sans formatage je peux choisir la distribution qui se lance normalement.
D'où mon interrogation : Qu'est ce qui fait que dans le dual OpenSuse Mageia cela ne fonctionne pas ?
J' avoue que peut-être suis-je passé à côté de quelque chose, ou quelque chose s'est mal passé (🨄 ou les deux).
➠ Après plusieurs tentatives je commence à avoir peur de foutre tout en vrac !!
Avant que l'on me le demande voici mes réglages BIOS :
Une photo vaut mieux qu'un long discourt.

Bonne journée !



Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #8
Bonjour.

Dans le bios dans mon cas avec un dual boot windows/openSuse, dans le bios j'ai:
UEFI WIndows
UEFI Opensuse.
UEFI Opensuse Secureboot

Quand je boote sur UEFI Opensuse "tout cours", j'ai bien le grub qui s'affiche avec le choix des os dont windows.
PS j'ai aussi  une carte mère msi, je regarderais ce que j'ai mis dans le bios ce soir.

EDIT; ah ton pb c'est dualboot openSuse/mageai.
SI j'ai le temps je testerais en vm ce cas précis.




Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #9
Re bonjour,
 ::)  Rhhoooo j'ai pas de Windows depuis 98SE/Millenium ....
 :D  ;)
Ma CM MSI étant récente (B550 bios à jour du 26/01/2021)  comme je l'ai dit : Leap 15.2 ne "passe" pas car elle ne reconnait pas le matériel  , je ne saurais dire si c'est la CM ou que sais-je mais  :15.2 plante.
Partant de là Leap 15.3 s'installe mais quid d'une bonne intégration ?...?

Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #10
J'ai une msi X470 + un ryzen 2600, et openSuse 15.2 passe sans soucis.
Comme évoqué sur l'autre sujet, ce qui coince plus avec la 15.2 ça doit surement être ton gpu nvidia.

Pour openSuse 15.3 on est encore en beta, donc j'avoue que pour le coup je ne saurais dire, tout n'est surement pas fonctionnel au niveau du grub.
Par exemple moi sur mon pc portable de test récent, la 15.3 ne me listait pas le périphérique wifi durant l'installation, alors qu'une fois installé c'était ok.

En l'état je ne saurais quoi te dire, tant que c'est une version "béta" c'est à installer pour test, mais pas vraiment pour un usage de tous les jours.  SI j'ai le temps je testerais en vm le dualboot OpenSuse 15.3/MAgeia mais pas sûr que je puisse reproduire ton utilisation précise vu que ça sera forcément en vm.

Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #11
Oui mais non, on comprend bien que l'installe se fera... j'ai essayé via Virtualbox sur MGA.
Mais en dur ??  Nada !!
- Maintenant "SI" les tests ne peuvent s’effectuer qu'en virtuel , ou est le test ?? = aucun intérêt. (mon avis) .
Je n'installe pas 15.3 pour tests mais seulement parce que je ne peux pas faire mieux.
Mais, je reste confiant.

Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #12
C'est peut-être le btrfs d'openSUSE qui pose un problème de reconnaissance pour Mageïa ?

J'ai eu ce problème avec un double boot Debian/openSUSE. Le grub de Debian ne reconnaissait par openSUSE en btrfs (car c'est la racine que cherche grub, pas le boot qui lui sera fourni par la racine). J'ai donc inversé l'insatallation. D'abord Debian, puis openSUSE en automatique. Qui ne reconnaissait pas Debian tout de suite. Une fois openSUSE installée -> YaST -> Chargeur d'amorçage -> options avancées -> cocher reconnaitre un autre système -> redémarrer.


à plus,
oh!rocks

Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #13
Pas faux.
Il est vrais que perso je suis toujours en EXT4 tout le temps, et qu'en plus je sépare toujours le /boot puisque le reste est toujours dans des conteneur LVM chiffrés.

Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #14
 ;)  Ouais, mais non !
Je reste ostensiblement en ext4.
Et, j'ajoute : /boot est séparé ! J'pige pas !
 parted -lm
Drapeaux de disque : 

Numéro  Début   Fin     Taille  Type     Système de fichiers  Drapeaux
 1      1049kB  992GB   992GB   primary  ext4
 2      992GB   1000GB  8389MB  primary  linux-swap(v1)


Modèle : Samsung SSD 970 EVO Plus 250GB (nvme)
Disque /dev/nvme0n1 : 250GB
Taille des secteurs (logiques/physiques) : 512B/512B
Table de partitions : gpt
Drapeaux de disque :

Numéro  Début   Fin     Taille  Système de fichiers  Nom  Drapeaux
 1      1049kB  629MB   628MB   fat32                     démarrage, esp
 2      630MB   27,8GB  27,2GB  ext4                      caché, legacy_boot
 4      27,8GB  124GB   96,6GB  ext4
 5      124GB   151GB   26,8GB  ext4
 6      151GB   250GB   98,8GB  ext4
Je dois faire quelque chose qui m'échâââapppppppe !