Aller au contenu principal
Sujet: Depot php7 inexistant (Lu 263 fois) sujet précédent - sujet suivant

Depot php7 inexistant

Bonjour,
La mise à jour m'indique que lesmises a jour php7 ont disparu :
ttps://download.opensuse.org/repositories/server:/php:/extensions:/php7/openSUSE_Leap_15.2/
Effectivement, quand on visite le lien, c'est plein de vide.
Je suppose que le but est un passage à php8..
sauf que je ne trouve pas l'url pour mettre le nouveau depot a jour.
Ce qui au passage me genere cet avertissement
Les 24 mises à jour de paquets suivantes ne seront PAS installées :
  gstreamer-plugins-bad-lang gstreamer-plugins-ugly-lang icewm icewm-default icewm-lang libaccounts-glib1 libappindicator1 libappindicator3-1 libgstphotography-1_0-0
  libpoppler-cpp0 libpoppler-glib8 libpoppler-qt5-1 libsox3 libvlc5 libvlccore9 poppler-tools typelib-1_0-AppIndicator3-0_1 vlc vlc-codec-gstreamer vlc-lang vlc-noX vlc-qt
  vlc-vdpau youtube-dl-bash-completion
Est ce que ces fichiers ont du php7 en dépendance ? Ce qui générerait cette impossibilité de mise à jour ?
Merci
Ooo

Re : Depot php7 inexistant

Répondre #1
Non,je crois que ces paquets sont délivrés par Packman. Ces paquets ont dû avoir une maj par le dépôt update mais tu as dû mettre une priorité plus élevée à packman. Tu ne peux faire cette maj que si tu permets le changement de fournisseur.
Quant à php7 je n'en sais pas plus que toi.

Édit: je suis allé voir sur software opensuse, il est dispo pour tumbleweed en version officiel et en en paquets communautaires et expérimentaux sous leap.

Re : Depot php7 inexistant

Répondre #2
Bonjour :)
https://download.opensuse.org/repositories/server:/php:/extensions:/php7/openSUSE_Leap_15.2/
ne fait plus parti des dépôts disponibles parmi les experimentaux pour Leap, comme l'indique jtro, quand on regarde ici :
https://software.opensuse.org/package/php7
Il y a une version officielle 7.4.6 et dans des dépôts expérimentaux 7.4.16

Pour php8, on retrouve la racine de ton dépôt dans les experimentaux :
https://software.opensuse.org/package/php8
Pour l'installation manuelle, les commandes sont :
zypper addrepo https://download.opensuse.org/repositories/server:php:extensions/openSUSE_Leap_15.2/server:php:extensions.repo
zypper refresh
zypper install php8

Re : Depot php7 inexistant

Répondre #3
Bonjour

Pour les dépôts expérimentaux php:languages:php et Apache:Modules sui proposent la version 7.4.16 fonctionnent tés bien et ce sont les mêmes paquets.

Par contre ne passe pas en php8, car cette version ne fonctionne pas sur openSUSE!!

Re : Depot php7 inexistant

Répondre #4
@Pascal Oui mais elle devrait marcher sous tumbleweed vu que c'est une version officielle ?

Re : Depot php7 inexistant

Répondre #5
@Pascal Oui mais elle devrait marcher sous tumbleweed vu que c'est une version officielle ?

Entièrement d'accord mais la version CLI fonctionne par contre en FastCGI et module apache.
J'ai pas réussi a les faire fonctionner.
Avec Yast impossible de démarrer apache et en manuel les scriptes php sont pas exécutés.

J'ai sur d'autre distribution et la ca fonctionne !!!!

Re : Depot php7 inexistant

Répondre #6
Bonjour :)
https://download.opensuse.org/repositories/server:/php:/extensions:/php7/openSUSE_Leap_15.2/
ne fait plus parti des dépôts disponibles parmi les experimentaux pour Leap, comme l'indique jtro, quand on regarde ici :
https://software.opensuse.org/package/php7
Il y a une version officielle 7.4.6 et dans des dépôts expérimentaux 7.4.16
Bonjour,
L'installation direct ne fonctionne pas. Je suppose que c'est normal... ou pas ?
L'installation en mode expert a fait le job.
Merci pour l'éclaircissement.