Aller au contenu principal
Sujet: Leap 15.3 beta - Openshot annonce des erreurs. (Lu 196 fois) sujet précédent - sujet suivant

Leap 15.3 beta - Openshot annonce des erreurs.

Bonjour,

Avec LEAP 15.3 BETA j'ai installé OpenShot 2.4.1 via YaSt software.
Sachant que OpenShot demande Blender et Inkscape je les ai donc installés également.
Mais au lancement d'Openshot, j'ai ces messages :
  • /usr/lib/python3.6/site-packages/openshot_qt/effects/icons/bars.png is not a valid image file.
  • /usr/lib/python3.6/site-packages/openshot_qt/effects/icons/colorshift.png is not a valid image file.
    • /usr/lib/python3.6/site-packages/openshot_qt/effects/icons/crop.png is not a valid image file.
    • /usr/lib/python3.6/site-packages/openshot_qt/effects/icons/shift.png is not a valid image file.
      • /usr/lib/python3.6/site-packages/openshot_qt/effects/icons/wave.png is not a valid image file.
    Puis OpenShot se lance, mais évidement  si je veux ouvrir un projet .osp; immanquablement j'ai :
    Failed to load project file /StockMobil/VIDEORAMA/norway/projet5.osp: invalid load key, '{'.

    Est ce dû au fait que c'est une version "béta" ?? Je l'ignore.
    Mais Openshot est une application assez courante et ne devrait pas poser de problème.. en principe.

    Amitiés,


Re : Leap 15.3 beta - Openshot annonce des erreurs.

Répondre #2
Là dans ce cas je ne pense pas, j'ai une autre distro d'installée (MGA) et OpenSot fonctionne correctement.
En passant sur MGA  je vois que la version proposée est la : 2.5.1 (??)  qui ne m'indique aucune erreur.
Je n'en tiens pas rigueur , je suis en beta... donc.

Re : Leap 15.3 beta - Openshot annonce des erreurs.

Répondre #3
Tu as quel bureau sur chacune des distributions ? KDE sur les deux ?
Tu fais une déclaration de bug, c'est le principe des beta ;)
Édit
Ça ressemble à ton bug
https://github.com/OpenShot/openshot-qt/issues/3123
Peux tu créer un nouveau projet, l’enregistrer , le réouvrir ?
Ce projet a été créé sous mageia avec la version 2.5.1 d’openshot ?

Re : Leap 15.3 beta - Openshot annonce des erreurs.

Répondre #4
J'ai sur les deux le bureau KDE  =  🥰 🥰 🥰  bon, ... ça c'est dit !!
Oui effectivement je n'avais pas percuté que MGA avait la version 2.5.1 quand leap15.3 propose la version 2.4.1.
Et, oui je peux "créer/enregistrer/et ouvrir" un nouveau projet (testé sur un simple film+diapo).
Cela dit openshot 2.4.1 m'indique une mise à jour vers 2.5.1, je pense que cela se fera tout simplement quand la RC sera en ligne.

L’intérêt (pour moi) étant de pouvoir travailler sur mes projets de film quel que soit le système lancé.

 - Le lien que tu donnes correspond à mon bug, seulement je pourrais y croire -SI- il se générait tout le temps sur les deux OS, je pense plus à une lecture impossible de 2.4.1 pour un fichier en 2.5.1.
Le truc c'est le pourquoi à l'ouverture (openshot 2.4.1 sur  Suse) il me signale: is not a valid image file pour  un dossier site-packages/python3.6 et des effets :  absent de base -mais présent sur MGA dans : /usr/lib/python3.8/site-packages/openshot_qt/effects/icons/
Sur Suse : /usr/lib/python3.6/site-packages/openshot_qt/effects/icons/
Je me demande si je ne vais pas faire un copier/coller ... pour voir !

Je verrais ça à tête reposée.

Re : Leap 15.3 beta - Openshot annonce des erreurs.

Répondre #5
Citer
- Le lien que tu donnes correspond à mon bug, seulement je pourrais y croire -SI- il se générait tout le temps sur les deux OS, je pense plus à une lecture impossible de 2.4.1 pour un fichier en 2.5.1.
 
 
Effectivement, je l'ai lu dans les bugs de qt des problèmes de conversion 2.2.4 ->2.5
Et l'erreur python se retrouve aussi dans les bugs.
Le problème c'est que 2.4.1 ça commence à dater sans doute et les devs ne s'occupent sans doute plus des vieilles versions.
Edit :
Si ça pose vraiment problème cette version 4.4.1 par rapport au projet fait avec la 2.5.1, il y a une appimage pour la version 2.5.1

Re : Leap 15.3 beta - Openshot annonce des erreurs.

Répondre #6
Salut,

Sur Tumbleweed, c'est openshot 2.5.1 avec Python 3.8. Tu devrais pouvoir installer les deux sur ta 15.3.


à plus,
oh!rocks

Re : Leap 15.3 beta - Openshot annonce des erreurs.

Répondre #7
Bonjour à tous !

Bon, j'ai fait le copier/coller des effets manquants = pas de soucis, je n'ai plus de messages d'erreurs.
Reste cette lecture impossible des -projets- créés avec une version supérieure ce qui me semble normal.
Pour les .appimages ; mouais , mais non: j'suis pas fan !

-- Sur Tumbleweed, c'est openshot 2.5.1 avec Python 3.8. Tu devrais pouvoir installer les deux sur ta 15.3.
  ;)  Vouais, j'avais vu !      Ce qui me fait réfléchir si je ne ferais pas mieux d'installer Tumbleweed directement.
C'est pas pour être négatif seulement les applications dont je me sers en "dual" sont; sur OpenSuse, bien souvent des versions un peu en retrait (OpenShot 2.4.1 - Kdenlive 20.04.2 - Shotcut 20.04.12 ~ etc...). Pas que ce soit inutilisable et largement suffisant si on utilise un seul Linux, mais dans mon cas, il me serait plus agréable d'avoir toutes mes applis avec la même version.

C'était ma réflexion du matin.

Re : Leap 15.3 beta - Openshot annonce des erreurs.

Répondre #8
Citation de: Mimosas
Bon, j'ai fait le copier/coller des effets manquants = pas de soucis, je n'ai plus de messages d'erreurs.
ça semble confirmer que le problème était lié à deux versions trop éloignées.
J'ai posté un message pour savoir si c'était possible d'avoir la version 2.5.1 sur Leap 15.3
On verra bien ;)
Quel est le fonctionnement de ton (ou tes) autres distributions ?
Si ce sont des rolling, effectivement tu seras peut-être mieux avec Tumbleweed.
Tumbleweed, si tu n'utilises pas les pilotes propriétaires Nvidia, ne devrait pas te poser problème.
Dans le cas contraire, ces derniers sont parfois à la traine par rapport aux mises à jour du noyau et ça donne un écran noir au redémarrage.

Re : Leap 15.3 beta - Openshot annonce des erreurs.

Répondre #9
Ou au pire utiliser le flatpak sur leap 15.3 si tu veux rester sur une base stable mais que tu veux la dernière version sable "comme une rolling release"?
https://flathub.org/apps/details/org.openshot.OpenShot

Re : Leap 15.3 beta - Openshot annonce des erreurs.

Répondre #10
Ahhh... les flatpack ....  8)
Pour dire vrai je vois pas bien l’intérêt. Je sais j'suis pénible; mais, j'aime pas plus que les appimage.
Pour moi, une distro propose des logs qui me conviennent ou pas.
Je l'installe ou pas.

Pour le moment je lorgne sur Tumbleweed .. ; ou ??  :o  je verrais ...

Re : Leap 15.3 beta - Openshot annonce des erreurs.

Répondre #11
Disons que les flatpaks ont un intérêt, justement quand il est question d'un seul logiciel qu'on veut à jour mais qu'on veut une base stable.

Idéalement il serait mieux d'avoir le logiciel en natif, mais ça peut permettre de rester sur une base stable fixed avec un logiciel totalement à jour.
Bon quand il ne s'agit pas d'un logiciel principal comme un navigateur qu'on ferme/ouvre tout le temps.
Perso j'ai 2 flatpaks sur ma leap et ça ne pose aucun problème.
J'ai remmina en flatpak pour avoir la toute dernière version pour le control RDP de mon pc pour le taf.
Et elementary/Riot pour ma connexion à mon serveur matrix. (pas dispo autrement et ça bouge trop de toute façon).


Il est évident que si tu as plusieurs logiciels à mettre à jour, il vaut mieux partir sur une tumbleweed, mais comme dit ça dépend tes priorités. Flatpak peut permettre d'éviter les défauts d'une rolling release tout en ayant certains logiciels à jour.
Si les défauts des rolling releases ne te posent pas de problème alors il est clair qu'il vaut mieux préférer tumbleweed!

Re : Leap 15.3 beta - Openshot annonce des erreurs.

Répondre #12
Bonsoir à tous.

Excusez-moi de m'immiscer dans cet échange.

Concernant Tumbleweed, les différents modules Virtualbox sont également mis a jour en temps et en heure?

J'avoue n'avoir jamais essayé Tumbleweed, peut-être un petit "stress" sur le coté Rolling.