Aller au contenu principal
Sujet: Mise à jour Zypper up et conséquences imprévues (Lu 383 fois) sujet précédent - sujet suivant

Mise à jour Zypper up et conséquences imprévues

Bonjour,

Je suis sous openSUSE 15.1, environnement KDE; et Dolphin.

Suite à une mise à jour avec zypper up, mon bureau est resté identique,    MAIS:

Dolphin ne s' ouvre pas,
K3B ne s' ouvre pas,
Yast s' ouvre, mais les divers thèmes ne s' ouvrent pas,
Le terminal super utilisateur ne s' ouvre pas,
Et le corbeille non plus.......

Quelqu'un aurait-il une solution à cette bizarrerie mal venue pour l' usage de mon ordi...

Merci.

Re : Mise à jour Zypper up et conséquences imprévues

Répondre #1
Si vous ne voulez pas passer à Leap 15.2 et que vous possédez le dvd d'installation de la 15.1 lancez une mise à niveau à partir de celui-ci. C'est tout simple, il faut juste ne pas oublier à une certaine page d'activer les dépôts.

Re : Mise à jour Zypper up et conséquences imprévues

Répondre #2
Hello ;=)

quels sont les dépôts de logiciels utilisés ?
en console :
 zypper lr -d

quelle erreur est rencontrée ?
en console :
dolphin

Re : Mise à jour Zypper up et conséquences imprévues

Répondre #3
Bonjour,
Au final, je suis passé sur 15.2 !
J' ai rencontré des problèmes pour installer mon imprimante Brother laser, mais y suis arrivé...
Maintenant, je ne peux pas lire mes fichiers vidéo avec VLC, malgré l' installation des codecs multimédias.
L' écran de lecture s' ouvre et se referme quasi instantanément.
Que faire pour résoudre ce problème ?
Merci à mes aidants.

Re : Mise à jour Zypper up et conséquences imprévues

Répondre #4
Salut,

Pour les codecs, utilses-tu ceux du dépôt Packman ?


à plus,
oh!rocks

Re : Mise à jour Zypper up et conséquences imprévues

Répondre #5
Hello ;=)

Tu peut lancer le logiciel en console pour identifier l'erreur rencontrée : exemple
$ vlc /chemin_vers_ton_fichier/fichier_video.avi

Quels dépôts as tu ? voir ci dessus  la commande

Quel fichier vidéo est-ce ? (extension )
 Certains fichiers peuvent ne pas être lus, chez moi un .mpg n'a pas été lu par vlc, mplayer l'a lu du 1er coup par contre. Il devait manquer un codec peut être.
 
Soit tu changes de lecteur vidéo selon le besoin (tu as smplayer qui est sympa) , soit tu peut aussi transcoder ton fichier au format souhaité (reconnu par ton logiciel). Pour cela, et si besoin, le choix ne manque pas : vlc, avidemux, ffmpeg, handbrake ...


il faut vérifier que tu as bien les codecs de packman voir là pour les détails :
https://en.opensuse.org/SDB:Install_Packman_codecs

Soit les commandes suivantes :
(NB : penses a contrôler tes dépôts : car t u as peut être déjà ajouté packman, ci dessous on l'ajoute, si tu l'as il faudra adapter la commande a tes dépôts sinon elle ne fonctionnera peut être pas  ; ou plus simplement si tu préfères : faire comme ci-dessous et ensuite supprimer ton 1er dépôt packman pour éviter les doublons)

Pour ajouter packman :

sudo zypper addrepo -cfp 90 https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.2/ packman

Puis

sudo zypper refresh
sudo zypper dist-upgrade --from packman --allow-downgrade --allow-vendor-change
sudo zypper install --from packman ffmpeg gstreamer-plugins-bad gstreamer-plugins-libav gstreamer-plugins-ugly libavcodec58 libavdevice58 libavfilter7 libavformat58 libavresample4 libavutil56 vlc-codecs

Re : Mise à jour Zypper up et conséquences imprévues

Répondre #6
Merci bien pour cette aide très documentée.
Donc après diverses manip. avec zypper, j' ai fait un changement de fornisseur et hop, VLC fonctionne.
Et merci à tous.