Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: Réinstallation, embrouilles codecs et Packman (Lu 808 fois) sujet précédent - sujet suivant

Réinstallation, embrouilles codecs et Packman

Bonsoir,

Avant-hier soir j'ai changé le SSD de ma tour et j'ai réinstallé Tumbleweed. J'ai voulu ensuite réinstaller les codecs multimédias avant d'aller me coucher avec l'idée de finir la configuration le lendemain. Il était tard et je suis passé (pourquoi?!) par la procédure One-Click de cette page : https://opensuse-community.org/

Je ne sais pas si j'ai fait quelque chose de mal à un moment donné mais j'ai constaté que la liste des paquets provenant de Packman sur ma tour différait de celle que j'ai sur mon ThinkPad où est également installé Tumbleweed, notamment entre autres par la présence nouvelle du paquet ffmpeg-5-mini-libs.

Impossible de lire certaines vidéos YouTube sur ma tour avec ça et sans certains paquets manquants visiblement.

J'ai désinstallé ce paquet, ce qui a eu pour effet de m'en installer automatiquement d'autres, de rétablir une correspondance plus juste des paquets provenant de Packman sur mes deux ordis, et de pouvoir tout lire sur YouTube. Bien!

Il demeure encore une petite différence au niveau des paquets Packman entre les deux installations : sur ma tour et ma nouvelle installation donc, j'ai deux paquets en plus : libvulkan_intel et Mesa-vulkan-device-select . Qui dit vrai entre les deux installations et à quoi ça me sert d'avoir ces deux là en plus sur ma tour?

Pour info, une nouvelle installation de Tumbleweed aujourd'hui installe automatiquement le nouveau dépôt Open H.264 Codec. Personnellement, je l'ai conservé mais je l'ai désactivé en attendant (rend-il tous les services espérés?).

Celui-là ajoute en plus un peu à la confusion je trouve car ce n'est déjà pas toujours simple de s'orienter dans la documentation éclatée, avec des variantes selon la langue, et les ressources communautaires, les uns et les autres ne donnant pas toujours exactement les mêmes consignes pour installer les codecs. Ce n'est pas vraiment une critique car je pense sincèrement qu'il y a de gros efforts derrière tout ça mais des fois, en tant que lecteur, on est un peu paumé.

Une commande qui m'a été bien utile pour lister tous les paquets installés de Packman et pour pouvoir comparer entre mes deux ordis (remplacer packman par le nom exact du dépôt chez vous, packman repository, Packman, ect) :

zypper se -i -r packman

Et si vous avez une idée pour libvulkan_intel et Mesa-vulkan-device-select ... pourquoi je me les ramasse et quel est leur utilité?

Re : Réinstallation, embrouilles codecs et Packman

Répondre #1

libvulkan_intel - Mesa vulkan driver for Intel GPU

Mesa-vulkan-device-select - Vulkan layer to select Vulkan devices provided by Mesa

Si vous n'avez pas de processeur Intel, ils sont inutiles. Pour Youtube, vérifiez que tous les paquets viennent de Packman. le plus simple est de passer par Yast->Vue->Dépôts->Packman Repository et de cliquer sur "Remplacer les paquets système par ceux de ce dépôt (Packman Repository) et regardez au passage si certains codecs ne sont pas installés.


Re : Réinstallation, embrouilles codecs et Packman

Répondre #2

libvulkan_intel - Mesa vulkan driver for Intel GPU

Mesa-vulkan-device-select - Vulkan layer to select Vulkan devices provided by Mesa

Si vous n'avez pas de processeur Intel, ils sont inutiles. Pour Youtube, vérifiez que tous les paquets viennent de Packman. le plus simple est de passer par Yast->Vue->Dépôts->Packman Repository et de cliquer sur "Remplacer les paquets système par ceux de ce dépôt (Packman Repository) et regardez au passage si certains codecs ne sont pas installés.

Bonsoir,

Je n'ai que des processeurs Intel, sur les deux ordis.

Pour Packman je suis bien rodé avec le changement de fournisseur, pas de souci de ce côté.

Il me semble à présent avoir tous les bons codecs sur ma tour mais honnêtement je ne connais pas l'utilité de chacun.

thierry@localhost:~> zypper se -i -r packman
Chargement des données du dépôt...
Lecture des paquets installés...

S  | Name                          | Summary                                                          | Type
---+-------------------------------+------------------------------------------------------------------+-------
i  | autopano-sift-C               | SIFT Feature Detection implementation                            | paquet
i+ | ffmpeg-4                      | Set of libraries for working with various multimedia formats     | paquet
i  | gdk-pixbuf-loader-libheif     | GDK PixBuf Loader for libheif                                    | paquet
i+ | gstreamer-plugins-bad-codecs  | Codecs/plugins for gstreamer-plugins-bad                         | paquet
i+ | gstreamer-plugins-libav       | A ffmpeg/libav plugin for GStreamer                              | paquet
i+ | gstreamer-plugins-ugly-codecs | Codecs/plugins for gstreamer-plugins-ugly                        | paquet
i+ | libavcodec57                  | FFmpeg codec library                                             | paquet
i  | libavcodec58_134              | FFmpeg codec library                                             | paquet
i  | libavcodec59                  | FFmpeg codec library                                             | paquet
i+ | libavdevice57                 | FFmpeg device library                                            | paquet
i  | libavdevice58_13              | FFmpeg device library                                            | paquet
i  | libavfilter6                  | FFmpeg audio and video filtering library                         | paquet
i  | libavfilter7_110              | FFmpeg audio and video filtering library                         | paquet
i  | libavfilter8                  | FFmpeg audio and video filtering library                         | paquet
i  | libavformat57                 | FFmpeg's stream format library                                   | paquet
i  | libavformat58_76              | FFmpeg's stream format library                                   | paquet
i  | libavformat59                 | FFmpeg's stream format library                                   | paquet
i  | libavresample3                | FFmpeg alternate audio resampling library                        | paquet
i+ | libavresample4_0              | FFmpeg alternate audio resampling library                        | paquet
i  | libavutil55                   | FFmpeg's utility library                                         | paquet
i  | libavutil56_70                | FFmpeg's utility library                                         | paquet
i  | libavutil57                   | FFmpeg's utility library                                         | paquet
i  | libdca0                       | DTS Coherent Acoustics decoder library                           | paquet
i  | libde265-0                    | Open H.265 video codec implementation - libraries                | paquet
i  | libfaac0                      | Shared library part of faac                                      | paquet
i  | libfaad2                      | Shared library part of faad2                                     | paquet
i  | libfdk-aac2                   | A standalone library of the Fraunhofer FDK AAC code from Android | paquet
i  | libgbm1                       | Generic buffer management API                                    | paquet
i  | libheif1                      | HEIF/AVIF file format decoder and encoder                        | paquet
i  | libopencore-amrnb0            | Shared library part of opencore-amr                              | paquet
i  | libopencore-amrwb0            | Shared library part of opencore-amr                              | paquet
i  | libpostproc54                 | FFmpeg post-processing library                                   | paquet
i  | libpostproc55_9               | FFmpeg post-processing library                                   | paquet
i  | libpostproc56                 | FFmpeg post-processing library                                   | paquet
i  | libquicktime0                 | Library for Reading and Writing Quicktime Movie Files            | paquet
i  | librist4                      | Development files for librist                                    | paquet
i  | librtmp1                      | RTMP Stream Dumper Library                                       | paquet
i  | libswresample2                | FFmpeg software resampling library                               | paquet
i  | libswresample3_9              | FFmpeg software resampling library                               | paquet
i  | libswresample4                | FFmpeg software resampling library                               | paquet
i  | libswscale4                   | FFmpeg image scaling and colorspace/pixel conversion library     | paquet
i  | libswscale5_9                 | FFmpeg image scaling and colorspace/pixel conversion library     | paquet
i  | libswscale6                   | FFmpeg image scaling and colorspace/pixel conversion library     | paquet
i  | libvlc5                       | Shared code for the VLC media player program                     | paquet
i  | libvlccore9                   | Shared code for the VLC media player program                     | paquet
i  | libvo-amrwbenc0               | VisualOn AMR-WB encoder library                                  | paquet
i  | libvulkan_intel               | Mesa vulkan driver for Intel GPU                                 | paquet
i  | libx264-164                   | A free h264/avc encoder - encoder binary                         | paquet
i  | libx265-199                   | A free H265/HEVC encoder - encoder binary                        | paquet
i  | libxvidcore4                  | Shared library libxvidcore                                       | paquet
i  | Mesa                          | System for rendering 3-D graphics                                | paquet
i  | Mesa-dri                      | DRI plug-ins for 3D acceleration                                 | paquet
i  | Mesa-gallium                  | Mesa Gallium GPU drivers                                         | paquet
i  | Mesa-libEGL1                  | EGL API implementation                                           | paquet
i  | Mesa-libGL1                   | The GL/GLX runtime of the Mesa 3D graphics library               | paquet
i  | Mesa-libglapi0                | Free implementation of the GL API                                | paquet
i  | Mesa-libva                    | Mesa VA-API implementation                                       | paquet
i  | Mesa-vulkan-device-select     | Vulkan layer to select Vulkan devices provided by Mesa           | paquet
i  | vlc                           | Graphical media player                                           | paquet
i  | vlc-codec-gstreamer           | GStreamer integration for the VLC media player                   | paquet
i+ | vlc-codecs                    | Additional codecs for the VLC media player                       | paquet
i  | vlc-lang                      | Translations for package vlc                                     | paquet
i  | vlc-noX                       | VLC without X dependencies                                       | paquet
i  | vlc-qt                        | Qt interface for the VLC media player                            | paquet
i  | vlc-vdpau                     | Additional vdpau codecs for the VLC media player                 | paquet

 

Re : Réinstallation, embrouilles codecs et Packman

Répondre #3
Bon, j'ai essayé d'en savoir un peu plus sur Vulkan. API graphique, moteur de rendu graphique, ect ... OpenGL, DirectX (Microsoft), ect. Tout ça me parle un peu, de loin. Vulkan serait dans la lignée OpenGL, d'accord. Les joueurs et les concepteurs 3D dont je ne fais pas partie sont certainement attentifs à tout ça et toujours au courant des évolutions (moi pas donc).

À priori, matériellement, je ne suis plus dans le coup non plus sur mes deux ordis avec mes processeurs Intel Haswell qui supporteraient partiellement et très mal Vulkan. Le Wiki d'openSUSE me le confirme sans ambiguïté  : https://en.opensuse.org/Vulkan

La question demeure : pourquoi je me retrouve avec ces deux paquets, libvulkan_intel et Mesa-vulkan-device-select, présents sur une installation et pas sur l'autre? Retrancher d'un côté ou ajouter de l'autre?

J'ai décidé de rajouter sur la plus ancienne installation, partant du principe que je les ai récupérés sans quasiment rien faire sur la nouvelle à peine modifiée, et en dépit du fait que je sois tricard chez Vulkan sur mes deux ordis (cela m'atteint très moyennement à vue de nez). Du gros pifomètre en somme!  :))

Je passe en résolu.