Aller au contenu principal
Sujet: plus d'internet !!!  (Lu 1741 fois) sujet précédent - sujet suivant

Re : plus d'internet !!!

Répondre #15
Donne le retour de (en root):
# traceroute 8.8.8.8

Si le paquet "traceroute" n'est pas installé, fais un zypper install, et tu valides (puis tu relances la commande précédente):
sudo zypper in traceroute

Voilà ce que ça donne :
traceroute 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
send: Opération non permise
Lances-la commande en root…


J'étais bien en root !!!

Re : plus d'internet !!!

Répondre #16
Hum.  ;)
Ce n'est pas normal ça.

Que te donne (en root):
# traceroute 192.168.1.1

Re : plus d'internet !!!

Répondre #17
@Mahanand
tu as lancé la commande traceroute avec "sudo" , ou bien en root ? Ce n'est pas tout à fait la même chose.
Je ne dis pas que tu'as fait, mais comme ton retour est imprécis, c'est flou…

Lance en root la commande et donne le retour en "quotant" (avec des balises code):
# traceroute 8.8.8.8
Qu'on soit fixé, sinon il manque des infos.

Chez moi, ça donne:
thierry@toto-PC:/etc> su
Passwort:
toto-PC:/etc # traceroute 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
 1  kabelbox (192.168.0.1)  2.409 ms  3.103 ms  3.734 ms
 2  * * *
 3  ip5886ea5b.static.kabel-deutschland.de (88.134.234.91)  18.305 ms  18.307 ms ip5886ea59.static.kabel-deutschland.de (88.134.234.89)  22.170 ms
 4  145.254.3.192 (145.254.3.192)  22.281 ms 145.254.3.196 (145.254.3.196)  22.172 ms 145.254.3.192 (145.254.3.192)  22.289 ms
 5  145.254.2.215 (145.254.2.215)  28.371 ms 145.254.2.217 (145.254.2.217)  26.507 ms 145.254.2.215 (145.254.2.215)  26.554 ms
 6  145.254.2.217 (145.254.2.217)  28.315 ms  15.439 ms 145.254.2.215 (145.254.2.215)  18.790 ms
 7  72.14.216.250 (72.14.216.250)  15.232 ms 72.14.194.138 (72.14.194.138)  23.938 ms  23.788 ms
 8  * * *
 9  dns.google (8.8.8.8)  19.937 ms  20.905 ms  20.662 ms
toto-PC:/etc #


Re : plus d'internet !!!

Répondre #19
Bonjour,

Bon je continue à trouver ça très bizarre que tu n'aies pas de carte wifi sur ton portable. (ou sur ton fixe?).
Tu peux m'en dire plus sur ta config? quel pc? acheté où? vieille carlingue ou récent?

Big thanx from Mister Lucky.(mais où est Averell?)

 

Re : plus d'internet !!!

Répondre #20
@denebe
Voici ce que ça donne
papaya@linux-6e3s:~> su
Mot de passe :
linux-6e3s:/home/papaya # sudo traceroute 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
send: Opération non permise
linux-6e3s:/home/papaya # traceroute 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
send: Opération non permise
linux-6e3s:/home/papaya # traceroute 192.168.1.1
traceroute to 192.168.1.1 (192.168.1.1), 30 hops max, 60 byte packets
 1  * * *
 2  * * *
 3  * * *
 4  * * *
 5  * * *
 6  * * *
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *

c'est bizarre non ???

Re : plus d'internet !!!

Répondre #21
@Mahanand

super, refais les deux derniers traceroute mais avec l'option "-I" (un i majuscule) (comme écris ici), et donne les retours.

Oui, j'essaie d'écarter tout ce qui à attrait au réseau en lui-même, ton réseau local semble fonctionner correctement, tu peux pinguer ta passerelle et la table de routage semble aussi correct.

Lorsque tu pingues une ip internet (ping echo request), tu ne reçois pas de "ping echo reply", mais la commande est autorisée. Deux possibilités ici, soit ça vient de après ton ordinateur (la passerelle, ou derrière), soit une configuration de ton ordinateur qui empêche par exemple les ping reply autres que ceux ciblant ta passerelle, je penche plus pour cette deuxième hypothèse.

Lorsque tu veux utiliser traceroute avec l'ip de ta passerelle: il n'y a aucun retour de la passerelle, alors que tu peux recevoir des paquets "ping echo reply". Fais-bien les commandes traceroute avec -I (c'est important). Si tu veux utiliser traceroute avec une ip internet, alors son utilisation est prohibée (not permitted). Sur ce point, je penche plus vers un logiciel de sécurité qui bloque son utilisation, un parefeu (iptables ?) ou selinux, apparmor ou bien une configuration exotique qui fait que ça bloque.

Ce n'est pas facile, il faut chercher, ça peut prendre un certain temps.

Que te donne:
# iptables -L

PS: c'est quoi ta passerelle par curiosité ? Elle travaille en ipv6 aussi? Je n'en suis pas certain (parenthèse fermée).
PS2: Quel est ton OS ?
PS3: Donne un peux l'historique de ta machine, ça marchait avant ? Décris un peu ton environnement, y-a-t-il d'autres machines, fonctionnent-elles ? Comment sont elles reliées ?

Re : plus d'internet !!!

Répondre #22
Je trouve ces deux sorties l'une avec l'autre (ensemble) assez intéressantes.

Voilà ce que ça donne :
ping -c 4 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) octets de données.
64 octets de 192.168.1.1 : icmp_seq=1 ttl=64 temps=0.487 ms
64 octets de 192.168.1.1 : icmp_seq=2 ttl=64 temps=0.348 ms
64 octets de 192.168.1.1 : icmp_seq=3 ttl=64 temps=0.455 ms
64 octets de 192.168.1.1 : icmp_seq=4 ttl=64 temps=0.345 ms

--- statistiques ping 192.168.1.1 ---
4 paquets transmis, 4 reçus, 0% packet loss, time 3079ms
rtt min/avg/max/mdev = 0.345/0.408/0.487/0.063 ms

linux-6e3s:/home/papaya # traceroute 192.168.1.1
traceroute to 192.168.1.1 (192.168.1.1), 30 hops max, 60 byte packets
 1  * * *
 2  * * *
 3  * * *
 4  * * *
 5  * * *
 6  * * *
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *
c'est bizarre non ???
Voilà ce que dit le man du traceroute:
→ If there is no response within a 5.0 seconds (default), an "*" (asterisk) is printed for that probe.

Chez moi, avec la passerelle juste derrière, quand j'utilise traceroute, je n'ai qu'un saut et c'est normal.
toto-PC:/home/thierry # traceroute 192.168.0.1
traceroute to 192.168.0.1 (192.168.0.1), 30 hops max, 60 byte packets
 1  kabelbox (192.168.0.1)  3.568 ms  4.304 ms  5.224 ms

Alors que chez toi, ça fonctionne, tu es autorisé à utiliser traceroute, mais il n'y a aucune réponse. Et à partir du 30ème saut (hop ou ttl), ça s'arrête automatiquement, mais ce dernier point est normal.

PS: refais bien les traceroute avec l'option -I, comme je te l'ai rappelé dans mon précédent message.

Il faut réfléchir…  :)