Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: problème après mise à jour dernier kernel - Leap 15.3 (Lu 982 fois) sujet précédent - sujet suivant

problème après mise à jour dernier kernel - Leap 15.3

Bonjour,

attention, il y a apparemment un bug avec la dernière mise à jour kernel:
Version            : 5.3.18-150300.59.43.1

Je me suis retrouvé avec un écran noir.

https://forums.opensuse.org/showthread.php/565718-Repair-after-faulty-kernel-update
https://forums.opensuse.org/showthread.php/565749-Boot-problem-after-latest-kernel-update-today
https://bugzilla.opensuse.org/show_bug.cgi?id=1195142

J'ai booté avec la version précédente pour à nouveau accéder à ma session…

Re : problème après mise à jour dernier kernel - Leap 15.3

Répondre #1
Bonjour denebe,

Vite fait car je dois sortir : je ne rencontre pas ce souci d'écran noir avec la dernière mise à jour du kernel.

À suivre...

Re : problème après mise à jour dernier kernel - Leap 15.3

Répondre #2
Même problème, après le choix dans grub, impossible de charger ramdisk !!! et écran noir, heureusement on peut booter sur version précédente !!!
Les liens fournis ne mènent à rien, pas de réponse qui aide /...

Re : problème après mise à jour dernier kernel - Leap 15.3

Répondre #3
Pas de souci non plus avec ce kernel. Un problème de pilote graphique ?

Re : problème après mise à jour dernier kernel - Leap 15.3

Répondre #4
no soucis

Re : problème après mise à jour dernier kernel - Leap 15.3

Répondre #5
Merci pour vos retours.

oui, on n'est clairement pas tous touché.

Ici un post en allemand: https://www.opensuse-forum.de/thread/65441-nach-update-startet-opensuse-nicht-mehr/

Selon tous les posts que j'ai lus, il semble qu'uniquement quelques cartes Radeon soient impactées. C'est le cas chez moi: le PC sur lequel j'ai eu l'écran noir après le grub est équipé avec une Radeon.


Je vais désinstaller ce kernel puis le bloquer.

Re : problème après mise à jour dernier kernel - Leap 15.3

Répondre #6
workaround :
As a workaround, you can simply copy the old radeon module file from
> 5.3.18-59.40 to *-43, e.g.
>   # mkdir /lib/modules/5.3.18-*.43-default/updates
>   # cp
> /lib/modules/5.3.18-*.40-default/kernel/drivers/gpu/drm/radeon/radeon.ko*
> /lib/modules/5.3.18-*.43-default/updates/
>   # depmod 5.3.18-150300.59.43-default
>   # mkinitrd
ou alors attendre un patch et booter sur un ancien kernel en attendant

Re : problème après mise à jour dernier kernel - Leap 15.3

Répondre #7
uname -r
5.3.18-150300.59.43-default
lspci | grep VGA
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Trinity [Radeon HD 7600G]
Pas de soucis pour moi.
Est-ce que la version 5.3.18-150300.59.43.1 est la même que 5.3.18-150300.59.43-default ?


Re : problème après mise à jour dernier kernel - Leap 15.3

Répondre #9
Yast Software ! C'est vrai ! Je ne pense pas à utiliser yast* En général, je fais tout avec le terminal, habitude prise avec Archlinux …

Re : problème après mise à jour dernier kernel - Leap 15.3

Répondre #10
J'ai essayé le workaround, sans succès. C'est possible que je m'y prenne mal.

J'ai fait comme ceci:
thierry@toto-PC:/lib/modules> su
Passwort:
toto-PC:/lib/modules # mkdir /lib/modules/5.3.18-*.43-default/updates
mkdir: das Verzeichnis „/lib/modules/5.3.18-*.43-default/updates“ kann nicht angelegt werden: Datei oder Verzeichnis nicht gefunden
toto-PC:/lib/modules # ls
5.3.18-150300.59.43-default  5.3.18-57-preempt     5.3.18-59.19-default  5.3.18-59.27-preempt  5.3.18-59.37-default  5.3.18-59.40-preempt  5.3.18-lp152.54-default  5.3.18-lp152.78-default
5.3.18-150300.59.43-preempt  5.3.18-59.16-default  5.3.18-59.19-preempt  5.3.18-59.34-default  5.3.18-59.37-preempt  5.3.18-59.5-default   5.3.18-lp152.75-default  5.3.18-lp152.78-preempt
5.3.18-57-default            5.3.18-59.16-preempt  5.3.18-59.27-default  5.3.18-59.34-preempt  5.3.18-59.40-default  5.3.18-59.5-preempt   5.3.18-lp152.75-preempt
toto-PC:/lib/modules # mkdir /lib/modules/5.3.18-150300.59.43-default/updates   
toto-PC:/lib/modules # cp /lib/modules/5.3.18-59.40-default/kernel/drivers/gpu/drm/radeon/radeon.ko.xz /lib/modules/5.3.18-150300.59.43-default/updates/
toto-PC:/lib/modules # depmod 5.3.18-150300.59.43-default
toto-PC:/lib/modules # mkinitrd
Creating initrd: /boot/initrd-5.3.18-150300.59.43-default
dracut: Executing: /usr/bin/dracut --logfile /var/log/YaST2/mkinitrd.log --force /boot/initrd-5.3.18-150300.59.43-default 5.3.18-150300.59.43-default
dracut: dracut module 'nvmf' will not be installed, because command 'nvme' could not be found!
dracut: dracut module 'biosdevname' will not be installed, because command 'biosdevname' could not be found!
dracut: dracut module 'nvmf' will not be installed, because command 'nvme' could not be found!
dracut: *** Including module: bash ***

retour avec l'ancien kernel !

Re : problème après mise à jour dernier kernel - Leap 15.3

Répondre #11
;)
l'écran c'est figé a 1 seconde du boot, reboot ok.

> uname -r
5.3.18-150300.59.43-default
 lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Curacao PRO [Radeon R7 370 / R9 270/370 OEM]

Re : problème après mise à jour dernier kernel - Leap 15.3

Répondre #12
@denebe : salut. tu n'as peut être pas tort. Sinon,tu collectionnes les noyaux? :)

Re : problème après mise à jour dernier kernel - Leap 15.3

Répondre #13
Les noyaux, je ne savais pas que j'en avais autant  :) Je pensais n'en avoir que deux.
thierry@toto-PC:~> rpm -qi kernel-default
Name        : kernel-default
Version     : 5.3.18
Release     : 59.40.1


Name        : kernel-default
Version     : 5.3.18
Release     : 150300.59.43.1


Dans Yast aussi il n'y en a que deux (kernel-default…)
=================================================

Sinon pour info:
# lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Redwood LE [Radeon HD 5550/5570/5630/6390/6490/7570]

Re : problème après mise à jour dernier kernel - Leap 15.3

Répondre #14
Les noyaux, je ne savais pas que j'en avais autant  :) Je pensais n'en avoir que deux.

Apparemment, quand on purge les kernels, ce que je ne manque pas de faire à chaque maj du kernel, ça ne fait pas le ménage dans les modules car j'ai la même chose que toi dans /lib/modules/

Il y a peut-être une raison à cela même si ça ne me paraît pas logique.