Aller au contenu principal

Sujets

Cette espace vous permet de voir toutes les Sujets réalisées par ce membre. Vous ne pouvez voir que les Sujets réalisées dans les espaces auxquels vous avez accès.

Sujets - Chumi

1
Programmes et logiciels / Discover à nouveau fonctionnel sur Leap 15.3 KDE
Bonjour,

Consécutivement à la mise à niveau de Leap 15.2 vers 15.3 (KDE), nous avions constaté un sérieux dysfonctionnement de Discover plus ou moins paralysé par l'absence de connexion internet selon lui (alors que la connexion était effective bien sûr). Cela entraînait aussi un sérieux dysfonctionnement de l'applet des mises à jour de KDE, liée à Discover.

Après les toutes récentes et copieuses mises à jour de Leap, Discover ne me signale plus d'absence de connexion et semble à nouveau fonctionner normalement.

Vous confirmez la même chose chez vous (utilisateurs de Leap KDE)?

Concernant l'applet des mises que j'avais désactivée, je ne suis pas chaud pour la réactiver car la ligne de commande offre quand même une meilleure lisibilité et certainement un fonctionnement moins aléatoire.

Ceci dit le retour de Discover est appréciable pour les nouveaux utilisateurs qui veulent découvrir une partie de la panoplie des logiciels.
2
Programmes et logiciels / Leap 15.3, Packman et VLC
Bonsoir,

J'ai remarqué que le référentiel Packman pour Leap 15.3 est dépourvu d'une version stable de VLC et ne propose qu'un paquet vlc-beta. Un oubli?

En attendant c'est gênant, surtout pour un nouvel utilisateur d'openSUSE car s'il installe VLC, il installe la version stable des dépôts officiels. Et s'il procède à un changement de fournisseur des paquets système vers ceux de Packman avec la commande :

zypper dup --allow-vendor-change --from packman

Il devra résoudre un problème, contradictoire dans l'énoncé et muet sur les conséquences (l'installation in fine de vlc-beta) :

Chargement des données du dépôt...
Lecture des paquets installés...
Calcul de la mise à niveau de la distribution...

Problème : le/la vlc-3.0.13-bp153.1.1.x86_64 installé(e) nécessite 'vlc-noX = 3.0.13-bp153.1.1', mais cette condition ne peut pas être remplie
 Solution 1 : Les actions suivantes seront exécutées :
  conserver l'élément vlc-noX-3.0.13-bp153.1.1.x86_64 obsolète
  conserver l'élément vlc-qt-3.0.13-bp153.1.1.x86_64 obsolète
 Solution 2 : désinstallation de vlc-3.0.13-bp153.1.1.x86_64
 Solution 3 : casser vlc-3.0.13-bp153.1.1.x86_64 en ignorant certaines de ses dépendances

Choisir une des solutions ci-dessus en tapant son numéro ou bien annuler en tapant 'a' [1/2/3/a/d/?] (a):

Je ne sais pas quoi penser de cette version bêta de VLC mais en tout cas je trouve que ce n'est pas top d'échouer là dessus dans le cadre de Leap. En attendant j'ai remplacé VLC par SMPlayer, pour moi ça peut le faire, mais bon... j'espère que ça va bouger du côté de Packman car ça peut refroidir un nouvel utilisateur qui tient à VLC.
3
Programmes et logiciels / darktable 3.6, version été 2021, est sortie mais attention sur Leap 15.3
Bonsoir,

Les nouvelles versions du logiciel darktable sont attendues et sont désormais des événements  pour un certain nombre de photographes amateurs mais aussi professionnels, convaincus ou pas par le logiciel libre, darktable étant installable gratuitement sur GNU/Linux, Mac ou Windows.

Ce sont aussi des événements autrement importants et même plus importants pour les utilisateurs d'une distribution Linux qui pour satisfaire leur besoin en matière de traitement d'images photographiques numériques, disposent d'un moindre choix de logiciels. La tentation d'essayer une nouvelle version d'un logiciel phare à notre portée dans le domaine est d'autant accrue.

darktable 3.6, version été 2021, vient donc de sortir. Je n'ai pas encore pris connaissance des nouveautés et je ne pense pas être assez qualifié pour en faire une critique objective, mais j'ai immédiatement été tenté  d'installer cette nouvelle version et c'est à ce sujet que je veux mettre en garde, tout au moins sur Leap 15.3.

Version officielle openSUSE Leap 15.3 : darktable 3.4.1

Le dépôt recommandé par les développeurs de darktable : graphics:darktable

1/ Dans les paquets expérimentaux Leap 15.3 ici : https://software.opensuse.org/package/darktable

L'installation en 1 clic tente de configurer de nouveaux dépôts SLE dont nous n'avons que faire à priori. À éviter dans l'immédiat et à ce jour pour un nouvel utilisateur d'openSUSE.

2/ L'installation experte, celle indiquée par les devs de darktable, renvoie ici : https://software.opensuse.org/download/package?package=darktable&project=graphics%3Adarktable

Si vous cliquez sur openSUSE, il n'y a pas de choix pour openSUSE Leap 15.3.

Il faut cliquer sur SUSE SLE pour atterrir sur ce qui nous parle : un lien One Click Leap 15.3, quand même assez surprenant ici.

Compte tenu de la confusion, je ne sais pas à quelle niveau elle se situe en raison des nouvelles orientations de la distribution, et compte tenu du point 1/ sur l'installation en 1clic, je pense qu'il est recommandé de passer par Ajouter le dépôt et installer manuellement.

Précédé de sudo éventuellement :

zypper addrepo https://download.opensuse.org/repositories/graphics:darktable/openSUSE_Leap_15.3/graphics:darktable.repo
zypper refresh
zypper install darktable

Pour le changement de fournisseur :

zypper dup --allow-vendor-change --from graphics_darktable

Ah oui! J'allais oublier... ça fonctionne  :D
5
Général / Mise à niveau et prise de poids
Bonjour,

Ne vous méprenez pas! je ne suis pas un boxeur qui cherche à monter de catégorie  :)) et concernant ce qui nous intéresse principalement sur ce forum, mon intention serait plutôt de jouer dans la catégorie supérieure en restant svelte, quelle folle ambition!

Je m'explique : Après la mise à niveau vers Leap 15.3, ma partition racine a enflé d'un peu plus de 6 Go, passant en gros de 14 Go à 20 Go. C'est beaucoup je trouve, je ne me l'explique pas et je me demande si ma partition racine d'une cinquantaine de Go peut plus ou moins récupérer son poids de forme (?).
7
Programmes et logiciels / Annonce : darktable 3.4 est sorti
Bonsoir,

darktable 3.4 est sorti le 24 décembre... comme un cadeau de Noël pour ses utilisateurs (c'est une tradition paraît-il, plutôt sympa non?).

C'est à nouveau une évolution importante de ce logiciel Open Source de traitement photographique ainsi qu'il se présente lui-même.

L'annonce sur darktable FR :  darktable 3.4 : la révolution colorimétrique continue (une refonte du logiciel a été initiée avec la version 3.0).

Pour installer cette version sur openSUSE, si vous l'estimez incontournable pour vous, darktable FR recommande ce dépôt tiers qui bien que non officiel ne nous est pas étranger ;) (paquets expérimentaux).
8
Programmes et logiciels / Sources additionnelles de paquets
Bonsoir,

Je rebondis un peu ici sur une discussion qui vient de se clore mais qui m'a intriguée sous certains rapports.

La documentation d'openSUSE répond souvent bien à mes questionnements mais elle me paraît parfois trop fragmentée pour saisir la logique globale de la distribution au regard des sources de paquets.

Je n'arrive pas en effet à hiérarchiser les sources additionnelles et leurs impacts respectifs sur la maintenance du système : Paquets communautaires et expérimentaux ou encore paquets provenant des dépôts de l'OBS? Dans quel ordre ça se joue pour garantir au mieux la stabilité (certains mots comme "expérimental" ne signifiant pas forcément plus de risques)?

Des questions analogues me viennent aussi à l'esprit quand j'envisage la mise à niveau future de la distribution (Leap bien entendu)... mais j'ai encore un peu de temps pour ça.

9
Général / Les touches magiques SysRQ et la valeur 184
Bonjour,

On peut se moquer mais pas me traiter de mytho car oui j'ai déjà réussi à planter Leap en dix jours de temps d'utilisation. Reboot sauvage (c'est pas bien d'où ce nouveau sujet) , expérimentation à l'arrache des snapshots, par bonheur ça fonctionne et je retrouve ma bonne humeur.

Les touches magiques SysRQ nom d'une pipe! Je les avais complètement oubliées celles-là, ne les ayant utilisé qu'une fois du temps de Mandrake ou Mandriva. Petit rappel : Ce sont des séquences et des combinaisons de touches pour essayer de sortir proprement d'un plantage.

Bref,  je révise la question, je constaste que ces touches magiques sont bien activées par défaut dans Leap et que par défaut il leur est attribué la valeur 184 (toutes choses vérifiables simplement dans Yast).

Cette valeur est en fait une limitation de l'usage des combinaisons de touches possibles car elles  ne sont pas anodines (elles titillent le noyau et le monsieur est rigoureux quand on s'adresse à lui).

Chez Ubuntu par exemple cette valeur est fixée par défaut à 176 et elle autorise trois actions successives à effectuer dans l'ordre.

https://doc.ubuntu-fr.org/touches_magiques

Comme on peut le lire sur cette page, 176 résulte d'une addition de valeurs équivalentes chacune à une action (attention, toutes les actions possibles ne sont pas listées dans le tableau).

Donc, par défaut chez openSUSE, avec la valeur 184, nous sommes autorisés à effectuer au moins une opération supplémentaire car je suppose qu'il y a une sorte de correspondance avec la politique d'Ubuntu à ce niveau (des opérations basiques à peu près compréhensibles pour un utilisateur lambda).

La question :  Par défaut que sommes-nous autorisés à faire pour tenter de sortir d'un plantage, comment et dans quel ordre?

J'ai essayé Alt-Sys-H pour consulter l'aide dans une console (Sys = Impr. Écran chez moi à priori), sans résultat soit dit en passant.

Maintenant, ce n'est pas vital non plus, j'avais fait une grosse boulette complètement idiote dont l'idée ne passe théoriqement pas par toutes les têtes.
10
Internet, réseaux et serveurs / Panne nationale du réseau SFR? SDB:Configure DNS :)
Panne nationale du réseau SFR sévissant depuis environ 16h30 et persistante à cette heure (23h) je crois bien.

Des serveurs DNS saturés paraît-il et des solutions de contournement qui émergent... faut changer les serveurs DNS qu'il se dit.

Une panne générale? D'habitude je lache l'affaire et je patiente. Et puis ces histoires de serveurs et de DNS, je ne suis pas trop chaud pour m'en mêler d'ordinaire (bon... vous voyez le niveau maintenant).

Sauf que je viens à peine d'installer Leap sur ma tour en ethernet, c'est rageant. Les DNS? et je fais comment moi avec mon openSUSE toute fraîche (une distribution que je découvre depuis peu sur mon netbook par ailleurs)?

La solution n'a pas tardé à venir dès ma première recherche et à ma très grande surprise ici : SDB:Configure DNS (Méthode 1). Du sur-mesure! clair, concis et qui fonctionne  :)

Bon... je me suis quand même un peu renseigné sur le serveur alternatif proposé par cette documentation (tant qu'à en jouer).
11
Sécurité / Ouverture de ports pour scanner Canon Pixma MG6650
Bonsoir,

j'ai installé ma multifonction Canon MG6650 en wifi avec le pilote propriétaire pour l'imprimante et finalement avec celui des dépôts pour le scanner (pilote MG6600 Séries, répertorié comme "non testé" mais qui fonctionne).

Si j'active le pare-feu dans Yast, tel qu'il est réglé par défaut, je communique bien avec l'imprimante mais pas avec le scanner. Je crois qu'il y a une raison objective à cela (j'ai vaguement lu un truc à ce sujet)... ceci pour dire que ce n'est pas une anomalie à priori. Et les utilisateurs d'autres distributions rencontrent la même difficulté avec ce matériel.

Bien entendu, le pare-feu désactivé, tout fonctionne à merveille.

J'ai donc fait quelques recherches et trouvé des éléments d'information chez Canon et dans des docs Linux en ligne au sujet de la librairie sane-pixma dépendante du paquet sane-backends.

Bref, pour utiliser le scanner en wifi, il faut ouvrir le port 8612 dans le pare-feu.

Honnêtement, les réseaux, le pare-feu et moi, ca fait vraiment trois. Je ne suis pas du tout à l'aise avec tout ça.

Mais bon, je suis donc retourné voir le pare-feu dans Yast et j'ai ouvert le port 8612 en TCP et UDP dans la zone "public" qui est activée par défaut je crois bien (une zone méfiante si j'ai un peu compris quelques petits trucs). Et ça fonctionne, je communique avec le scanner, le pare-feu étant activé.

Maintenant, je ne suis absolument pas certain de ne pas avoir commis de boulettes.

Si quelqu'un de plus avisé pouvait me donner son avis, je suis preneur.

Sources : Bah en fait, la page de man de sane-pixma donne l'info pour les ports (je viens de m'en apercevoir).
12
Programmes et logiciels / Maj forcée de Glibc en un clic, dangereux?
Je teste actuellement Infomaniak kDrive, un Cloud hébergé en Suisse et multiplateforme.

On peut installer une application de synchronisation qui est en AppImage pour Linux. Mais j'ai été un peu surpris de ne pas pouvoir lancer cette application en cliquant dessus sous Leap (ça passe bien sous Debian Stable par exemple, pour ne citer que cette distribution).

J'ai donc retenté mon coup en passant par le terminal et j'ai ainsi appris qu'il me manquait la glibc 2.27 (2.26 dans Leap, tout s'explique).

J'ai trouvé cette glibc 2.27 dans les paquets communautaires ici : https://software.opensuse.org/package/glibc
et je l'ai donc installée avec la solution en 1 clic.

Mon AppImage fonctionne à présent mais tout nouvel utilisateur d'OpenSUSE je ne ne mesure pas encore les conséquences de mes actes d'autant qu'en plus j'ignore complètement l'importance de cette librairie pour le système.

Bon j'ai bien vu qu'un nouveau dépôt (de la communauté donc) avait été ajouté mais je ne comprends pas pour le moment non plus comment le système gère ça.

Bref, cette manipulation est-elle dangereuse pour la stabilité du système?

Cette histoire de Cloud est assez importante pour moi car j'ai peut-être trouvé une alternative à OneDrive, à la fois intéressante et peu coûteuse.
13
Présentations / Bas le masque!
Bonsoir à tous,

Je suis le mari de la célèbre Madame Michu... il était temps que je me manifeste, surprise!

Je bricole avec Gnu/Linux depuis Mandrake, sans aucune motivation professionnelle (c'est entendu je pense), mais je suis davantage conditionné par l'univers Debian depuis un certain nombre d'années.

Ma tour actuelle est encore sous Windows (les précédentes ne l'ont pas toujours été) et je vous avoue ne pas avoir de gros souci avec cet OS (il fonctionne pour moi). Mais je suis quand même bien tenté de faire le grand ménage.

Bref, le confinement passant par là dernièrement, acquisation faite d'un portable relativement récent, j'ai fait une petite tournée des popotes (en dur pour être sûr et façon Chumi... on  oublie Slackware, Arch et Gentoo).

J'ai retardé l'approche d'openSuse (Suse a pourtant toujours été dans mon collimateur). Je me demande bien pourquoi aujourd'hui, en ayant opté pour KDE en plus? Plus de peur que de mal en somme. Je me suis lancé sur Leap ceci dit, qui me semble un choix raisonnable pour débuter et se remettre en question... avec le "Guide du débutant" d'Alionet dans l'onglet, ça aide beaucoup!  ;)

Je crois d'ailleurs avoir déjà commis quelques actions barbares, au moins une c'est sûr, avec des dépôts communautaires mais nous en reparlerons, comme d'autres choses que je découvre.

Bonne fin de soirée à tous.