Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: conflits dans les MàJ (Lu 697 fois) sujet précédent - sujet suivant

conflits dans les MàJ

Bonjour à toutes et tous
Je viens de faire des MàJ , et il y a conflit entre 9 paquets , tous en provenance de " pricipal OSS "
J'avais l'intention de verrouiller  un paquet sur les deux  pour faire ma MàJ , est faisable et cela résoudra t-il le problème  , et surtout est ce une bonne idée
   @page { size: 21cm 29.7cm; margin: 2cm } p { margin-bottom: 0.25cm; line-height: 115%; background: transparent } 
[font=monospace][color=#000000]File /usr/share/man/fr/man1/free.1.gz [/color]
  from install of
     man-pages-fr-4.2.0-1.2.noarch (Dépôt principal (OSS))
  conflicts with file from install of
     procps-lang-3.3.17-1.1.noarch (Dépôt principal (OSS))
 
 File /usr/share/man/fr/man1/pgrep.1.gz
  from install of
     man-pages-fr-4.2.0-1.2.noarch (Dépôt principal (OSS))
  conflicts with file from install of
     procps-lang-3.3.17-1.1.noarch (Dépôt principal (OSS))
 
 File /usr/share/man/fr/man1/pmap.1.gz
  from install of
     man-pages-fr-4.2.0-1.2.noarch (Dépôt principal (OSS))
  conflicts with file from install of
     procps-lang-3.3.17-1.1.noarch (Dépôt principal (OSS))
 
 File /usr/share/man/fr/man1/ps.1.gz
  from install of
     man-pages-fr-4.2.0-1.2.noarch (Dépôt principal (OSS))
  conflicts with file from install of
     procps-lang-3.3.17-1.1.noarch (Dépôt principal (OSS))
 
 File /usr/share/man/fr/man1/pwdx.1.gz
  from install of
     man-pages-fr-4.2.0-1.2.noarch (Dépôt principal (OSS))
  conflicts with file from install of
     procps-lang-3.3.17-1.1.noarch (Dépôt principal (OSS))
 
 File /usr/share/man/fr/man1/tload.1.gz
  from install of
     man-pages-fr-4.2.0-1.2.noarch (Dépôt principal (OSS))
  conflicts with file from install of
     procps-lang-3.3.17-1.1.noarch (Dépôt principal (OSS))
 
 File /usr/share/man/fr/man5/sysctl.conf.5.gz
  from install of
     man-pages-fr-4.2.0-1.2.noarch (Dépôt principal (OSS))
  conflicts with file from install of
     procps-lang-3.3.17-1.1.noarch (Dépôt principal (OSS))
 
 File /usr/share/man/fr/man8/sysctl.8.gz
  from install of
     man-pages-fr-4.2.0-1.2.noarch (Dépôt principal (OSS))
  conflicts with file from install of
     procps-lang-3.3.17-1.1.noarch (Dépôt principal (OSS))
 
 File /usr/share/man/fr/man8/vmstat.8.gz
  from install of
     man-pages-fr-4.2.0-1.2.noarch (Dépôt principal (OSS))
  conflicts with file from install of
     procps-lang-3.3.17-1.1.noarch (Dépôt principal (OSS))
 
 
 [/font]
 

Bonne journée

Re : conflits dans les MàJ

Répondre #1
Tu as la solution que je pratique: Refaire les mises à jours plus tard. Pendant ce temps, elles sont réajustées.

Re : conflits dans les MàJ

Répondre #2
Bonjour Chumi
Merci , l'idée est bonne , mais voila plus d'une semaine que je pratique comme ça , et rien ne change , et j'en suis maintenant à 2800 MàJ , c'est pour ça que je me suis décidé à demander si ma solution était " correct " , je ne voudrais pas refaire une installe sur un gros loupé
Bonne journée

Re : conflits dans les MàJ

Répondre #3
salut,perso j'ai fait les majs,passé nickel. Ça va s'arranger à la prochaine maj. Sinon tu ne fais rien et tu attends la prochaine maj


Re : conflits dans les MàJ

Répondre #5
Bonsoir Chalu
la réponse à la ligne de commande
jenrem@linux-bhnz:~> zypper info procps-lang 
Chargement des données du dépôt...
Lecture des paquets installés...
 
 
Informations sur paquet procps-lang :
-------------------------------------
Dépôt                     : Dépôt principal (OSS)
Nom                       : procps-lang
Version                   : 3.3.17-1.1
Architecture              : noarch
Fabricant                 : openSUSE
Taille une fois installé  : 752,7 KiB
Installé                  : Oui (automatiquement)
État                      : pas à jour (version 3.3.16-6.1 installée)
Paquet source             : procps-3.3.17-1.1.src
Résumé                    : Translations for package procps
Description               : 
    Provides translations for the "procps" package.
 
Installé " automatiquement " , avec quelle appli , est il possible de le savoir
@ Quoi , désolé , je n'ai pas vérifié de qui était le post précédent , et comme je venais de lire  un post de Chumi , éh bien j'ai fais association d'idée  ( un lapsus , )
Bonne soirée
Edit , " procps " c'est en rapport avec " processeur"  ??


Re : conflits dans les MàJ

Répondre #7
Bonsoir  Jtro
C'est une installation récente ou déjà ancienne , as tu trouvé des dépendances pour savoir quel paquet avait besoin de ce " lang "
je ne trouve pas le N° de version , j'ai fait
jenrem@linux-bhnz:~> cat /etc/lsb-release 
cat: /etc/lsb-release: Aucun fichier ou dossier de ce type
jenrem@linux-bhnz:~> cat /etc/*release
NAME="openSUSE Tumbleweed"
# VERSION="20210210"
ID="opensuse-tumbleweed"
ID_LIKE="opensuse suse"
VERSION_ID="20210210"
PRETTY_NAME="openSUSE Tumbleweed"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:tumbleweed:20210210"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"
DOCUMENTATION_URL="https://en.opensuse.org/Portal:Tumbleweed"
LOGO="distributor-logo"
 
Je suis allé voir ton lien Chalu , et effectivement  , il n'est pas parmi toutes les " versions " de "proc "
Bonne soirée

Re : conflits dans les MàJ

Répondre #8
c'est une installation fraîche en vm via gnome-boxes de tumbleweed.

Le paquet procps-lang  requiert évidemment procps. il provient du dépôt OSS.

Par contre procps est sur ma leap mais procps-lang n'est pas trouvable.

Pour tes conflits, ne t'inquiète pas, ça concerne man-pages.fr qui est mons à jour que le manuel en anglais.
Tu peux donc passer outre sans danger.
Avec ta commande tu cherchais ta version de tumbleweed? j'ai pas compris?
Sinon,je tourne là sur la TW du 22/02. Là j'ai encore fait une grosse maj mais je n'ai pas redémarré donc la version est encore plus récente

 

Re : conflits dans les MàJ

Répondre #9
Bonsoir Jtro
 Oui , je cherchais la version de TbWd , parce que j'avais vu ton N° de version avant de comprendre que c'était celui de "procps "
Si tu veux , ce qui me chipotais un peu , c'est que deux paquets venant du même dépôt , qui plus est " officiel " puissent être en conflits
Je vais passer les paquets mans en " locked " et je viendrai redire ( demain , ou tout à l'heure ) ce qu'il en est . J’espère que je ne serai pas obligé de le faire à partir d'une autre distrib 😱
Bonne soirée

Re : conflits dans les MàJ

Répondre #10
Bonjour à toutes et tous
J'ai , ce matin verrouillé les paquets  ( man et procps ) , au départ , seulement un de chaque ,le résultat est correct  ," ajouté au verrouillage avec succés " ,et relancé la MàJ , même résultat , le même nombre de paquets en conflits , j'ai donc verrouillé plusieurs paquets , et relancé , toujours 9 paquets en conflits
 Il existe une commande ( que je n'arrive pas à retrouver )  qui permet de ne pas charger ( exclure ) des paquets que l'on ne veut pas mettre à jour
Quelqu'un peut il me confirmer qu'elle existe bien sous openSuSE
Bonne journée

Re : conflits dans les MàJ

Répondre #11
bonjour,
As tu lu le man zypper?
--replacefiles
               Install the packages even if they replace files from other,
               already installed, packages. Default is to treat file conflicts
               as an error. --download-as-needed disables the fileconflict
               check because access to all packages filelists is needed in
               advance in order to perform the check.

cette option pourrait t'intéresser. Donc le conflit c'est qu'il qu'il existe déjà des fichiers de config ou autre pour le paquet incriminé. Par défaut zypper considère cela comme une erreur.
Perso je fais quand même la maj et zypper remplace les anciens fichiers par les nouveaux et c'est transparent. Bref je trouve que tu t'embêtes beaucoup pour pas grand chose.Ce n'est pas un reproche bien sûr. ;)
À propos des conflits:
Package File Conflicts
       File conflicts happen when two packages attempt to install files with
       the same name but different contents. This may happen if you are
       installing a newer version of a package without erasing the older
       version, of if two unrelated packages each install a file with the same
       name.

       As checking for file conflicts requires access to the full filelist of
       each package being installed, zypper will be able to check for file
       conflicts only if all packages are downloaded in advance (see
       --download-in-advance). If you are doing a --dry-run no packages are
       downloaded, so the file conflict check will skip packages not available
       in the packages cache. To get a meaningful file conflict check use
       --dry-run together with --download-only.

       As the reason for file conflicts usually is a poor package design or
       lack of coordination between the people building the packages, they are
       not easy to resolve. By using the --replacefiles option you can force
       zypper to replace the conflicting files. Nevertheless this may damage
       the package whose file gets replaced.


pour voir si tout va bien :
zypper ve

Re : conflits dans les MàJ

Répondre #12
Bonjour Jtro
OK , je vais faire , et merci de m'avoir " envoyé "sur le man , ( je n'ai vraiment pas acquis ce reflex )
Je vais donc finir cette Màj
Je ne considère pas comme un reproche quelque chose qui m'oblige à avancer un peu , donc , pas d'inquiétude sur le sujet
Bonne journée
ps , je ferai la manip en fin de journée

Re : conflits dans les MàJ

Répondre #13
Bonjour à toutes et tous
@ Jtro Voila , c'est fait , il y quelques paquets qui n'ont pas été installé , je n'ai pas eu le temps de les enregistrer  (ils défilaient trop vite )
Le résultat pour " zypper ve " , = " toutes les dépendances sont satisfaites
Merci d'avoir pris de votre temps pour m'aider
Je passe en résolu
Bonne journée