Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: Kdrive (Infomaniak) sur Tumbleweed (Lu 1843 fois) sujet précédent - sujet suivant

Re : Kdrive (Infomaniak) sur Tumbleweed

Répondre #15
@chumi :
Bonjour et meilleurs voeux !
Je ne sais si tu as résolu ton problème de "page blanche" pour la synchro avec kdrive.
Comme je te le disais, pas de souci de mon côté sous Tumbleweed.
Toutefois, j'ai créé une nouvelle session sur ma machine et là je rencontre le même problème ! J'ai pensé à un possible problème de thème mais j'ai fait plusieurs essais sur la nouvelle session, tous non concluants.
Autre chose : dans ma session,  il m'est demandé de saisir le mot de passe du portefeuille kde alors que la session nouvellement créée ce n'est pas le cas. Relation de cause à effet ?

 

Re : Kdrive (Infomaniak) sur Tumbleweed

Répondre #16
@Mirliton :

Bonsoir et tous mes vœux également pour l'année 2022, ainsi qu'à tous les participants de ce forum.

Qu'entends-tu par nouvelle session?

J'ai pour ma part créé un nouvel utilisateur sans rencontrer plus de succès. J'ai aussi installé Gnome, pas mieux (parallèlement à KDE, ce n'est pas le top ceci-dit).

J'avais aussi des doutes autour du portefeuille de KDE. Et j'en ai toujours...peut-être pour d'autres raisons : je n'ai jamais rien compris à KWallet qui semble incontournable en plus. Même avec un mot de passe à vide pour ne pas pas être sans cesse ennuyé, on voit bien que ce programme a la main sur certaines choses (dont kDrive) même si on ne lui demande rien. Je n'aime vraiment pas ça et c'est un truc qui pourrait à regret me faire remettre en question l'adoption de KDE.

Re : Kdrive (Infomaniak) sur Tumbleweed

Répondre #17
@Chumi :
Bonjour !
Par nouvelle session, j'entendais création d'un nouvel utilisateur.
Je viens de refaire un test, après la grosse mise à jour d'aujourd'hui, sans plus de succès. Je n'ai pas essayé sous un autre environnement de bureau, donc je ne peux dire si cela change quelque chose (ou pas).
Dans ma session, aucun problème ; tout est OK.
Quant à KWallet, pour l'utilisateur 1 (moi) il se lance avec kdrive ou si je lance Brave. Pour l'utilisateur 2, rien de tel. kdrive n'a pas l'air de s'en soucier et inversement. Ni Brave d'ailleurs ! Je ne vais pas chercher à comprendre pour l'instant mais çà m'interroge quand même !

Re : Kdrive (Infomaniak) sur Tumbleweed

Répondre #18
@Mirliton :

J'ai bien failli abandonné l'affaire mais l'idée que le problème se reproduise peut-être dans la future Leap (15.4), m'a poussé à insister. Je n'ai ni envie d'abandonner kDrive pour une solution plus coûteuse (je mets des limites financières à ce petit confort), ni envie de changer de distribution (à part Debian si j'y étais contraint, je ne vois pas).

Quelques questionnements déjà comme tu peux t'en rendre compte. Mais on reprend tout.

Étape 1 : nouvelle machine virtuelle Tumbleweed avec un Gnome tout propre. Problème identique.

Étape 2 : je détruis et je refais une machine virtuelle Tumbleweed avec KDE. Le problème demeure.

Étape 3 : je contacte enfin le support technique d'Infomaniak par mail, en étant le plus précis possible et en joignant des copies d'écran. C'était ce midi. Réponse obtenue dans l'après-midi, pas mal non?!

Copie de la réponse :

Citer
Merci pour votre message.

Concernant votre demande, il semblerait qu'un bug se soit glissé dans la dernière version de glibc sur certaines distributions de Linux :

https://bugs.launchpad.net/ubuntu/+source/glibc/+bug/1939993

En lançant l'app via le Terminal avec la commande : export QTWEBENGINE_CHROMIUM_FLAGS="--no-sandbox"

Devrait permettre de lancer le logiciel de manière saine.

Merci pour votre confiance. Nous restons à votre disposition.

Je ne savais pas trop comment associer cette commande avec celle de l'app et après quelques échecs je m'en suis sorti en collant un point virgule entre les deux (comme s'il s'agissait de deux commandes successives) :

export QTWEBENGINE_CHROMIUM_FLAGS="--no-sandbox" ; ./kDrive-3.2.6.20211208.AppImage 

Résultat : J'ai enfin pu me connecter via l'AppImage, configurer une synchronisation (minimale pour un test), vérifier que l'app est bien configurée pour se lancer au démarrage (elle se charge d'informer KDE), et tout compte fait, ça fonctionne et c'est pérenne (même après un redémarrage s'entend).

Maintenant il faut avoir à l'esprit que c'est une solution de contournement à propos de laquelle on peut s'interroger (no-sandbox?) même si c'est un bel effort du support technique d'Infomaniak. Peut-être à surveiller cette histoire de glibc et plus précisément de glibc 2.34 qui est bien dans Tumbleweed? Mais je n'ai rien vu de parlant à mon niveau sur Bugzilla à ce sujet.

Re : Kdrive (Infomaniak) sur Tumbleweed

Répondre #19
La suite de l'échange avec le support technique d'Infomaniak après l'avoir remercié pour sa solution :

Citer
Merci pour votre retour et content de savoir que tout est rentré dans l'ordre.

Nous espérons trouver un workaround pour la prochaine version de kDrive, la 3.3.0 actuellement en préparation.

Vu que le bug est présent sur un certain nombre de distributions utilisant cette release de glibc, cela nous gêne passablement.

Voilà, le problème est sérieusement pris en compte  :)

Edit : Je passe le fil en Sujet résolu, en partie résolu, soit! mais il existe une solution.