Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: Petit soucis d'upgrade (Lu 379 fois) sujet précédent - sujet suivant

Petit soucis d'upgrade

Bonjour à tous,
J'ai suivi ce tuto pour passer mon PC portable de la version 15.3 à la 15.4 :
https://gist.github.com/oleksis/8cb48edd682c8adf818da2d097ae2979

L'opération c'est déroulée sans aucun problème mais maintenant que je veux faire la même opération sur la tour, ça coince :

[
Citer
localhost:/home/pierrot # zypper --releasever=15.4 dup -y
Avertissement : Paramètre appliqué: $releasever=15.4
Chargement des données du dépôt...
Lecture des paquets installés...
Avertissement : Vous êtes sur le point d'exécuter une mise à niveau de distribution avec tous les dépôts activés. Assurez-vous que ces dépôts sont compatibles avant de continuer. Reportez-vous à 'man zypper' pour obtenir plus d'informations sur cette commande.
Calcul de la mise à niveau de la distribution...
22 problèmes :
Problème : problème avec l'élément gstreamer-plugins-bad-1.16.3-pm153.3.6.5.x86_64 installé
Problème : problème avec l'élément gstreamer-plugins-libav-1.16.2-pm153.2.6.x86_64 installé
Problème : problème avec l'élément gstreamer-plugins-ugly-1.16.3-pm153.3.5.5.x86_64 installé
Problème : problème avec l'élément libavcodec57-3.4.9-pm153.1.4.x86_64 installé
Problème : problème avec l'élément libavcodec58_134-4.4-pm153.2.9.x86_64 installé
Problème : problème avec l'élément libavdevice57-3.4.9-pm153.1.4.x86_64 installé
Problème : problème avec l'élément libavdevice58_13-4.4-pm153.2.9.x86_64 installé
Problème : problème avec l'élément libavfilter6-3.4.9-pm153.1.4.x86_64 installé
Problème : problème avec l'élément libavfilter7_110-4.4-pm153.2.9.x86_64 installé
Problème : problème avec l'élément libavformat57-3.4.9-pm153.1.4.x86_64 installé
Problème : problème avec l'élément libavformat58_76-4.4-pm153.2.9.x86_64 installé
Problème : problème avec l'élément libavresample3-3.4.9-pm153.1.4.x86_64 installé
Problème : problème avec l'élément libavresample4_0-4.4-pm153.2.9.x86_64 installé
Problème : problème avec l'élément libavutil55-3.4.9-pm153.1.4.x86_64 installé
Problème : problème avec l'élément libavutil56_70-4.4-pm153.2.9.x86_64 installé
Problème : problème avec l'élément libpostproc54-3.4.9-pm153.1.4.x86_64 installé
Problème : problème avec l'élément libpostproc55_9-4.4-pm153.2.9.x86_64 installé
Problème : problème avec l'élément libswresample2-3.4.9-pm153.1.4.x86_64 installé
Problème : problème avec l'élément libswresample3_9-4.4-pm153.2.9.x86_64 installé
Problème : problème avec l'élément libswscale4-3.4.9-pm153.1.4.x86_64 installé
Problème : problème avec l'élément libswscale5_9-4.4-pm153.2.9.x86_64 installé
Problème : l'élément gimp-plugins-python-2.10.12-150200.3.9.1.x86_64 installé nécessite 'gimp = 2.10.12', mais cette exigence ne peut pas être remplie

Problème : problème avec l'élément gstreamer-plugins-bad-1.16.3-pm153.3.6.5.x86_64 installé
 Solution 1 : installer gstreamer-plugins-bad-1.20.1-lp154.1.1.x86_64 du fournisseur openSUSE
en remplaçant gstreamer-plugins-bad-1.16.3-pm153.3.6.5.x86_64 du fournisseur http://packman.links2linux.de
 Solution 2 : conserver l'élément gstreamer-plugins-bad-1.16.3-pm153.3.6.5.x86_64 obsolète

Choisir une des solutions ci-dessus par son numéro ou bien sauter, recommencer ou annuler [1/2/s/r/a/d/?] (a): a
localhost:/home/pierrot #

Ce que je comprends pas, c'est que j'ai fait exactement pareil sur l'autre PC sans aucun problème (mise à jour des paquets puis suppression des dépôts non nécessaires pour ne garder que les 6 listés dans le tuto).
Du coup, je tente rien de plus en attendant le conseil des pro.
Merci pour votre aide
Pierrot

Re : Petit soucis d'upgrade

Répondre #1
Bonjour,

regarde ici: https://www.alionet.org/index.php?topic=1224.msg10628#msg10628
C'est presque le même tuto, avec deux étapes en plus, pour éviter d'avoir trop de questions. Il s'agit de la configuration de /etc/zypp/zypp.conf. Une avant la mise à niveau, et une après pour reconfigurer en mode "normal".

Je pense que ça va aider.

Re : Petit soucis d'upgrade

Répondre #2
@pierrotbj je pense que tu peux choisir la solution 1 sans aucun problème a priori.

Re : Petit soucis d'upgrade

Répondre #3
J'ai eu ça aussi  j'ai repassé tout en dépôt officiel

 

Re : Petit soucis d'upgrade

Répondre #4
Bingo ! ! !
J'ai combiné les deux méthodes mais obligé quand même dû supprimer  les plugins  gstreamer-blugins-bad et gimp-plugins-python pour que la mise à niveau puisse se dérouler en toute sérénité  8)  8)  8)
Maintenant je vais pouvoir les réinstaller si besoin.
Merci à toi Denebe

Jtro, après vérification, tout était bien installé au départ avec les dépôts officiels