Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: Une erreur de téléchargement (Lu 2375 fois) sujet précédent - sujet suivant

Une erreur de téléchargement

Bonjour,

Après une mise à jour de Tumbleweed, j'ai tout le temps ce message qui s'affiche :
Citer
Voici les détails des erreurs du gestionnaire de paquets :

Erreur de téléchargement (curl) pour 'https://download.opensuse.org/repositories/openSUSE:/Factory/snapshot/repodata/repomd.xml' :
Code d'erreur : Connection failed
Message d'erreur : Could not resolve host: download.opensuse.org
Tout semble fonctionner normalement, mais il y a juste ce message d'erreur.
A quoi sert snapshot ?
Existe-t-il une solution à ce petit souci ?

Re : Une erreur de téléchargement

Répondre #1
Salut,

C'est juste que le serveur est down pour quelques temps... en général ça ne dure pas longtemps.

Ça se produit surtout pendant les changements de version (la 15.2 va bientôt sortir).

À retenter ce soir ou demain.


à plus,
oh!rocks

Re : Une erreur de téléchargement

Répondre #2
Ce message s'affiche toujours même après 3 ou 4 mises à jour : que faire pour résoudre ce souci ?

Re : Une erreur de téléchargement

Répondre #3
bonsoir.
C'est toi qui as installé ce dépôt? apparemment il ne mène à rien ou pas grand chose. Tu peux le supprimer ou le désactiver soit en passant par yast(gestion des dépôts) ou par zypper(regarde le manuel de zypper pour trouver les commandes.

Re : Une erreur de téléchargement

Répondre #4
Bonjour,
Non, je n'ai pas installer ce dépot : apparemment il semble utile à la mise à jour de la Tumbleweed.
https://en.opensuse.org/Portal:Factory
1) Est-il utile d'avoir ce dépôts ? Il est indiqué pour la mise à jour continue de cette distribution (codebase).
2) il y a aussi une indication de snapshot dans le /etc/fstab. A quoi ça sert ?
UUID=d7f6a122-d4f0-48aa-95a0-527425017cfc  /.snapshots             btrfs  subvol=/@/.snapshots          0  0


Re : Une erreur de téléchargement

Répondre #6
Pour ce dépôt, il est possible qu'il se soit ajouté si tu as installé un logiciel téléchargé sur le net ou avec la méthode one-click install
les dépôts officiels sont ici :
https://fr.opensuse.org/D%C3%A9p%C3%B4ts_de_paquets

Pour avoir ta liste de dépôts avec les adresses, en utilisateur normal  tu fais la commande :
zypper lr -u

Re : Une erreur de téléchargement

Répondre #7
Il n'était pas utilisé donc j'ai supprimé ce dépôts mais l'erreur reste et même si je désinstalle le paquet snapper

Re : Une erreur de téléchargement

Répondre #8
les snapshot, c'est pour les sauvegardes du système
https://en.opensuse.org/Portal:Snapper
si tu as un pépin, tu peux restaurer les versions précédentes. Comme tu es sur Tumbleweed, c'est pas une bonne idée à mon avis de te supprimer cette possibilité.
snapper est installé sur mon système (Leap 15.1) et je n'ai pas de souci de dépôt.

Il faudrait que tu donnes les retours des commandes sinon on n'avancera pas.
sudo zypper refresh

te retourne une erreur aussi ?

Tu fais bien tes mises à jour en ligne de commande avec sudo zypper dup ?

Re : Une erreur de téléchargement

Répondre #9
Je fais les mises à jour avec ces 2 commandes et je lances aussi sudo zypper clean
Voici le retour de sudo zypper refresh (sans le dépôts factory : je l'ai enlevé).
jom@desktop-knvmeen:~> sudo zypper refresh
Le dépôt 'devel:languages:python' est à jour.                                  
Le dépôt 'home:jayvdb:branches:devel:languages:python' est à jour.             
Le dépôt 'home:manu15e' est à jour.                                            
Le dépôt 'openSUSE:Tumbleweed' est à jour.                                     
Le dépôt 'home:xpd259' est à jour.                                             
Le dépôt 'Packman' est à jour.                                                 
Le dépôt 'openSUSE-Tumbleweed-Non-Oss' est à jour.                             
Le dépôt 'openSUSE-Tumbleweed-Oss' est à jour.                                 
Le dépôt 'openSUSE-Tumbleweed-Update' est à jour.                              
Tous les dépôts ont été rafraichis.
Je souhaite juste savoir s'il est possible d'effacer ce message d'erreur car apparament : il y a rien d'anormal.

Re : Une erreur de téléchargement

Répondre #10
Il ne s’est pas affiché là le message ? Il s’affiche où et quand ?

Re : Une erreur de téléchargement

Répondre #11
Refais un zypper dup stp et regarde s'il te remet l'erreur.

Re : Une erreur de téléchargement

Répondre #12
Ce message s'affiche après le login quant Gnome a fini de se charger. Il est dans la fenêtre "Logiciel" de Gnome, où se trouve les 3 onglets "Explorer", installées" et "mise à jour". Les commandes zypper refresh ou zypper dup ne retourne pas ce message d'erreur.

Re : Une erreur de téléchargement

Répondre #13
Tant que zypper dup va bien,c'est essentiel.
"Logiciel" de gnome, je ne m'en sers pas de même que packagekit qui sèment un peu le bazar et rament à mort.
Quand tu fais zypper dup,pas nécessaire de faire un zypper ref avant, c'est fait par défaut.
Tu peux quand même faire un zypper ref tout seul pour rafraîchir tes dépôts sans mettre à jour ton système.

Re : Une erreur de téléchargement

Répondre #14
sudo zypper dup fonctionne bien :
jom@desktop-knvmeen:~> sudo zypper dup
Chargement des données du dépôt...
Lecture des paquets installés...
Avertissement : Vous êtes sur le point d'exécuter une mise à niveau de distribution avec tous les dépôts activés. Assurez-vous que ces dépôts sont compatibles avant de continuer. Reportez-vous à 'man zypper' pour obtenir plus d'informations sur cette commande.
Calcul de la mise à niveau de la distribution...

Rien à faire.
Il faut sans doute chercher du côté de "Logiciel" il doit conserver ce message d'erreur.
Je vais chercher un peu pour voire où les messages d'erreur sont conservés.
Si je supprimer le paquet gnome-software : ce message n'est plus affiché