Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: Zypper très lent (Lu 258 fois) sujet précédent - sujet suivant

Zypper très lent

Bonjour à tous,

J'ai un petit soucis, je trouve Zypper très lent lorsque je l'utilise. Par exemple, en tapant un Zypper search des fois il reste bloqué sur un dépôt pendant plusieurs secondes.

Ma connexion est bonne car sur une autre distrib je n'avais pas ce problème.  J'avais le résultat de la recherche rapidement.

Que puis-je faire selon vous ? Un réglage à faire ? Peut-être changer de dépôts ? Je début depuis 2 mois sous Suse donc désolé si je n'ai pas encore les bons reflexes. Mais ça progresse ça progresse  :D

Bonne soirée à tous,

Re : Zypper très lent

Répondre #1
Bonjour,

JE te rassure (ou pas) mais effectivement zypper (mais je pense que c'est surtout les dépôts) est assez lent comparé à d'autres distributions.

Exemple en fibre, je n'ai jamais vu des débits > à 5mo/S , ce qui est certes pas mal,  mais reste très loin du débit fibre que j'ai. (et là on parle du débit max)
Ce n'est pas un soucis de peering, car depuis j'ai changé de fai et j'ai exactement le même résultat.

Je pense que ça manque de miroir malheureusement.

Re : Zypper très lent

Répondre #2
Bonjour,
Je pense comme burn2 qu'il y a parfois embouteillages sur les serveurs.

Re : Zypper très lent

Répondre #3
Bonjour à tous,

Merci pour vos réponses :) Arf, cela confirme un peu mes craintes : il n'y a pas de choix de miroirs comme cela peut être le cas sur Debian par exemple ?

Bon par contre, j'ai réussi à gagner pas mal de secondes dans en désactivant l'autorefresh sur les dépôts. Cela me fait gagner pas mal de temps, sans pour autant non plus être quasi-instantané. Mais ça ira très bien. Il faut juste que je pense à faire un rafraîchissement des dépôts régulièrement.

En tout cas merci à vous pour temps accordé,

Une très bonne journée  ;)